Author Topic: [WIP][MOD][OXCE] From the Apocalypse 0.13.0  (Read 127895 times)

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #405 on: March 22, 2020, 10:58:33 pm »
new version up 0.10.2
finally vanilla farm is out. i'm still not done with this new terrain.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 259
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #406 on: March 22, 2020, 11:07:35 pm »
Thank you very much !  :)   :)

But... since several previous versions, it seems that two constants are missing in the "language" file!  ;)
I noticed it while searching in the "tree viewer"!

STR_CONVERT_SHIELD_SNALL_ALIEN
STR_ALIEN_CONTROL_CONSOLE

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #407 on: March 23, 2020, 10:08:53 pm »
STR_CONVERT_SHIELD_SNALL_ALIEN
STR_ALIEN_CONTROL_CONSOLE
thanks, will fix.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 259
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #408 on: April 01, 2020, 06:35:35 pm »
Sorry but bug !

v0.10.2
Initial : [FATAL]   OpenXcom has crashed: Unit STR_CORP_NONHOSTILE_PSI not found
Reload game, same mission : [FATAL]   OpenXcom has crashed: Item STR_HIGH_EXPLOSIVE2 not found (this object is disabled in the 'items' file)

Mission type : STR_CORP_WAREHOUSE_ASSAULT_ALERT

Log + last save : see below (second test)

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #409 on: April 01, 2020, 09:02:59 pm »
Thank you very much. Will try to fix it all in the weekend.

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.2
« Reply #410 on: April 05, 2020, 09:31:14 pm »
new version up, 0.10.4

fixed the following:
Initial : [FATAL]   OpenXcom has crashed: Unit STR_CORP_NONHOSTILE_PSI not found
Reload game, same mission : [FATAL]   OpenXcom has crashed: Item STR_HIGH_EXPLOSIVE2 not found (this object is disabled in the 'items' file)
two constants are missing in the "language" file
STR_CONVERT_SHIELD_SMALL_ALIEN
STR_ALIEN_CONTROL_CONSOLE

Offline SIMON

  • Commander
  • *****
  • Posts: 640
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #411 on: April 05, 2020, 11:08:55 pm »
Seems to be a problem with version 0.10.4-see attached.

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #412 on: April 05, 2020, 11:41:13 pm »
I don't get that error. Could be related to the newer OXCE, I'm still on 6.2, I'll have to check.
It's strange, I don't use STR_ZOMBIE nor STR_CHRYSSALID_TERRORIST in the mod.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 259
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #413 on: April 06, 2020, 11:40:03 am »
@ robin
Thanks for v0.10.4 !
Work fine with OXCE 6.4.2 !

Seems to be a problem with version 0.10.4-see attached.
Do you use/activate the Mod "Chryssalid_tweaks" ?
This Mod uses these two "units". But it is useless with this pack!
« Last Edit: April 06, 2020, 03:24:14 pm by BlackStaff »

Offline SIMON

  • Commander
  • *****
  • Posts: 640
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #414 on: April 06, 2020, 03:13:21 pm »
No other mods activated including the preset ones.

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #415 on: April 06, 2020, 09:51:40 pm »
No other mods activated including the preset ones.
still haven't tested myself but, maybe: did you have an old version of my mod already and you unzipped the new package over it (without deleting the old content first)?
if so, I suggest to delete the whole mod folder and unzip it anew.

Offline SIMON

  • Commander
  • *****
  • Posts: 640
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #416 on: April 06, 2020, 11:22:52 pm »
I already tried that and still get the same error with oxce 6.43 of 05/04/20 and 06/04/20. I have just tested with oxce 6.42 of 29/03/20 and v 0.10.4 works ok so it does seem to be the 6.43 versions of oxce.

There are unofficial nightly builds after every change.
They live on the bleeding edge.

6.4.2 is the latest official.
« Last Edit: April 06, 2020, 11:35:36 pm by SIMON »

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #417 on: April 06, 2020, 11:51:59 pm »
I have just tested with oxce 6.42 of 29/03/20 and v 0.10.4 works ok so it does seem to be the 6.43 versions of oxce.
yeah the problem seems to be related to 6.4.3.

Offline robin

  • Commander
  • *****
  • Posts: 1115
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.11.0
« Reply #418 on: April 07, 2020, 02:49:51 pm »
new version up, 0.11.0
mmmh, i need to fix the spawn nodes in the new FARMN / FARMU terrains, and fix the amount of enemies in the new mission (they're too clumped together currently). DONE
also i want to add a bunch more MCDs to the FARMU_BITS library, it's a little minimal right now.
this post will serve as a memo.
i'm SURE there is something missing somewhere, like some language entry and the like.
« Last Edit: April 12, 2020, 02:34:05 pm by robin »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6910
  • OXCE developer
    • View Profile
    • My Wiki
Re: [WIP][MOD][OXCE] From the Apocalypse 0.10.4
« Reply #419 on: April 08, 2020, 02:00:31 pm »
yeah the problem seems to be related to 6.4.3.

Code: [Select]
  - type: STR_ZOMBIE
    race: STR_ZOMBIE
    rank: STR_LIVE_TERRORIST
    armor: ZOMBIE_ARMOR
...
    standHeight: 18
    kneelHeight: 18
    value: 18
    intelligence: 3
    aggression: 2
    energyRecovery: 20
    spawnUnit: STR_CHRYSSALID_TERRORIST           # this is vanilla zombie, it needs STR_CHRYSSALID_TERRORIST which you deleted
    livingWeapon: true

You have made vanilla ruleset inconsistent.
You can either remove STR_CHRYSSALID_TERRORIST from STR_ZOMBIE like this:

Code: [Select]
units:
  - type: STR_ZOMBIE
    spawnUnit: ""

or if you don't need the vanilla zombie at all, delete it completely like this:

Code: [Select]
units:
  - delete: STR_ZOMBIE

OXCE is slowly adding more such checks to prevent inconsistencies and (unexpected) crashes...