Author Topic: [WIP][MOD][OXCE] From the Apocalypse 0.9.3  (Read 79605 times)

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #390 on: December 29, 2019, 12:00:23 am »
new version up, 0.9.2
I'm going to need an exorcist to fix research and manufacture.

@BlackStaff
tested a little and couldn't find any particular bug. Tell me if something is still wrong.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 189
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #391 on: December 29, 2019, 11:00:08 am »
All right!
For the old version the bug was particular !
In a mission I had:
- an active robot using a "vehicle" seat on board
- an inactive robot carried by a soldier

In any case, the turn ended well, but...
If the soldier activated his robot, everything went well during the mission but at the end of the mission... CTD!
I'll test with the latest version...  ;)

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #392 on: December 29, 2019, 11:26:40 am »
For the old version the bug was particular !
In a mission I had:
- an active robot using a "vehicle" seat on board
Yes, there was a "recover: true" that enabled you to load the craft with the already-active robot as a vehicle, but only in Quick Battle. I set "recover: false" and -hopefully- fixed this bug.
In my little testing I didn't get a CTD related to the robot, but I surely won't deny the possibility of it happening.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 189
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #393 on: December 30, 2019, 12:12:40 am »
Sorry but I have the same problem with the latest version 0.92!  :-[
Log + quick save in attachments :  ;)
Tks !

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #394 on: December 30, 2019, 12:06:07 pm »
Sorry but I have the same problem with the latest version 0.92!  :-[
Log + quick save in attachments :  ;)
Tks !
I get the crash too with your savegame. Are you sure you don't have other mods active? Because it says the savegame uses other mods.
I played the same type of mission (aircar in the desert vs Liskoid + spitters, using the Robo medi-kit) and I didn't get any crash. The ruleset for the stuff involved in the mission seems ok.
Will keep looking into it.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 189
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #395 on: December 30, 2019, 01:27:13 pm »
Thanks !

Are you sure you don't have other mods active?
mods:
  - active: true
    id: xcom1
  - active: true
    id: from_apoc
  - active: true
    id: Medailles
  - active: true
    id: UFOextender_Psionic_Line_Of_Fire
  - active: true
    id: Aliens_Pick_Up_Weapons
  - active: true
    id: XcomUtil_Statstrings

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #396 on: December 30, 2019, 11:08:53 pm »
alright i managed to reproduce it.
it seems to be related to the STR_BRAINSUCKER_HYBERNATED item.
maybe is it because it uses "battleType: 11" while not being an actual corpse linked to an armor? I'm going to need some help to solve this.
anyway tomorrow i won't be able to, next year!

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 189
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #397 on: December 31, 2019, 12:18:05 am »
No problemo !
Thanks !

Offline Dioxine

  • Commander
  • *****
  • Posts: 5265
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #398 on: December 31, 2019, 06:07:50 am »
maybe is it because it uses "battleType: 11" while not being an actual corpse linked to an armor?

If the game finds a BT:11 item (corpse) in battlescape, but cannot find an unit which produced it (by dying in this mission), it crashes. BT: 11 items therefore should ever only be used as actual corpses, linked to armors, and never spawned in any other way in battlescape.

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #399 on: December 31, 2019, 12:38:20 pm »
Thanks.
What battleType to use then? The item is a corpse, in the sense that it is the corpse of the creature dead from natural causes.

Also I used the same BT for items linked to MCDs:

  - type: STR_CHRYSALIS_CORPSE
    size: 0.4
    costSell: 20000
    weight: 40
    bigSprite: 140
    floorSprite: 140
    invWidth: 2
    invHeight: 3
    recoveryPoints: 5
    battleType: 11  <-----------------
    specialType: 31   <----------------
    armor: 26

Unlike the bugged item, these items are also used as effective corpses for the units (liked to armor that is).
However, when placed as MCDs, these corpses can exist without begin generated by the death of a corresponding unit. AFAIK from my testing, at the time, this did work and didn't crash the game. Some time passed I have to test again I guess...

Offline Dioxine

  • Commander
  • *****
  • Posts: 5265
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #400 on: December 31, 2019, 11:21:53 pm »
I think the MCD recovery circumvents the issue, since the item is never generated in battlescape. What type to use? If you want an item which is creature's corpse (generated on death) AND at the same time an item which you want to spawn on map - this is not possible.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 9187
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #401 on: December 31, 2019, 11:28:58 pm »
I suppose you could make a normal item which is then manufactured into the corpse.

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.2
« Reply #402 on: January 01, 2020, 11:51:03 am »
What I needed was a 'blank' (not a firearm, not a grenade, not anything else) battlescape item.
I checked the vanilla Elerium item and the solution was obvious: not defining any battleType.
I honestly thought it was required. Feel turbo dumb now. Still haven't tested but it should work.

Offline robin

  • Commander
  • *****
  • Posts: 1050
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.3
« Reply #403 on: January 01, 2020, 03:46:52 pm »
new version up, 0.9.3
bug fixed.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 189
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.9.3
« Reply #404 on: January 01, 2020, 07:26:05 pm »
new version up, 0.9.3
No alarms in the LOG! No crash!
Speed and precision! Bravo and thank you!  :)   8)