Author Topic: OXCE (OpenXcom Extended) main thread  (Read 430235 times)

Offline Rangerh

  • Colonel
  • ****
  • Posts: 114
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1140 on: July 09, 2022, 11:31:52 am »
Does not seem to be a syntax error
Code: [Select]
facilities:
  - type: STR_ACCESS_LIFT
    spriteShape: 2
    spriteFacility: 17
    lift: true
    provideBaseFunc: [BASE]
    buildCost: 300000
    buildTime: 1
    monthlyCost: 4000
    sickbayAbsoluteBonus: 0.0
    sickbayRelativeBonus: 50.0
    mapName: XBASE_00

I even added the sickbay lines to the living quarters in case but still the troops are healing at a normal rate.
Code: [Select]
  - type: STR_LIVING_QUARTERS
    requiresBaseFunc: [BASE]
    spriteShape: 1
    spriteFacility: 18
    buildCost: 400000
    buildTime: 16
    monthlyCost: 10000
    sickbayAbsoluteBonus: 0.0
    sickbayRelativeBonus: 50.0
    personnel: 50
    mapName: XBASE_01

I really don't understand why this is, i searched in case buildings were also defined somewhere else in the 40k and Rosigma folders, but no it's only in this terrain_40k.rul file from the 40k mod folder (there's no building definition in the Rosigma mod folder itself)
So i'm completely clueless at why it does not work.

Then i went to the codex (the ufopedia name for the 40k mod) and gave a look to the living quarter debug and default and noticed maybe why things are not working :

and it's the same for the access lift
Huh ?  the modification seems correct in the terrain_40k.rul but ingame it does not take them in account ?

Offline Rangerh

  • Colonel
  • ****
  • Posts: 114
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1141 on: July 09, 2022, 03:13:00 pm »
Ok, i went with a different approach, adding a "Medical Unit" facility as a submod instead of editing the facilities from 40k/Rosigma

So i have in my user\mods\ folder , one that is named "HealUP"
Inside of it i have metadata.yml
Code: [Select]
#
# metadata.yaml for Heal UP for 40k

name: "Heal UP for 40k"
version: 1.0
description: "Provide an early basic medical facitily."
author: OpenXcom

master: "40k"

I have a HealUP.rul (with intentional very low building time and very high sickbayRelativeBonus for easier testing)
Code: [Select]
facilities:
  - type: STR_EARLY_TREAT
    spriteShape: 1
    spriteFacility: 18
    buildCost: 400000
    buildTime: 1
    monthlyCost: 10000
    sickbayAbsoluteBonus: 0.0
    sickbayRelativeBonus: 50.0
    maxAllowedPerBase: 1
    mapName: XBASE_01

ufopaedia:
  - delete: STR_EARLY_TREAT
  - id: STR_EARLY_TREAT #facility
    type_id: 16
    section: STR_BASE_FACILITIES
    image_id: 01.SPK
    text: STR_EARLY_TREAT_UFOPEDIA

a Language sub folder that has the  en-US.yml
Code: [Select]
en-US:
STR_EARLY_TREAT: "Medical Unit"
STR_EARLY_TREAT_UFOPEDIA: "{NEWLINE} Provides some basic medical assistance to the base personel."

Then i enabled the mod with 40/Rosigma.
Ingame the submod works as i can build a new facility named "Medical Unit"
Spoiler:

It has codex entry
Spoiler:

But if i go to the Info then enable DEBUG and DEFAULT, it does not take in account that this building has sickbayRelativeBonus: 50.0 (i even tried other value, and even some reasonnable ones)
Spoiler:

I was wondering maybe the ufopedia/codex simply does not display the correct value but still the game apply them ?
So i checked with my high HP high wounded units, like "Vaitai Trasea" that for my save is at 60 days of recovering
Spoiler:

Then i let 4 or 5 days going, according to sickbayRelativeBonus: 50.0 , it means the trooper should be healed in max 2 days, but it is not the case, as after several days, this guy is at 55 days of recovering
Spoiler:

So at that point i'm really completely puzzled as to why it's not working, as the log does not show any error , any help please ?

« Last Edit: July 09, 2022, 03:14:52 pm by Rangerh »

Offline Delian

  • Colonel
  • ****
  • Posts: 240
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1142 on: July 09, 2022, 03:20:19 pm »
Maybe because it's "sickBay" and not "sickbay".

Offline Rangerh

  • Colonel
  • ****
  • Posts: 114
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1143 on: July 09, 2022, 04:35:42 pm »
THANK YOU !

Can't believe it was such a basic mistake, but correcting "b" into "B" worked !
Thank you a lot, not understanding why it was not working was maddening .

Offline Ethereal

  • Commander
  • *****
  • Posts: 610
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1144 on: July 11, 2022, 07:53:29 pm »
До зимы теперь ждать что-ли?

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 8563
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1145 on: July 11, 2022, 08:06:54 pm »
If the question is when comes the next update, then the answer is this month (July 2022).

Offline Juku121

  • Commander
  • *****
  • Posts: 1510
  • We're all mad here.
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1146 on: July 11, 2022, 09:55:18 pm »
Crash when trying to change (well, disable) display filter. OXCE 7.5.16, XCF 2.5 (with tweaks).

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 8563
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1147 on: July 12, 2022, 08:58:16 pm »
this is above my paygrade :) no idea how the filters work

Offline Yankes

  • Moderator
  • Commander
  • ***
  • Posts: 3158
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1148 on: July 12, 2022, 09:48:50 pm »
at least backtrack show `OpenXcom::Surface::CleanSdlSurface(SDL_Surface*)` that our code was last that thing done before crash.
This mean if whole SDL is not corrupted it could be way to avoid this.

Offline Juku121

  • Commander
  • *****
  • Posts: 1510
  • We're all mad here.
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1149 on: July 13, 2022, 02:52:04 am »
Well, if it helps any:
  • I recently moved computers and just pasted the whole OXCE install over.
  • Disabling and re-enabling filters via options.cfg still seems to work.
  • After I change filters in-game, there's heavy lag and the "do you want to keep this" box comes up for a little while before the total crash.
« Last Edit: July 13, 2022, 10:50:34 am by Juku121 »

Offline krautbernd

  • Commander
  • *****
  • Posts: 1116
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1150 on: July 13, 2022, 10:37:28 am »
Well, if it helps any:
  • I recently moved computers and just pasted the whole install over.
  • Disabling and re-enabling filters via config seems to still work.
  • After I change filters in-game, there's heavy lag and the "do you want to keep this" box comes up for a little while before the total crash.
What do you mean by "just passed the whole install over"? The whole OS or just OXCE in particular?

Have you tried a fresh install (of OXCE)?

Offline Juku121

  • Commander
  • *****
  • Posts: 1510
  • We're all mad here.
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1151 on: July 13, 2022, 10:48:55 am »
What do you mean by "just passed the whole install over"? The whole OS or just OXCE in particular?
OXCE plus the mod plus other necessities, of course. I also changed OS-s, so even if I wanted to do the first that wouldn't have worked.

Have you tried a fresh install (of OXCE)?
No, but I doubt it'd change much. A 'fresh install' of OXCE is basically pasting a few files over, anyway.

But just to satisfy my (and your) curiosity, I upgraded to 7.5.19. No change.
« Last Edit: July 13, 2022, 10:51:47 am by Juku121 »

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 8563
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1152 on: July 15, 2022, 11:54:20 am »
New OXCE v7.6 is up.

2022-07-15
QoL:
 - Added mouse wheel scrolling to Monthly Report UI: https://openxcom.org/forum/index.php/topic,10510.0.html
 - Ability to persist PL/NV/B toggles: https://openxcom.org/forum/index.php/topic,10629.msg147476.html#msg147476
 - Added Energy toggle to pathfinding preview (Options > Battlescape): https://openxcom.org/forum/index.php/topic,9556.0.html
 - Save file formatting less verbose in selected cases (functionally same, no performance gain or loss, smaller file size, easier to read by humans)

Features:
 - AI: aliens are now capable of running during escape battle action (if running enabled by armor, and 50% probability)
 - AI: aliens (leeroys only) are now capable of running during aggro if they have a lot of energy (40% of stamina or more)
 - Added support for checking required OXC engine (e.g. OXC, OXCE, FtA, etc.) - `requiredExtendedEngine` in metadata.yml
 - Removed `enforcedExtendedVersion` attribute in metadata.yml (`requiredExtendedVersion` attribute now enforces!)

Modding:
 - Ability to change tile move cost per armor: https://openxcom.org/forum/index.php/topic,11239.msg145137.html#msg145137
 - New movement type Sneaking = force walking even if you can fly (using Alt modifier): see link above
 - Ability to change cost of moving items in the inventory: https://openxcom.org/forum/index.php/topic,11240.0.html
 - Custom object counters for completed research: https://openxcom.org/forum/index.php/topic,10318.msg146284.html#msg146284
 - Craft preview: ability to reveal/not reveal the whole map: https://openxcom.org/forum/index.php/topic,10370.msg147475.html#msg147475
 - Ufopedia: unhardcoded colors for Text and TextImage articles: https://openxcom.org/forum/index.php/topic,10484.0.html
 - Ufopedia: draw armor sprite on the background: https://openxcom.org/forum/index.php/topic,10425.0.html

Scripting:
 - Ability to change movement type during battle: https://openxcom.org/forum/index.php/topic,6586.msg145244.html#msg145244
 - Ability to set negative health by script (i.e. overkill): https://openxcom.org/forum/index.php/topic,10535.msg146195.html#msg146195

Bugfixes:
 - (possible breaking change in scripts) Fixed broken fire extinguisher: https://openxcom.org/forum/index.php/topic,10522.msg145855.html#msg145855
 - Fixed trying to delete/process a research project twice: https://openxcom.org/forum/index.php/topic,10504.msg145545.html#msg145545
 - Craft preview: bugfix for crash when craft landed and craft deployed are different
 - Craft preview: bugfix: allowed to dismantle the access lift, if it's the last facility in the base: https://openxcom.org/forum/index.php/topic,6413.msg144635.html#msg144635
 - Craft preview: bugfix: check existence of the battlescape map for preview: https://openxcom.org/forum/index.php/topic,10370.msg145652.html#msg145652
 - Fixed AI using unusable weapons during xcom base defense: https://openxcom.org/forum/index.php/topic,4058.msg145954.html#msg145954
 - Civilians shouldn't destroy xcom bases (see above)
 - Fixed storage check corner case: https://openxcom.org/forum/index.php/topic,10595.0.html
 - Fixed startup checks when sound is muted: https://openxcom.org/forum/index.php/topic,10541.0.html
 - PromotionsState screen now includes in-transit soldiers if promoted (by karadoc): https://github.com/MeridianOXC/OpenXcom/commit/050b86483422e18eb861fc8c98f63df215290e12
 - lowAccuracyHitCounter fix (by Delian): https://github.com/OpenXcom/OpenXcom/commit/761a978cbbe52752ee9a2f1a46cc065fef46e587

Download: https://openxcom.org/forum/index.php/topic,5258.0.html

Ruleset validator was updated.
Wiki ruleset reference was updated.
Auto-update will be available on Windows in 2-3 weeks.
« Last Edit: April 29, 2023, 03:27:50 pm by Meridian »

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 336
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1153 on: July 15, 2022, 05:14:34 pm »
New OXCE v7.6 is up.
Thank you very much !

Offline Ethereal

  • Commander
  • *****
  • Posts: 610
    • View Profile
Re: OXCE (OpenXcom Extended) main thread
« Reply #1154 on: July 16, 2022, 04:20:07 pm »
New OXCE v7.6 is up.

Thank you for your work and update.