Author Topic: Bugs, crashes, typos & bad taste  (Read 648221 times)

Offline Stoddard

  • Colonel
  • ****
  • Posts: 485
  • in a fey mood
    • View Profile
    • Linux builds & stuff
Re: Bugs, crashes, typos & bad taste
« Reply #480 on: May 27, 2017, 07:27:04 pm »
@Solarius: it crashes "somewhere" in the lighting calculation... I can't even say where, because the stack trace looks like

Wanted to take a look out of curiosity and it doesn't crash for me on neither xenial64 or mingw, or mxe builds under wine.
Any specific steps to take?

It might be the compiler versions. My builds are all gcc 5.3+ :  5.4.0 (native, mxe 5.3.2 (mingw)  while yours is 4.9.4

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7383
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #481 on: May 27, 2017, 07:34:34 pm »
Hmm, looks like it doesn't always crash.

It crashed on me the first time I loaded it (right after clicking on Yes button in Confirm landing GUI, just before Briefing GUI).

I tried again now, first 2 attempts were without a crash, third attempt crashed again.

I have save scumming off, so I guess map issue is unlikely, I'd bet on a code issue.

It might be the compiler versions. My builds are all gcc 5.3+ :  5.4.0 (native, mxe 5.3.2 (mingw)  while yours is 4.9.4

I tested in visual studio 2017.
« Last Edit: May 27, 2017, 07:42:43 pm by Meridian »

Online Yankes

  • Commander
  • *****
  • Posts: 2727
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #482 on: May 27, 2017, 08:14:25 pm »
This all depends on how data is layout in memory, if buged region is closed to end of allocated block it will crash otherwise will access some random unused memory.

Offline Stoddard

  • Colonel
  • ****
  • Posts: 485
  • in a fey mood
    • View Profile
    • Linux builds & stuff
Re: Bugs, crashes, typos & bad taste
« Reply #483 on: May 27, 2017, 08:18:04 pm »
Okay, valgrind to the rescue!

https://lxnt.wtf/oxem/builds//massif/xfiles-valgrind.txt

Take a look at the last two records. Those happen in the lighting code, and it seems that whatever is passed as lastPount to the "calculateBlock" lambda is out of bounds - that is, outside the map.

Which, depending on what the allocator does, may crash the party, work correctly, or mess up the lightning.


Offline Dreamsicle

  • Sergeant
  • **
  • Posts: 14
    • View Profile
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #484 on: May 28, 2017, 07:35:02 am »
Noticed that the X Com Origins UFOPedia states that GiB was founded in 1997 even though the new date is December 1996.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 10508
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #485 on: May 28, 2017, 06:56:27 pm »
Good luck with the bug hunt, guys!

Noticed that the X Com Origins UFOPedia states that GiB was founded in 1997 even though the new date is December 1996.

Yeah, I have moved the date back and forth a lot. Thanks :)

Offline LuigiWhatif

  • Colonel
  • ****
  • Posts: 156
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #486 on: May 30, 2017, 05:18:24 pm »
I encountered a visual bug during the M.A.G.M.A robotics mission.  The marker for allied tanks on the mini-map was messed up and kept rotating between various glitched forms.  I have no idea how to make a gif, but here are two images as an example.  Also, after the mission I captured the one tank I stunned but I can't research it and it has no sell price.  I did not recover the wrecks of the ones I killed.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 10508
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #487 on: May 30, 2017, 08:43:11 pm »
Hmmm, it shouldn't be recoverable, but fix that.

As for the glitch... No idea what happened (nothing in my mod I think), but I'd like to know how to do that. :)

Offline LuigiWhatif

  • Colonel
  • ****
  • Posts: 156
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #488 on: May 30, 2017, 10:02:47 pm »
I also get the glitch when I used the battle creator, if you want to look for yourself.  Is it because it is a 4-space ally unit?  I think that this is the first time I've seen one.

Also, I just got an EXALT mission at the start of February, despite researching their termination at the end of December.  I'm pretty sure they should have left the spawn pool by now, so is this a bug?  I remember someone else mentioning something similar.  I'll post again if it shows up again next month.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 10508
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #489 on: May 30, 2017, 10:48:38 pm »
Oh shit... You're right. Sorry, try this hotfix.

Offline LuigiWhatif

  • Colonel
  • ****
  • Posts: 156
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #490 on: May 31, 2017, 02:10:51 am »
I downloaded the hotfix but now its causing a new problem.  This message pops up and the game closes.  When I restart XCOMFiles is disabled and trying to turn it on just causes the message again.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7383
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #491 on: May 31, 2017, 02:46:24 pm »
I encountered a visual bug during the M.A.G.M.A robotics mission.  The marker for allied tanks on the mini-map was messed up and kept rotating between various glitched forms.  I have no idea how to make a gif, but here are two images as an example. 

https://www.ufopaedia.org/index.php/SCANG.DAT

Code: [Select]
//minimap sprite index:
// * 0-2   : Xcom soldier
// * 3-5   : Alien
// * 6-8   : Civilian
// * 9-11  : Item
// * 12-23 : Xcom HWP
// * 24-35 : Alien big terror unit(cyberdisk, ...)

Civilian big units don't exist (there are no corresponding red minimap images in the spriteset)... so game just takes index 6-15... which are the funky effects you see.

EDIT: I could maybe change it to just display 4 blinking red dots, see attached
« Last Edit: May 31, 2017, 03:11:42 pm by Meridian »

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 10508
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #492 on: May 31, 2017, 06:33:01 pm »
I downloaded the hotfix but now its causing a new problem.  This message pops up and the game closes.  When I restart XCOMFiles is disabled and trying to turn it on just causes the message again.

Arrrgh! I had no idea it would prevent the mod from launching! Why do these safety measures only work when they aren't supposed to?!

Just find and remove this part from the missionScripts_Xcomfiles.rul:

Code: [Select]
  - type: VampireCastle
    firstMonth: 0
    executionOdds: 15
    missionWeights:
      0:
        STR_VAMPIRE_CASTLE: 100
    regionWeights:
      0:
        REGION_VAMPIRE_CASTLE: 100
    researchTriggers:
      STR_FOLLOW_THE_ZOMBIES: true
    useTable: false
    startDelay: 20
    randomDelay: 43500


EDIT: I could maybe change it to just display 4 blinking red dots, see attached

Sure, thanks.

Offline LuigiWhatif

  • Colonel
  • ****
  • Posts: 156
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #493 on: May 31, 2017, 06:47:34 pm »
That got it working again.  Thanks.

Offline HT

  • Colonel
  • ****
  • Posts: 455
    • View Profile
    • Email
Re: Bugs, crashes, typos & bad taste
« Reply #494 on: May 31, 2017, 10:10:01 pm »
Hello, I'm not sure if it counts as a bug, but the FAMAS rifle has a bit of an odd behavior regarding the Ufopaedia: I've been able to "research" it and acquire it for my soldiers, but it doesn't show its relevant article anywhere. Sometimes it does show up after getting Promotion 2 and "researching" similar weapons.

Another one which I believe it has been commented is that I'm given the option to investigate a "Zrbite tank"... Without having found said alien material ingame yet.