Author Topic: Bugs & Crash Reports  (Read 361153 times)

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5570
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #3120 on: February 28, 2019, 06:02:11 pm »
"OpenXcom has crashed: std::bad_alloc
More details here: D:/spiele/Dioxine_XPiratez/user/openxcom.log
If this error was unexpected, please report it to the developers."

Error message when I clicked the save button. Prevented me from making a screen shot.

We have a bug when creating a save/load list... please move all your older saves, except for the last 10-20 somewhere else in a backup directory and try again.

Out of curiosity, how many saves do you have and how big are they together?

Offline Zharkov

  • Colonel
  • ****
  • Posts: 402
    • View Profile
Re: Bugs & Crash Reports
« Reply #3121 on: February 28, 2019, 07:05:22 pm »
We have a bug when creating a save/load list... please move all your older saves, except for the last 10-20 somewhere else in a backup directory and try again.

Out of curiosity, how many saves do you have and how big are they together?

23 .sav, 2 .asav, 53.8 MB

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5570
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #3122 on: February 28, 2019, 11:33:47 pm »
23 .sav, 2 .asav, 53.8 MB

thanks, you helped discover some important issues. there will be a fix soon.

Offline Zharkov

  • Colonel
  • ****
  • Posts: 402
    • View Profile
Re: Bugs & Crash Reports
« Reply #3123 on: March 01, 2019, 08:52:25 pm »
string missing

Offline Zharkov

  • Colonel
  • ****
  • Posts: 402
    • View Profile
Re: Bugs & Crash Reports
« Reply #3124 on: March 02, 2019, 12:01:48 pm »
typo

Offline clownagent

  • Colonel
  • ****
  • Posts: 379
    • View Profile
Re: Bugs & Crash Reports
« Reply #3125 on: March 03, 2019, 10:08:40 am »
Some weapons like dart rifle and whip use "hitSound: 1".

Depending on your original files (e.g. files from GOG version) this might lead to some annoying cracking sound when using.

If you want to get rid of it you may change the ruleset "hitSound: 1" to "hitSound: 999" for these weapons.

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5570
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #3126 on: March 03, 2019, 11:37:01 am »
Some weapons like dart rifle and whip use "hitSound: 1".
Depending on your original files (e.g. files from GOG version) this might lead to some annoying cracking sound when using.
If you want to get rid of it you may change the ruleset "hitSound: 1" to "hitSound: 999" for these weapons.

GOG version uses identical sound effects as Steam version.

Also, there is no gun called "dart rifle"... did you mean "harpoon gun"?
Not sure how you define "annoying cracking" sound (maybe you can record it? so that we know what you mean), but for me it's not annoying with any combination of Steam/GOG 1.4/1.0 sound effects.

Offline clownagent

  • Colonel
  • ****
  • Posts: 379
    • View Profile
Re: Bugs & Crash Reports
« Reply #3127 on: March 03, 2019, 12:16:32 pm »
GOG version uses identical sound effects as Steam version.

Also, there is no gun called "dart rifle"... did you mean "harpoon gun"?
Not sure how you define "annoying cracking" sound (maybe you can record it? so that we know what you mean), but for me it's not annoying with any combination of Steam/GOG 1.4/1.0 sound effects.

Yes I meant harpoon rifle. (But all weapons with hitSound: 1 have the same issue)

I assumed the issue was that "hitSound: 1" is filled with "garbage" for 1.4 as is written here: https://www.ufopaedia.org/index.php/SOUND

I do not know how to record the "annoying cracking". It is very easily audible.
Maybe it is only specific to my computer or OS.

When I changed the "hitSound: 1" to another blank sound "hitSound: 999" in the piratez mod, the "cracking" was clearly gone.
So this is the fix for me.
« Last Edit: March 03, 2019, 12:22:22 pm by clownagent »

niculinux

  • Guest
Re: Bugs & Crash Reports
« Reply #3128 on: March 03, 2019, 01:05:15 pm »
I have the same issue, i own "xcom:collector's edition" that provides an enemy unknown windows version, and it's the 1.4
« Last Edit: March 05, 2019, 06:12:31 pm by niculinux »

Offline Zharkov

  • Colonel
  • ****
  • Posts: 402
    • View Profile
Re: Bugs & Crash Reports
« Reply #3129 on: March 03, 2019, 02:36:06 pm »
Live or psi capture of the Zombie Sentinel makes the game jump.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5244
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #3130 on: March 03, 2019, 06:29:50 pm »
Hitsound on harpoon gun is exactly as intended. Not supposed to be blank, lol.

Offline clownagent

  • Colonel
  • ****
  • Posts: 379
    • View Profile
Re: Bugs & Crash Reports
« Reply #3131 on: March 04, 2019, 10:07:41 am »
Hitsound on harpoon gun is exactly as intended. Not supposed to be blank, lol.

According to the Wiki, sound 1 is differently defined for different game versions. So players with game files 1.2 will experience an "empty" sound, players with game files 1.4 the "garbage" sound.

sounds from SAMPLE2.CAT    https://www.ufopaedia.org/index.php/SOUND

Code: [Select]
ref# offset length         Description
00 B8 01            02 2B         Snakeman slither
01 BD 2C            63 01  not used (empty in 1.2, garbage in 1.4)
« Last Edit: March 04, 2019, 10:10:05 am by clownagent »

Offline Mathel

  • Captain
  • ***
  • Posts: 54
    • View Profile
Re: Bugs & Crash Reports
« Reply #3132 on: March 05, 2019, 06:03:21 pm »
Playing with 1.4 version of base game.
Whenever a Dart Gun, Harpoon Gun, Harpoon Carabine or Automatic Harpoon Gun hit with any ammo that does not do a purple splash, there is a buzzing sound.
I suppose this could be the intentional sound of a harpoon, but if there is no equivalent in 1.2, that could be a problem.

Offline thevideogameraptorboggle

  • Colonel
  • ****
  • Posts: 152
    • View Profile
Re: Bugs & Crash Reports
« Reply #3133 on: March 05, 2019, 07:09:53 pm »
I'm also having difficulty opening the save and load menu. It takes a few seconds to open, but if I open it too many times in a short timeframe, like before and after an intercept, then it just hangs forever and the game softlocks. Never brings up an error message, but the only way to get out of it is by closing the game.

Offline Stoddard

  • Colonel
  • ****
  • Posts: 459
  • in a fey mood
    • View Profile
    • Linux builds & stuff
Re: Bugs & Crash Reports
« Reply #3134 on: March 05, 2019, 07:15:29 pm »
I'm also having difficulty opening the save and load menu. It takes a few seconds to open, but if I open it too many times in a short timeframe, like before and after an intercept, then it just hangs forever and the game softlocks. Never brings up an error message, but the only way to get out of it is by closing the game.


This should be fixed in recent builds. Try the 5.3