aliens

Author Topic: [WIP][MOD][OXCE] From the Apocalypse 0.15.1  (Read 133537 times)

Offline robin

  • Commander
  • *****
  • Posts: 1135
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.0
« Reply #480 on: October 10, 2021, 09:33:12 pm »
No problemo !  ;)
Thanks !

Error for 'CIV_CARGO_F': First Battle corpse item need have corpse item type

Since the OXCE 7.1 version there are some changes to do!
Example : "battleType: 11" in "items" for all armor corps...

So it's better to use an earlier OXCE version.
aaaargh
i didn't think about the new version of OXCE  :-[

Thanks for so fast!))
New release will work with previous saves?
no, I'm changing too many things at this stage.

Offline robin

  • Commander
  • *****
  • Posts: 1135
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.0
« Reply #481 on: October 10, 2021, 11:47:54 pm »
v 0.15.0 works fine in latest nightly but not in latest oxce-see attached.
Should be fixed.
Also fixed a missing ufo trajectory.
Thanks for the feedback and the patience.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 269
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #482 on: October 11, 2021, 02:01:13 am »
Sorry big crash with v0.151 & OXCE 7.1.1 !
Crash when I clicked on a "alien base" icon!
Note: this is an old game! Should we start a new campaign?

Offline The Reaver of Darkness

  • Commander
  • *****
  • Posts: 1449
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #483 on: October 11, 2021, 08:34:14 am »
Sorry big crash with v0.151 & OXCE 7.1.1 !
Crash when I clicked on a "alien base" icon!
Note: this is an old game! Should we start a new campaign?

Code: [Select]
[11-10-2021_00-57-43] [ERROR] Failed to load country STR_CANADA
[11-10-2021_00-58-39] [FATAL] A fatal error has occurred: Segmentation fault.
This indicates that the game loaded successfully even though none of the countries loaded. The game was then played for almost a minute before it crashed with a segmentation fault. My guess is that when BlackStaff clicked on the alien base, it attempted to access its region data which didn't exist.

Code: [Select]
[11-10-2021_00-57-36] [ERROR] Crossing the prime meridian in mission zones requires a different syntax, region: STR_NORTH_AMERICA, zone: 5, area: 3, lonMin: 355, lonMax: 5
[11-10-2021_00-57-36] [ERROR]   Wrong example: [350,   8, 20, 30]
[11-10-2021_00-57-36] [ERROR] Correct example: [350, 368, 20, 30]
All of the countries pulled up an invalid coordinate error, I'm guessing this is what caused them to all fail to load.

Solution: I have no idea. Wait for Robin or someone else to chime in.

Code: [Select]
[11-10-2021_00-57-32] [INFO] Active mods:
[11-10-2021_00-57-32] [INFO] - xcom1 v1.0
[11-10-2021_00-57-32] [INFO] - from_apoc v0.15.1
[11-10-2021_00-57-32] [INFO] - extra_pockets v1.0
[11-10-2021_00-57-32] [INFO] - UFOextender_Psionic_Line_Of_Fire v1.0
[11-10-2021_00-57-32] [INFO] - First_turn_TU_tweak v0.8
[11-10-2021_00-57-32] [INFO] - Medailles_UFO v2.12
« Last Edit: October 11, 2021, 08:36:13 am by The Reaver of Darkness »

Offline robin

  • Commander
  • *****
  • Posts: 1135
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #484 on: October 11, 2021, 10:34:45 pm »
I modified the world extensively, vanilla countries and cities do not exist anymore, and mission zones are changed or added (or removed).
I doubt there is a way to edit the old savegames to make them compatible with this version.
I would start a new campaign, but I must warn you that you might encounter critical bug that will stop you from completing it.

Offline BlackStaff

  • Colonel
  • ****
  • Posts: 269
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #485 on: October 11, 2021, 10:46:43 pm »
Thanks !

When starting a new campaign, I also have many alarms!
Not fatal but many!
For example, those of this type of alarm worry me a little!

[INFO]   Supressed Error for 'STR_CORP_SECURITY_F': There is live alien item but unit is not recoverable (missing armor recover)
[INFO]   Supressed Error for 'STR_ROBOTURRET_PLASMA_TERRORIST': There is live alien item but unit is not recoverable (missing armor recover)
« Last Edit: October 11, 2021, 10:49:57 pm by BlackStaff »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6968
  • OXCE developer
    • View Profile
    • My Wiki
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #486 on: October 11, 2021, 10:55:40 pm »
These are warnings, they may or may not be errors... I'll look at the check more carefully a bit later and adjust the wording to not be so scary if appropriate.

Offline robin

  • Commander
  • *****
  • Posts: 1135
  • ULTIMATE ROOKIE
    • View Profile
Re: [WIP][MOD][OXCE] From the Apocalypse 0.15.1
« Reply #487 on: October 11, 2021, 11:08:54 pm »
Thanks !

When starting a new campaign, I also have many alarms!
Not fatal but many!
For example, those of this type of alarm worry me a little!

[INFO]   Supressed Error for 'STR_CORP_SECURITY_F': There is live alien item but unit is not recoverable (missing armor recover)
[INFO]   Supressed Error for 'STR_ROBOTURRET_PLASMA_TERRORIST': There is live alien item but unit is not recoverable (missing armor recover)
Thanks. Will check everything.