Author Topic: Bugs & Crash Reports  (Read 362205 times)

Offline LytaRyta

  • Colonel
  • ****
  • Posts: 319
  • Lisbeth ;p My Engrish is easy bad, Csaba is dead!
    • View Profile
    • svetmightandmagic.cz
Re: Bugs & Crash Reports
« Reply #3075 on: February 02, 2019, 07:40:45 pm »
what are those "ranks" (Matriarch, Lord, Admiral, FleetComm.) before the names of Gals ? :o ;S

niculinux

  • Guest
Re: Bugs & Crash Reports
« Reply #3076 on: February 02, 2019, 09:14:12 pm »
what are those "ranks" (Matriarch, Lord, Admiral, FleetComm.) before the names of Gals ? :o ;S

There are the ranks of the vanilla ufo enemy unknown/ufo defence

In 0.99J11 i researched "!underground missions!" "before cavern hunting, but the latter unlocks the former...pheraps it is a bug, that is to say these mission may should be unlocked and researched once i completed the cavenr topic? Here is a save :)

I have also mada a base in indonesia but i've seen most missions (every kind of missions, progoms included) spawns in north and south america and in europe,  a few of them in asia, africa, indonesia and australia. Does it sound like a waspe of space  :'(

Edit: also, in some missions the briefing says "scratching hot" but actually in battlescape nothing happens, here a quicksave of a ratmen rodeo that is supposed to be "hot". I've seen this not happen in the "freezing cold" ones; but i think it be better double check
« Last Edit: February 02, 2019, 09:38:33 pm by niculinux »

Offline Toothless Shark

  • Sergeant
  • **
  • Posts: 35
    • View Profile
Re: Bugs & Crash Reports
« Reply #3077 on: February 02, 2019, 10:36:33 pm »
I'm getting a crash when selecting my Pirate Queen in the inventory menu before tactical battle (the one in base works fine) or during tactical combat. Other gals seem to work fine.

Snipped from the log:

[02-02-2019_21-14-32]   [FATAL]   A fatal error has occurred: Sprite UBERGAL__3__CHAIN_F39 not found
[02-02-2019_21-14-32]   [FATAL]   0x7ef470 OpenXcom::CrossPlatform::stackTrace(void*)
[02-02-2019_21-14-32]   [FATAL]   0x7f0930 OpenXcom::CrossPlatform::crashDump(void*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
[02-02-2019_21-14-32]   [FATAL]   0x401570 exceptionLogger()
[02-02-2019_21-14-32]   [FATAL]   0xb56770 MPEGaction::MPEGaction()
[02-02-2019_21-14-32]   [FATAL]   0xcfdfa0 void std::iter_swap<__gnu_cxx::__normal_iterator<OpenXcom::ScriptProcData*, std::vector<OpenXcom::ScriptProcData, std::allocator<OpenXcom::ScriptProcData> > >, __gnu_cxx::__normal_iterator<OpenXcom::ScriptProcData*, std::vector<OpenXcom::ScriptProcData, std::allocator<OpenXcom::ScriptProcData> > > >(__gnu_cxx::__normal_iterator<OpenXcom::ScriptProcData*, std::vector<OpenXcom::ScriptProcData, std::allocator<OpenXcom::ScriptProcData> > >, __gnu_cxx::__normal_iterator<OpenXcom::ScriptProcData*, std::vector<OpenXcom::ScriptProcData, std::allocator<OpenXcom::ScriptProcData> > >)
[02-02-2019_21-14-32]   [FATAL]   0xd02f40 OpenXcom::ScriptGlobal::addTagType<OpenXcom::ScriptTag<OpenXcom::RuleItem, unsigned char> >()::{lambda(unsigned long long)#1}::_FUN(unsigned long long)
[02-02-2019_21-14-32]   [FATAL]   0xbfb060 OpenXcom::Surface* OpenXcom::Mod::getRule<OpenXcom::Surface>(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::map<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, OpenXcom::Surface*, std::less<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std::pair<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const, OpenXcom::Surface*> > > const&, bool) const
[02-02-2019_21-14-32]   [FATAL]   0x646dc0 OpenXcom::Mod::getSurface(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, bool)
[02-02-2019_21-14-32]   [FATAL]   0x873110 OpenXcom::BattlescapeState::updateSoldierInfo(bool)
[02-02-2019_21-14-32]   [FATAL]   0x852860 OpenXcom::BattlescapeGame::primaryAction(OpenXcom::Position)
[02-02-2019_21-14-32]   [FATAL]   0x878f90 OpenXcom::BattlescapeState::mapClick(OpenXcom::Action*)
[02-02-2019_21-14-32]   [FATAL]   0x7e6a00 OpenXcom::InteractiveSurface::mouseClick(OpenXcom::Action*, OpenXcom::State*)
[02-02-2019_21-14-32]   [FATAL]   0x7e73b0 OpenXcom::InteractiveSurface::handle(OpenXcom::Action*, OpenXcom::State*)
[02-02-2019_21-14-32]   [FATAL]   0x7e3e20 OpenXcom::State::handle(OpenXcom::Action*)
[02-02-2019_21-14-32]   [FATAL]   0xba73b0 OpenXcom::BattlescapeState::handle(OpenXcom::Action*)
[02-02-2019_21-14-32]   [FATAL]   0x7d7060 OpenXcom::Game::run()
[02-02-2019_21-14-32]   [FATAL]   0x4016b0 SDL_main
[02-02-2019_21-14-32]   [FATAL]   0x9bd4f0 console_main
[02-02-2019_21-14-32]   [FATAL]   0x9bd610 WinMain
[02-02-2019_21-14-32]   [FATAL]   ??
[02-02-2019_21-14-32]   [FATAL]   ??
[02-02-2019_21-14-32]   [FATAL]   0x7ffadcfa3020 BaseThreadInitThunk
[02-02-2019_21-14-32]   [FATAL]   0x7ffadd5e3670 RtlUserThreadStart
[02-02-2019_21-16-30]   [FATAL]   OpenXcom has crashed: Sprite UBERGAL__3__CHAIN_F39 not found

It seems this happens no matter what armor or items i put on queen or what mission i try to do. This started happening after i updated the game from J9 to J11. I can provide save if needed

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5244
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #3078 on: February 03, 2019, 03:20:26 am »
what are those "ranks" (Matriarch, Lord, Admiral, FleetComm.) before the names of Gals ? :o ;S

Never seen/heard about such ranks

It seems this happens no matter what armor or items i put on queen or what mission i try to do. This started happening after i updated the game from J9 to J11. I can provide save if needed

Already reported, only happens if you try to strip her naked.
« Last Edit: February 03, 2019, 03:22:39 am by Dioxine »

Offline sanyaskillpro

  • Captain
  • ***
  • Posts: 89
    • View Profile
Re: Bugs & Crash Reports
« Reply #3079 on: February 03, 2019, 10:41:57 am »
In 0.99J11 i researched "!underground missions!" "before cavern hunting, but the latter unlocks the former...pheraps it is a bug, that is to say these mission may should be unlocked and researched once i completed the cavenr topic?
Its not a bug, there are 2 types of unlocking in tech tree. If it says "unlocked by:" then you only need a single researched topic to unlock this. If it says "depends on:" then you need to check all the requirements. In your case you probably had a cleared tavern cellar or recruiting lokknaars, which both unlock the underground missions.

niculinux

  • Guest
Re: Bugs & Crash Reports
« Reply #3080 on: February 03, 2019, 11:56:35 am »
Its not a bug, there are 2 types of unlocking in tech tree. If it says "unlocked by:" then you only need a single researched topic to unlock this. If it says "depends on:" then you need to check all the requirements. In your case you probably had a cleared tavern cellar or recruiting lokknaars, which both unlock the underground missions.

In fact, i accomplished an "infested cellar" mission before, thanks :)

Offline Ninawindia

  • Captain
  • ***
  • Posts: 65
  • Certified cat girl, nya~
    • View Profile
Re: Bugs & Crash Reports
« Reply #3081 on: February 04, 2019, 02:28:24 am »
Hello hello! So, umm, recruited some newbies and stuff, one of them always crashes now?  The one at the very bottom center of the base in my save..

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 8921
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #3082 on: February 04, 2019, 03:28:28 pm »
Is the offending  newbie nude? There is a bug related to that.

Offline sanyaskillpro

  • Captain
  • ***
  • Posts: 89
    • View Profile
Re: Bugs & Crash Reports
« Reply #3083 on: February 04, 2019, 05:04:19 pm »
A raider firebat from a raider gunship spawned with a rocket launcher + dagger. And he could shoot it, even though it's a strictly 2h weapon. Some kind of bug or the AI is using different rules?

Also i decided to test electric nets on him for the first time. Are they supposed to be the unlimited ammo weapon? I thought they would be like a throwing hammer, 1 use weapon for a very powerful throw.

Offline clownagent

  • Colonel
  • ****
  • Posts: 379
    • View Profile
Re: Bugs & Crash Reports
« Reply #3084 on: February 04, 2019, 10:01:19 pm »
Part of the text in the battleflag pedia entry is cut.

Offline cc

  • Colonel
  • ****
  • Posts: 244
    • View Profile
Re: Bugs & Crash Reports
« Reply #3085 on: February 04, 2019, 11:32:10 pm »
Some kind of bug or the AI is using different rules?
The AI is using different rules.
Are they supposed to be the unlimited ammo weapon?
Yes.

niculinux

  • Guest
Re: Bugs & Crash Reports
« Reply #3086 on: February 05, 2019, 09:58:28 am »
As for the bugh reported here just wanted only to  point out that it seems to happen in windows, since in linux i had no problem at all. Stronge, since in the quicksave attached i'm not using the chan outfit, but the ganger one.

Edit: it seems to happen randomly anyway; i started a brand new game on win. Dont' know whether the attached savefile is corrupted or not, maybe the usual bad luck on mine  >:(
« Last Edit: February 06, 2019, 03:43:26 pm by niculinux »

Offline Malekh

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: Bugs & Crash Reports
« Reply #3087 on: February 07, 2019, 11:08:18 am »
Had the UBERGAL__3__CHAIN_F39 not found in assassin armor - quick way for the player to avoid it is to go to a gals inventory in equipment loadout screen in base (vessel - equipment - inventory) and hit m on the offending gal's screen - this allows you to change her apparance. Doesn't fix the bug, but at least dosen't crash the game each time I want to use my pirate queen.

Offline Rince Wind

  • Colonel
  • ****
  • Posts: 488
    • View Profile
Re: Bugs & Crash Reports
« Reply #3088 on: February 07, 2019, 11:20:55 am »
Hell's Keep doesn't have a walkway through potential evil grass all around. Right side and back seem to be missing it. Could be intended, it is Hell after all. :D

Offline Ashghan

  • Colonel
  • ****
  • Posts: 102
    • View Profile
Re: Bugs & Crash Reports
« Reply #3089 on: February 08, 2019, 06:27:50 pm »
There is a problem when transferring space occupying units to a base with small amount of vault space. I transferred 10 tamed reapers to a fresh base with a burrow. They now occupy 10 space each (100 total) in the target base (even though they are in transfer), while the burrow has only 25 vaults. At days end, the transfer is still in progress, but the base checks available space (exceeded) and moves me to the forced sell/transfer screen. Even if I move all the stuff out of the base, I'm still over the capacity 100 vs 25 and I can't transfer the damned reapers because they have not arrived yet. So i'm stuck in the sell window, with only option to kill the game.

While I wouldn't consider it even a minor bug (a pretty rare situation I'm in), it could ruin someone's day (especially on ironman).