aliens

Author Topic: 40k Bug/crashes/problem´s report  (Read 102736 times)

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7492
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #300 on: November 21, 2020, 01:10:12 am »
I'm getting a Segmentation Fault for a base defense. I'm not sure how to fix it.

I attached the save. I'm also using the Exdoorminatus Chapter skin but I don't think that has anything to do with the fault.

I also attached my crash log. Thank you for the help!

No crash for me.

Where can we download the Exdoorminatus mod to test?

But most likely it is caused by the zip files you still have lying around in the mods folder... please move or delete those zip files, they will conflict with your mods.

Code: [Select]
[20-11-2020_16-17-47] [WARN] scanModZipRW(rwops, D:/Mods/Open Xcom Updated/OpenXcom/user/mods/Exdoorminatus Chapter.rar): Ignoring zip: failed finding central directory
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_cutscenes_024.zip, '40k Cutscenes/'): modId 40k_cutscenes already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_cutscenes_024.zip/40k Cutscenes/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip, '40k/'): modId 40k already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip/40k/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip, '40k StatStrings/'): modId 40k_statstrings already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip/40k StatStrings/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip, 'Blood Angels/'): modId Blood Angels already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip/Blood Angels/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip, 'Imperial Fists/'): modId Imperial Fists already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_026.1.zip/Imperial Fists/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip, '40k/'): modId 40k already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip/40k/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip, '40k StatStrings/'): modId 40k_statstrings already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip/40k StatStrings/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip, 'Blood Angels/'): modId Blood Angels already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip/Blood Angels/
[20-11-2020_16-17-47] [WARN] mapZippedMod(D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip, 'Imperial Fists/'): modId Imperial Fists already mapped in, skipping D:/Mods/Open Xcom Updated/OpenXcom/user/mods/40k_024.zip/Imperial Fists/
« Last Edit: November 21, 2020, 01:13:30 am by Meridian »

Offline narayansav

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #301 on: November 21, 2020, 03:55:15 am »
Here's the chapter reskin mod. I don't think it'll change anything but you can try.

I'm going to get rid of those zips like you asked and I'll let you know if it helps.

Thanks again!

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 636
    • View Profile
    • Email
Re: 40k Bug/crashes/problem´s report
« Reply #302 on: November 21, 2020, 03:12:11 pm »
Bases defense now are 4 height long with some changes to mcd, so probably the exdoor will not be compatible, but try desabling the mod and trying, if not I will have a look into it Monday

Offline narayansav

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #303 on: November 21, 2020, 10:20:28 pm »
No worries! I managed to fix it by moving the unused .zip files that were in the folder. The skin mod hasn't had any problems with it.

Thank you.

Offline Gnelf88

  • Sergeant
  • **
  • Posts: 22
    • View Profile
    • Email
Re: 40k Bug/crashes/problem´s report
« Reply #304 on: November 22, 2020, 02:57:13 pm »
I have manufactured Librarian armor and equipped it, but can't use the tome. I'm not sure if its devotion related but my soldier has decent psychic ability.

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1939
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #305 on: November 22, 2020, 05:39:33 pm »
You need to have devotion revealed (train in the chapel for about 1 month) to use the tome on librarian armor.

Offline Gnelf88

  • Sergeant
  • **
  • Posts: 22
    • View Profile
    • Email
Re: 40k Bug/crashes/problem´s report
« Reply #306 on: November 22, 2020, 05:57:05 pm »
You need to have devotion revealed (train in the chapel for about 1 month) to use the tome on librarian armor.
Thought as much, thanks for thee tip :)

Offline Ceeddd

  • Squaddie
  • *
  • Posts: 1
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #307 on: November 22, 2020, 08:43:00 pm »
Okay, so while checking out the different crafts in the battle mode, i noticed that when using the 1st Company craft you lose 2 soldiers. First attached picture shows that i picked 26 soldiers. Second attached picture shows the Battlescape with only 24 soldiers deployed.

Offline PaladinF1

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #308 on: January 16, 2021, 12:45:38 am »
Hello!
Thank you for your mod.
I encountered error and crash when enemy attacks my outpost (space marines):
[16-01-2021_01-33-31]   [INFO]   SDL_mixer initialized successfully.
[16-01-2021_01-33-52]   [INFO]   MCD XBASES05 object 39 has 0 armor
[16-01-2021_01-33-52]   [INFO]   MCD XBASES05 object 40 has 0 armor
[16-01-2021_01-33-52]   [INFO]   MCD XBASES05 object 41 has 0 armor
[16-01-2021_01-33-52]   [FATAL]   A fatal error has occurred: Map generator encountered an error: facility STR_ACCESS_OUTP has no block on first verticalLevel.
[16-01-2021_01-33-52]   [FATAL]   0x5b0d30 OpenXcom::CrossPlatform::stackTrace(void*)
[16-01-2021_01-33-52]   [FATAL]   0x5b1ba0 OpenXcom::CrossPlatform::crashDump(void*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
[16-01-2021_01-33-52]   [FATAL]   0x41c880 exceptionLogger()
[16-01-2021_01-33-52]   [FATAL]   0xb88780 MPEGaction::MPEGaction()
[16-01-2021_01-33-52]   [FATAL]   0xd767e0 void

Can't avoid it (restart does not help).

Is there any chance to continue game besides deleting outpost or something like that?


Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1939
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #309 on: January 16, 2021, 05:02:01 am »
Open up any of the ruleset files contained in the 40k/Ruleset folder with a text editor like notepad, and add the following line to the very top:

Code: [Select]
baseDefenseMapFromLocation: 1

40k/Ruleset/vars40k.rul is the file the line will be in when the new release is ready.

Offline PaladinF1

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #310 on: January 16, 2021, 11:55:43 am »
Thank you very much, it helps (no more crush).
Btw, stationary gun can't shoot now (it is blocked by its own walls). I don't know if it's consequence of that change or not.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 636
    • View Profile
    • Email
Re: 40k Bug/crashes/problem´s report
« Reply #311 on: January 16, 2021, 01:28:45 pm »
Paladinf1 you need to del or reinstall the xbase01 files in the terrain folder of the imperial fist mod or bloodangles, those files are now obslote in those optional mods

Offline Warcom

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #312 on: February 04, 2021, 10:12:12 am »
Hi guys

I have an error whenever my trading outpost gets assaulted.
Just fast forward the save untill the trade outpost gets attacked.
I had the same error as PaladinF1 and I used the same ruleset fix for it,yet it leads to a second crash.


Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 636
    • View Profile
    • Email
Re: 40k Bug/crashes/problem´s report
« Reply #313 on: February 04, 2021, 04:15:12 pm »
put the .map on the map folder and the .rmp on the routes folder, was a miss on my part , will be patched new version

Offline Warcom

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #314 on: February 04, 2021, 05:29:45 pm »
put the .map on the map folder and the .rmp on the routes folder, was a miss on my part , will be patched new version

I tried it out and it worked,did the trade outpost from start to finish.
Thank you for the help  :)