aliens

Author Topic: Bugs & Crash Reports  (Read 669305 times)

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 10138
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #1080 on: October 31, 2016, 02:38:11 am »
I did a mission against a landed reticulan ship. The last enemy remaining was a mechtoid. He came out and shot down three of my girls, failing the mission for me. In the post-battle screen it said the mechtoid surrendered and indeed, I got a mechtoid as loot, and nothing else.

Where else was he supposed to go, all alone? :)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5254
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1081 on: October 31, 2016, 02:39:44 am »
I did a mission against a landed reticulan ship. The last enemy remaining was a mechtoid. He came out and shot down three of my girls, failing the mission for me. In the post-battle screen it said the mechtoid surrendered and indeed, I got a mechtoid as loot, and nothing else.

What a freakish coincidence :) I even like that; the Mechtoid decided that the best way to end this sad episode is to head to pirate base and surrender himself :)

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6824
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #1082 on: October 31, 2016, 08:40:41 am »
What a freakish coincidence :) I even like that; the Mechtoid decided that the best way to end this sad episode is to head to pirate base and surrender himself :)

Might also be a nasty bug... I didn't test what happens when you lose the mission... it might actually be that all standing enemies capable of surrendering will surrender even if they won.
I'll test/fix it today.

EDIT: unfortunately, it's a critical bug... if you lose the mission (abort doesn't count), remaining enemies count as surrendered... will provide a fix today
« Last Edit: October 31, 2016, 11:07:00 am by Meridian »

Offline Mobling

  • Sergeant
  • **
  • Posts: 13
    • View Profile
Re: Bugs & Crash Reports
« Reply #1083 on: October 31, 2016, 10:47:03 am »
Hello world, this is my first post on the OpenXcom forums. Props to all of you guys active in developing, supporting, and contributing to this amazing mod. But to cut to the chase, my game crashes immediately before the funding screen at the end of the first month. The error message indicates it has something to do with the new underwater treasure missions. 

Attached is a screencap of the crash and a save file shortly beforehand. Forgive me if I am not reporting bugs the right way.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6824
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #1084 on: October 31, 2016, 11:35:01 am »
I'm getting a crash upon researching bullpup carbine through the gun almanach - if I try to scroll to the next topic when the item research screen comes up I get a crash to desktop. Closing the research screen avoids this problem.

Do you have a save for this?

It doesn't crash for me, but the "next" button shows the first topic (AIRBUS), since the current article index is reset to zero (which is caused by nonexistence of the pedia article for the gun almanach itself, which the game tries to display as well). Still... it should not crash.

PS: Can you please try if the attached save crashes for you?
« Last Edit: October 31, 2016, 11:38:37 am by Meridian »

Offline thisnameismeta

  • Sergeant
  • **
  • Posts: 12
    • View Profile
Re: Bugs & Crash Reports
« Reply #1085 on: October 31, 2016, 02:12:23 pm »
Do you have a save for this?

It doesn't crash for me, but the "next" button shows the first topic (AIRBUS), since the current article index is reset to zero (which is caused by nonexistence of the pedia article for the gun almanach itself, which the game tries to display as well). Still... it should not crash.

PS: Can you please try if the attached save crashes for you?

I'll try the attached save tonight. I also have a save for testing that I can attach tonight too.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5254
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1086 on: October 31, 2016, 06:02:37 pm »
The error message indicates it has something to do with the new underwater treasure missions. 

Attached is a screencap of the crash and a save file shortly beforehand. Forgive me if I am not reporting bugs the right way.

Shit Murphy's Law. I made a typo which results in a fatal crash. Repaired file attached to downloads section.

Offline saladofstones

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #1087 on: November 01, 2016, 05:19:37 am »
Noticed two entries with reference to strings, instead of a research name

Offline Mobling

  • Sergeant
  • **
  • Posts: 13
    • View Profile
Re: Bugs & Crash Reports
« Reply #1088 on: November 01, 2016, 08:11:42 am »
So the game crashes when I complete my first giant spider hunt. Attached is a save before the last spider is killed.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 10138
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #1089 on: November 01, 2016, 11:06:26 am »
Noticed two entries with reference to strings, instead of a research name

It's an artefact from version upgrade, not a bug.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5254
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1090 on: November 01, 2016, 11:43:57 am »
So the game crashes when I complete my first giant spider hunt. Attached is a save before the last spider is killed.

Fooog, another typo. That's what I get for not coding at home.

In piratez_factions.rul:
Is:
Code: [Select]
  - type: STR_GIANSPIDER_TERRORIST
    size: 0.0
    recover: true
    liveAlien: true
    costSell: 2500

should be:

Code: [Select]
  - type: STR_GIANTSPIDER_TERRORIST
    size: 0.0
    recover: true
    liveAlien: true
    costSell: 2500

Offline saladofstones

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #1091 on: November 01, 2016, 10:20:47 pm »
It's an artefact from version upgrade, not a bug.

I'm guessing nothing bad will happen if I research it then?


Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5254
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1092 on: November 01, 2016, 11:20:56 pm »
No since normally you'd get them automatically.

Offline thisnameismeta

  • Sergeant
  • **
  • Posts: 12
    • View Profile
Re: Bugs & Crash Reports
« Reply #1093 on: November 02, 2016, 12:37:50 am »
Do you have a save for this?

It doesn't crash for me, but the "next" button shows the first topic (AIRBUS), since the current article index is reset to zero (which is caused by nonexistence of the pedia article for the gun almanach itself, which the game tries to display as well). Still... it should not crash.

PS: Can you please try if the attached save crashes for you?

The attached save crashes for me when gun almanach research finishes, I click view report, and then I click the arrow to move to the previous topic (rather than the next topic, I misremembered the crash). It doesn't matter what gun is actually researched by the topic, they all seem to crash the same for me. Attached is the save where I originally experienced the bug, but your save does the same thing for me.

Offline Eddie

  • Commander
  • *****
  • Posts: 561
    • View Profile
Re: Bugs & Crash Reports
« Reply #1094 on: November 02, 2016, 01:00:35 am »
Reporting a non-critical research bug. Bad Touch Bootypeadia page doesn't show because of a typo.

It's:
Code: [Select]
  - id: AUX_BAD_TOUCH
    type_id: 4
    section: STR_WEAPONS_AND_EQUIPMENT
    text: AUX_BAD_TOUCH_UFOPEDIA
    requires:
      - STR_AUX_BAD_TOUCH

While it should be
Code: [Select]
    requires:
      - AUX_BAD_TOUCH