Author Topic: Bugs & Crash Reports  (Read 406939 times)

Offline xaphias

  • Captain
  • ***
  • Posts: 57
    • View Profile
Re: Bugs & Crash Reports
« Reply #975 on: September 06, 2016, 03:43:13 am »
ya I noticed It was kinda crucial, so I just removed the duplicate string and got past it that way, and now added the right string :)

ps. I love the updates. this is really fleshed out now, compared to just before the extended. I'm loving it :)

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5973
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #976 on: September 06, 2016, 10:43:03 am »
Can't buy workers, the amount goes to -19 when you try to add some, not sure what causes it.

OXC doesn't support buying items with negative size.
I have fixed that, it will be OK with next EXE update.

E: also, the Contacts: Merchants bootypedia entry seems to reset to unread very often. Not between multiple visits to the bootypedia at one time, but frequently nonetheless.

Can you post your save?
(I think it will be something similar to this: https://openxcom.org/forum/index.php/topic,4058.msg66854.html#msg66854 but I'll need your save, otherwise I am looking for a needle in a haystack)

Offline xaphias

  • Captain
  • ***
  • Posts: 57
    • View Profile
Re: Bugs & Crash Reports
« Reply #977 on: September 06, 2016, 01:04:37 pm »
OXC doesn't support buying items with negative size.
I have fixed that, it will be OK with next EXE update.

Ah, cool, nice to know :)
« Last Edit: September 06, 2016, 01:06:19 pm by xaphias »

Offline H0lyD4wg

  • Squaddie
  • *
  • Posts: 8
    • View Profile
Re: Bugs & Crash Reports
« Reply #978 on: September 06, 2016, 02:22:24 pm »
Some of the PNGs used in XPiratez aren't well-formed according to the PNG format specification. This doesn't cause any serious problems, but when running OpenXcomEx from the command line on Linux, libpng complains about out-of-place iCCP chunks and that's pretty annoying.

This problem can be fixed by re-encoding the offending files, which I did (see attachment). I took care not to increase the file sizes (except for 1 file out of 46 that grew by 163 bytes), so that the fixed PNGs may be incorporated into the next release.

https://drive.google.com/open?id=0B3tkOxruoA-VZllwQTlILXJ5c0k

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5973
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #979 on: September 06, 2016, 02:35:03 pm »
Thanks. That bugs me every time too :)
Hope Dioxine will include the fixed ones.

Offline Premier

  • Sergeant
  • **
  • Posts: 27
    • View Profile
Re: Bugs & Crash Reports
« Reply #980 on: September 07, 2016, 03:35:37 am »
I'm playing... not the recentmost version, but whichever was up-to-date on the 2nd of August, and I have two things to report (alas, no screenshots).

One: the inventory screen graphics for a mortally wounded (i.e. little red crosses) Guild G.O. seems to be buggy. Instead of a proper full-colour image, it's sort of a weird outline in strange colours, and has a red background.

Two: just now, my radar has spotted a UFO travelling at Ludicruos Speed. I don't remember the exact number, but the speed was 6 or 7 digits... I clicked 'Center on UFO', and at the next 5 second tick I had a popup for a Mutant Pogrom (not sure if it was related, it was located outside my radar range, but what are the chances of these two things happening in two contiguous ticks?

Offline Arthanor

  • Commander
  • *****
  • Posts: 2560
  • XCom Armoury Quartermaster
    • View Profile
Re: Bugs & Crash Reports
« Reply #981 on: September 07, 2016, 04:07:00 am »
What you caught was the emergency signal just as the pogrom was starting. That's expected. Certain pogroms start this way instead of having the usual terror ships.

Offline Premier

  • Sergeant
  • **
  • Posts: 27
    • View Profile
Re: Bugs & Crash Reports
« Reply #982 on: September 07, 2016, 04:56:03 pm »
Ah, okay, good to know.

Offline Arthanor

  • Commander
  • *****
  • Posts: 2560
  • XCom Armoury Quartermaster
    • View Profile
Re: Bugs & Crash Reports
« Reply #983 on: September 07, 2016, 04:59:18 pm »
I forgot to mention, the crazy speed you see is the speed of light in knots (or whatever the unit is.. Been playing XComFiles too much!). That's why it's so fast,

Also, the corpse issue should be reported in Ivan's AltCorpse mod, not here, as it is a bug in that mod, not in the main Piratez mod.

Offline ivandogovich

  • Commander
  • *****
  • Posts: 2409
  • X-Com Afficionado
    • View Profile
    • Ivan Dogovich Youtube
Re: Bugs & Crash Reports
« Reply #984 on: September 07, 2016, 06:05:52 pm »
I forgot to mention, the crazy speed you see is the speed of light in knots (or whatever the unit is.. Been playing XComFiles too much!). That's why it's so fast,

Also, the corpse issue should be reported in Ivan's AltCorpse mod, not here, as it is a bug in that mod, not in the main Piratez mod.

Right: Bug fix is here:
https://openxcom.org/forum/index.php/topic,4424.msg68172.html#msg68172

Offline xaphias

  • Captain
  • ***
  • Posts: 57
    • View Profile
Re: Bugs & Crash Reports
« Reply #985 on: September 08, 2016, 07:27:41 am »
game crashes when I get a base defense mission, crash code 0xc0000005
happens in save after a few hours.

it's this mission that crashes the game

  - type: STR_ALIEN_RETALIATION_L
    region: STR_EUROPE
    race: STR_ETHEREAL_WAR
    nextWave: 0
    nextUfoCounter: 0
    spawnCountdown: 480
    liveUfos: 0
    uniqueID: 169
    missionSiteZone: -1

if that helps
« Last Edit: September 08, 2016, 08:34:06 am by xaphias »

Offline Boltgun

  • Colonel
  • ****
  • Posts: 254
  • [UTTERANCES]
    • View Profile
    • Piratez let's play
Re: Bugs & Crash Reports
« Reply #986 on: September 08, 2016, 10:58:51 am »
The game crashes on 99A, B or C at the geoscape at one specific date. I tried reloading a previous save with savescumming on which led me to crash at another later date.

OpenXcom has crashed: vector::_M_range_check: __n (which is 5) >= this->size() (which is 4)

My save is a bit of a mess, having gone through so many versions. Assuming it's caused by a specific UFO, if I wipe the alien strategy, does the mod will generate new missions for me?

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5973
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #987 on: September 08, 2016, 11:34:04 am »
game crashes when I get a base defense mission, crash code 0xc0000005
happens in save after a few hours.

MapBlock on position [x=5,y=1] (Sickbay) is NULL.
I guess Dioxine needs to test if it works as it should.
Map "XBR_66" probably doesn't exist.

The game crashes on 99A, B or C at the geoscape at one specific date. I tried reloading a previous save with savescumming on which led me to crash at another later date.
OpenXcom has crashed: vector::_M_range_check: __n (which is 5) >= this->size() (which is 4)
My save is a bit of a mess, having gone through so many versions. Assuming it's caused by a specific UFO, if I wipe the alien strategy, does the mod will generate new missions for me?

A broken messy save is infinitely better than no save.
If you have anything, attach it pls.
« Last Edit: September 08, 2016, 11:35:57 am by Meridian »

Offline Boltgun

  • Colonel
  • ****
  • Posts: 254
  • [UTTERANCES]
    • View Profile
    • Piratez let's play
Re: Bugs & Crash Reports
« Reply #988 on: September 08, 2016, 02:21:43 pm »
A broken messy save is infinitely better than no save.
If you have anything, attach it pls.

I knew I forgot something, here you go.

Crashes on 29 May 2602 after 11:30.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5973
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #989 on: September 08, 2016, 03:22:55 pm »
I knew I forgot something, here you go.

Crashes on 29 May 2602 after 11:30.

It crashes when determining town to terrorize.
Details in attachment.
I don't know exactly what needs to be fixed... if ruleset or code... I don't understand this alienMission->region->missionZones[objective]->areas[missionZoneSite] concept very well. But I'd guess it's the ruleset that's missing something (or your save got messed up).
« Last Edit: September 08, 2016, 04:33:08 pm by Meridian »