aliens

Author Topic: [OXCE] Hyper & Trajectories  (Read 370 times)

greenscarf_005

  • Guest
[OXCE] Hyper & Trajectories
« on: March 31, 2021, 09:22:46 pm »
[REQUIRES OXCE 6.5+]
mod.io page:
https://openxcom.mod.io/oxce-hyper-velocity
A highly configurable mod for fast-paced XCOM experience.

By adding vapor trail to projectiles, this mod merges these two key factors once seemed incompatible:

- High Visibility
- Fast Projectiles

weapon projectile and animation speeds are now blatantly fast; which is both time-efficient and visually appealing at the same time. Helps greatly when you need to fire huge amount of volley with automatic arms.

INSTALLATION
unzip the folder attached below
move it into documents/OpenXcom/mods (create one if there isn't)
enable the mod in-game

The mod is split into two sections; 'hyperspeed' and 'trajectory'. Each consists of projectile speed and projectile trajectory. Remove one if you only need one of the features.

MODDING

highly moddable and addable to any vanilla/modded contents. Create a custom .rul file and add these properties to item of desire:

check ruleset reference nightly for more information:
https://www.ufopaedia.org/index.php/Ruleset_Reference_Nightly_(OpenXcom)

SPEEDS
Spoiler:
bulletSpeed : Projectile velocity; default 0; vanilla fastest 20
explosionSpeed : Explosion/Animation playback speed; default 0; 2 means double speed
hitAnimation: Sprite id when rendering explosion/animation; -1 removes animation
VAPORS
Spoiler:
vaporColorSurface:determines color ( numbers in transparency.rul)
vaporDensitySurface:size of vapor
vaporProbabilitySurface:% if a vapor would be created; default 15

multiple vapor trails are also possible when using shotgunpellets as above video demonstrates;

CREDITS
OpenXcom Extended by Meridian

greenscarf_005

  • Guest
[1.0.0 OFFICIAL RELEASE]
« Reply #1 on: April 08, 2021, 05:48:42 pm »
even more configurable using refnodes

Online greenscarf

  • Sergeant
  • **
  • Posts: 26
    • View Profile
    • reddit page
[UPDATE] Hyper & Trajectories for Hardmode Expansion
« Reply #2 on: April 23, 2021, 09:21:44 am »
now hyper & trajectories officially support hardmode expansion!
please keep in mind that you'll need oxce to run hyper & trajectories.


btw I've found out I was using alternative account all the time by mistake (auto-logins), it would be nice to remove these topics entirely, since I've accidently removed my alt account before removing topics above...