Author Topic: 40k Bug/crashes/problem´s report  (Read 19706 times)

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 43
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #45 on: September 01, 2018, 10:00:49 pm »
Hi Bulletdesigner,

I found you a crash. I think it is the same as before, but this time I have every information, saved game, screenshot, log, and I can recreate the crash.

-Terror mission (in Tehran)
-Pipe map

To recreate the crash:
-Select the Marine with the name "Gelasimus Lucius". (see crash capture1.png)
-Select Snap shot.
-and target the left-hinter square of the Chaos Dreadnought to the Southwest where my cursor points. (see crash capture2.png)
-The second shot to the same square will trigger the crash.

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1718
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #46 on: September 02, 2018, 03:03:43 am »
It's a similar kind of crash, it's an out-of-bounds destroyed tile, thanks for reporting it.

@bulletdesigner: it's in CONST.MCD, entry 13 (the forklift) points at 51 for the Die_MCD when it should point at 14.  I've attached a fixed version of the terrain.

@Lord Flasheart: try copying the files from the attached .zip into the TERRAIN folder of your copy of the 40k mod, or turn on save scumming in advanced options to reset the RNG so that it doesn't destroy the bugged tile.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 521
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #47 on: September 03, 2018, 11:55:13 am »
thks ohartenstein23 , i missed it while searching for it , even orbital bombarded the whole map with no crash, so nice that is now found

attention 15,16,17,18 were also out of range,
just repaired it
« Last Edit: September 03, 2018, 12:09:35 pm by bulletdesigner »

Offline dbomb

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #48 on: September 13, 2018, 02:08:30 am »
I just encountered a stuck HWP bug. I was putting sentinel in the droppods and the sentinel was placed into the third drop pod and got stuck. Also are we supposed to put sentinels in the droppods?

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1718
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #49 on: September 13, 2018, 03:22:12 am »
Not a bug - you just put the sentinel in the wrong order in the craft.  Put any 2x2 units to the top of the crew list before launching the craft to have them spawn in the correct order.

Offline dbomb

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #50 on: September 13, 2018, 05:15:55 am »
Not a bug - you just put the sentinel in the wrong order in the craft.  Put any 2x2 units to the top of the crew list before launching the craft to have them spawn in the correct order.

Ah thanks I did not know that.

Offline pje8268

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #51 on: October 18, 2018, 06:13:28 pm »
So I've been trying to install 40k, and I have encountered the same issue twice

I installed it as instructed (extracted the mod folder in the User directory, ran OXCE with the usual game files in place), and enabled the mod. When it restarted, I didn't even get to the title screen before it hit me with:

Error linking 'STR_CENT_ARMORR' in research: Unknown research 'STR_UFO_NAVIGATION   '

I tried the nightly, and it worked (but missing certain features as expected). I've deleted the User directory and installed OCXE again, but the same error shows up. My ISP is really bad (a few days ago I had download speeds around 10 KBps), so I might have just downloaded it incorrectly. But WinRAR didn't detect a file corruption so I don't think it's that.

From what limited gameplay I saw, the mod looks beautiful.

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1718
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #52 on: October 18, 2018, 06:19:13 pm »
Which version of the mod did you download?  You need the latest (010) in order for it to work with the latest OXCE as it causes the game to quit with that error message when the research ruleset is missing something.

Offline pje8268

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #53 on: October 18, 2018, 06:29:05 pm »
Wow, I feel pretty dumb now. Thanks for the quick response.

Offline Ves

  • Sergeant
  • **
  • Posts: 26
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #54 on: October 27, 2018, 07:18:31 pm »
I forgot to save the game, but i think i encountered a bug in a hulk mission. In the second stage of the mission some of my units started with less than the maximum of time units. It seemed to me they had the amount of TU's left with which they ended the previous stage. I'll add a save to this once i encounter it again. I use OpenXcom Extended 5.1 (2018-10-14).

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5554
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: 40k Bug/crashes/problem´s report
« Reply #55 on: October 27, 2018, 07:20:27 pm »
I forgot to save the game, but i think i encountered a bug in a hulk mission. In the second stage of the mission some of my units started with less than the maximum of time units. It seemed to me they had the amount of TU's left with which they ended the previous stage. I'll add a save to this once i encounter it again. I use OpenXcom Extended 5.1 (2018-10-14).

Yes, it's a known issue.
You can download fixed OXCE version here: https://lxnt.wtf/oxem/builds//Extended/Extended-5.1-5f27e4bff-2018-10-25-win32.7z

Offline d00my

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #56 on: November 05, 2018, 10:33:45 am »
I found a strange and fun bug...  Not sure, it's about 40k mod, but... i have a FEMALE SPACEMARINE! Here's a screenshot. And save file also.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 521
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #57 on: November 05, 2018, 12:23:04 pm »
it´s not a bug   femaleFrequency: 15 , if you want you can femaleFrequency: 0 if you don´t want female marines on soldiers_40k.rul

Offline MajorDerp16

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #58 on: November 15, 2018, 11:08:41 pm »
Hi Bulletdesigner,

I got an error message when i used the drop-pods to deploy, i got this error when i clicked end turn, it states
'OpenXcom has crashed: Segmentation fault. This usually indicates something missing in a mod.',
this may been due to me installing incorrectly, if so could you lend me some help.

Thanks p.s great mod

see attached screenshot: Droppods
 

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 521
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #59 on: November 16, 2018, 12:04:54 pm »
send me the save game i will try to recreate the bug

the only tricky part on installation is always using latest OCXE+ Installed
« Last Edit: November 16, 2018, 12:06:37 pm by bulletdesigner »