Author Topic: Hardmode Expansion - Bugreports  (Read 17143 times)

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Hardmode Expansion - Bugreports
« on: October 04, 2016, 08:15:18 pm »
Please leave Bugreports in this thread.

Good to have:
- Screenshots
- Savegame File

Please include also the Version of the mod you are useing and the Version of openxcom.

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #1 on: October 22, 2016, 09:11:57 pm »
OpenXcom nightly 2016.09.25
Harmode Expansion 0.99.2d

What happened just before saving: alien shot Gebre Cristos Negasi, he got 3 fatal wounds and his health dropped down to 27 (very little aftershot drop, accounting 3 FWs, by the way). On next turn his health correctly dropped to 24. A soldier, Peter Stanimirov, came to him. He has Field Medic Pack, which showed that Negasi had 1 fatal wound - torso. He healed that wound, now medic pack shows there are no FWs, but Negast still have three ones.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #2 on: October 22, 2016, 09:57:55 pm »
OpenXcom nightly 2016.09.25
Harmode Expansion 0.99.2d

What happened just before saving: alien shot Gebre Cristos Negasi, he got 3 fatal wounds and his health dropped down to 27 (very little aftershot drop, accounting 3 FWs, by the way). On next turn his health correctly dropped to 24. A soldier, Peter Stanimirov, came to him. He has Field Medic Pack, which showed that Negasi had 1 fatal wound - torso. He healed that wound, now medic pack shows there are no FWs, but Negast still have three ones.

Hi Constantine,
the savegame you attached is from a TFTD game. Maybe do you still have the correct safe file?

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #3 on: October 28, 2016, 03:52:38 pm »
I am sorry, no, it was overwritten.
Hmm, but I remember definitely that I had taken my savefile from user/xcom1 folder. Strange...

But there is one more bug)
In Research_Tree_Hardmode_Expansion (both .jpg and .dia) Soldier Armor Repair depends on Alloy Vest, whereas in reality it is available from the beginning.

Btw, where can I see list of modules included into Hardmode Expansion? At first place I'm interested in Muton Commander module.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #4 on: October 28, 2016, 07:35:12 pm »
I am sorry, no, it was overwritten.
Hmm, but I remember definitely that I had taken my savefile from user/xcom1 folder. Strange...

But there is one more bug)
In Research_Tree_Hardmode_Expansion (both .jpg and .dia) Soldier Armor Repair depends on Alloy Vest, whereas in reality it is available from the beginning.

Thanks, that is actually a bug in the research tree graphic, I made that research topic available from the start, I will add a corrected version towards the next release. Thanks for noticing :)

Btw, where can I see list of modules included into Hardmode Expansion? At first place I'm interested in Muton Commander module.

There is a new badass Race called Muton Elites which are using the Muton Commander sprites.
I never made a dedicated list of what mods I did include, since I changed values modified Sprites, added additional Sprites etc..
There is a list of Features located here.
Maybe I make a dedicated list of included Mods in the future.

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #5 on: October 30, 2016, 03:03:05 pm »
And one more bug in research tree: Alien Grenade should be dependent on Elerium.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #6 on: October 31, 2016, 09:53:45 am »
And one more bug in research tree: Alien Grenade should be dependent on Elerium.

Thanks, I also found a bug in the research tree but only a minor one.
Fixed goes into the next Version.

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #7 on: November 03, 2016, 12:09:54 pm »
The next research bug )

I have in storage corpses of sectoid, silacoid, etc. In lab I see I can research them all. I do research sectoid corpse and then get message: Now you can research silacoid corpse, chryssalid corpse.
That just seems to be excessive.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #8 on: November 03, 2016, 04:33:16 pm »
The next research bug )

I have in storage corpses of sectoid, silacoid, etc. In lab I see I can research them all. I do research sectoid corpse and then get message: Now you can research silacoid corpse, chryssalid corpse.
That just seems to be excessive.

This also occurs in Vanilla, so it should not be a mod related bug.
It is expected behaviour, also you can start all researches you can research. they will still exist and will wait for Scientist to be asigned. It is virtual Research management ^^

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #9 on: November 03, 2016, 05:59:31 pm »
This also occurs in Vanilla, so it should not be a mod related bug.

Hmm... I don't remember such behavior nor in vanilla under DOS neither in OpenXcom. Otherwise I would have posted that to OpenXcom bugtracker already.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #10 on: November 03, 2016, 08:27:51 pm »
Hmm... I don't remember such behavior nor in vanilla under DOS neither in OpenXcom. Otherwise I would have posted that to OpenXcom bugtracker already.

If you have a savegame, I will certainly recheck this behaviour. Might take a few days thou, since I am moving into my new appartment this weekend.

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #11 on: November 03, 2016, 08:39:43 pm »
Now I haven't. But after some time I'll post it here, OK.

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #12 on: November 07, 2016, 01:19:39 am »
Now I haven't. But after some time I'll post it here, OK.

I am looking forward to it. ;)

Offline Constantine

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Hardmode Expansion - Bugreports
« Reply #13 on: November 12, 2016, 05:13:56 pm »
'Alien threat' research text has a misprint: 'cilivian' should be 'civilian'.
And also there is word combination 'if they aliens'. Maybe word 'they' is redundant here? And if no, what dose it mean here?

https:// English is not my native

Offline hellrazor

  • Moderator
  • Commander
  • ***
  • Posts: 2199
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: Hardmode Expansion - Bugreports
« Reply #14 on: November 12, 2016, 07:36:28 pm »
'Alien threat' research text has a misprint: 'cilivian' should be 'civilian'.
And also there is word combination 'if they aliens'. Maybe word 'they' is redundant here? And if no, what dose it mean here?

https:// English is not my native

Thanks I fixed the typos and correct the text a little bit goes into the next Version. =)