Author Topic: win32 msvc2010 extremely slow YAML  (Read 2336 times)

Offline werty

  • Sergeant
  • **
  • Posts: 16
    • View Profile
win32 msvc2010 extremely slow YAML
« on: May 18, 2014, 06:22:30 pm »
Hi, I'm building x-com on windows 7 msvc 2010.
I've found that built yaml-cpp library is EXTREMELY slow
yaml-cpp was built on this system too using cmake (msvc2010 platform was selected), as static library (tried also shared - shared library produces errors on x-com link stage - unresolved symbols. Looks like yaml-cpp doesn't export enough symbols).
Any suggestions?

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2116
    • View Profile
Re: win32 msvc2010 extremely slow YAML
« Reply #1 on: May 18, 2014, 07:48:09 pm »
Yaml-cpp is extremely slow in Debug. To get the most performance, you have to build/run it in Release mode, or even run it outside Visual Studio altogether.
(as for not exporting enough symbols, you can try the fixed version on our site that uses shared library: https://openxcom.org/download/dev/openxcom-deps-win-vc.zip )
« Last Edit: May 18, 2014, 07:52:47 pm by SupSuper »

Offline werty

  • Sergeant
  • **
  • Posts: 16
    • View Profile
Re: win32 msvc2010 extremely slow YAML
« Reply #2 on: May 18, 2014, 11:00:27 pm »
God bless you! Slow yaml is a pain.

Offline werty

  • Sergeant
  • **
  • Posts: 16
    • View Profile
Re: win32 msvc2010 extremely slow YAML
« Reply #3 on: May 19, 2014, 02:56:24 am »
I have installed your deps folder into project, now YAML doesn't want to launch at all, spams those exceptions
https://clip2net.com/s/i8DzTn
Looks like memory inside yaml binary is corrupted or something like this. Can it be so?

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2116
    • View Profile
Re: win32 msvc2010 extremely slow YAML
« Reply #4 on: May 19, 2014, 03:58:25 am »
You might be mixing Debug and Release yaml-cpp or Visual Studio versions, I don't remember which one the dependencies use.