Author Topic: Mac OS 1.6.8  (Read 3872 times)

Offline kokon

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Mac OS 1.6.8
« on: May 13, 2013, 10:47:53 pm »
Hi,
i cant play 0.9 xcom with my 1.6.8 mac os.
Plz add support to this OS

Offline kokon

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: Mac OS 1.6.8
« Reply #1 on: May 13, 2013, 10:49:00 pm »
I mean Mac os 10.6.8 ofc

Offline luciderous

  • Colonel
  • ****
  • Posts: 108
  • There is no spoon...
    • View Profile
Re: Mac OS 1.6.8
« Reply #2 on: May 14, 2013, 08:08:01 am »
For the time being, the lowest target OSX supported in my builds is 10.7+ 64-bit. After the release 1.0 this might change and some legacy OS versions might be supported as well.

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2111
    • View Profile
Re: Mac OS 1.6.8
« Reply #3 on: May 14, 2013, 10:56:51 am »
You can always try setting it up with homebrew.

Offline kokon

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: Mac OS 1.6.8
« Reply #4 on: May 14, 2013, 11:12:50 am »
ok

Offline mat_the_swat

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: Mac OS 1.6.8
« Reply #5 on: April 18, 2014, 11:29:59 pm »
Anyone who actually wants to run this game in Mac OS X 10.6.8 can try this little trick:
  • Download Mac OS X App Bundle from download section
  • Right click on game icon and choose: "show package contents".
  • Open "Contents" folder.
  • Right click on "Info.plist" file and choose Open with... then select "TextEdit".
  • Find text "<key>LSMinimumSystemVersion</key>" and change information below it - from "<string>10.7</string>" to "<string>10.6</string>".
  • Close editor and SAVE changes.
From now game should work in but I cannot guarantee the stability (and proper working) of the game and/or operating system. This trick works for me (I've tried to install the game using homebrew but I had problems so I looked for other options). Good luck :)
« Last Edit: April 18, 2014, 11:37:52 pm by mat_the_swat »

Offline darklord42

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Mac OS 1.6.8
« Reply #6 on: June 13, 2014, 09:43:03 pm »
Just a suggestion for the mac version dev

If it's because you don't have a 10.6 sdk lying around, I'd be happy to help.  I still have one lying around as I use it for my xboard work, where i don't use xcode.  Personally I already use macports so I can't install homebrew lest it interfere with my setup.  But with macports, it's easy to set all ports to build for 10.6 by adding to the /opt/local/etc/macports/macports.conf file

# MACOSX_DEPLOYMENT_TARGET - osx version to be compatible with earlier OSX version.
macosx_deployment_target            10.6
MACOSX_DEPLOYMENT_TARGET            10.6
SDKROOT                             /Developer/SDKs/MacOSX10.6.sdk

I have no idea how to configure this in homebrew.

then compile with the -mmacosx-version-min=10.6 -isysroot /Developer/SDKs/MacOSX10.6.sdk flags

Then you would also want to make sure the minimum version is 10.6 in the app's plist file as mentioned above.


« Last Edit: June 13, 2014, 10:01:41 pm by darklord42 »

Offline darklord42

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Mac OS 1.6.8
« Reply #7 on: June 16, 2014, 05:07:08 pm »
I looked into this for you. Unfortunately compiling for 10.6 it isn't possible unless you have a mac with OSX10.6 installed.   As is, yaml-cpp doesn't compile properly.   It needs resources from xcode 3.2.6 Which simply cannot be installed on 10.8 and up without making your mac unbootable.  (which might be able to be fixed after by running a preinstalled fixing script, but I'm not risking it)  in Xcode 5/4 the libraries won't target anything below 10.7 :(
building on 10.7 may be possible, but you have to jump through various hoops to install xcode 3.2.6 plus setup macports as I have above.
« Last Edit: June 16, 2014, 05:09:50 pm by darklord42 »

Offline mat_the_swat

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: Mac OS 1.6.8
« Reply #8 on: June 16, 2014, 09:47:44 pm »
In the end, We can always use an Windows emulation software like Wineskin or Winebottler  8)

Offline darklord42

  • Sergeant
  • **
  • Posts: 29
    • View Profile
Re: Mac OS 1.6.8
« Reply #9 on: June 17, 2014, 07:38:44 am »
This is true, as wineskin still manages to maintain 10.6 support. But sure adds to the size of the app. Its a shame really.  I keep thinking that if I spend time with it, I can find a way to get around these issues.