aliens

Author Topic: "Facility In Use" message without detail  (Read 421 times)

Offline 0xEBJC

  • Colonel
  • ****
  • Posts: 180
  • Y'all are awesome! Thankful for this community.
    • View Profile
    • My Projects
"Facility In Use" message without detail
« on: March 30, 2024, 10:32:49 pm »
I'm getting the "Facility In Use" message without any reasons when trying to remove a base facility, not build over it. 

I've tested this in OXCE, and BRUTAL-AI and this issues is only in BAI. Meridian added this feature and it works properly in OXCE.

Done.
https://github.com/MeridianOXC/OpenXcom/commit/254ecccacfafc3c80e2229b15c76231126cb576f
 :D
As mentioned above, it doesn't cover all possible cases, situations and combinations.


It might also be due to some logic with having different hangar types since the facility I'm trying to remove is a hangar type 'garage' with hangar type 1
https://github.com/Xilmi/OpenXcom/tree/oxce-plus/Examples


The specific case is when I have multiple hangars, say 3, and one craft is out so although 3 hangars are being used the basescape shows one hangar (looks empty).  I know this is an unlikely event when someone looses track of crafts being out while trying to dismantle a hangar, but that's what happened to me.

Game Version:
OXCE: 7.12.2 BAI: 8.3.3 (2024-03-23)

« Last Edit: April 05, 2024, 02:53:39 pm by Meridian »

Offline Xilmi

  • Moderator
  • Commander
  • ***
  • Posts: 623
    • View Profile
Re: "Facility In Use" message without detail
« Reply #1 on: April 03, 2024, 12:46:03 am »
Was a relatively easy fix after I found the issue. No need to remove the entire hangar-type and multiple crafts-per hangar feature for it.

But I gotta say the thread-title sounded rather melodramatic considering what the actual nature of the problem was.  ::)
« Last Edit: April 05, 2024, 02:53:47 pm by Meridian »

Offline Juku121

  • Commander
  • *****
  • Posts: 1664
  • We're all mad here.
    • View Profile
Re: "Facility In Use" message without detail
« Reply #2 on: April 03, 2024, 10:09:33 am »
But I gotta say the thread-title sounded rather melodramatic...
This was probably in an attempt to make a general 'bugs' thread similar to this one.

« Last Edit: April 05, 2024, 02:53:56 pm by Meridian »

Offline Xilmi

  • Moderator
  • Commander
  • ***
  • Posts: 623
    • View Profile
Re: "Facility In Use" message without detail
« Reply #3 on: April 03, 2024, 12:33:16 pm »
This was probably in an attempt to make a general 'bugs' thread similar to this one.
Yeah, considering that these threads have the exact same name, the inspiration being drawn from there seems more than likely.

I personally prefer a separate threat for each issue and ideally also with a descriptive title. I think that makes it easier to keep the overview.
« Last Edit: April 05, 2024, 02:54:01 pm by Meridian »

Offline 0xEBJC

  • Colonel
  • ****
  • Posts: 180
  • Y'all are awesome! Thankful for this community.
    • View Profile
    • My Projects
Re: "Facility In Use" message without detail
« Reply #4 on: April 04, 2024, 07:44:42 pm »
Yeah, considering that these threads have the exact same name, the inspiration being drawn from there seems more than likely.

I personally prefer a separate threat for each issue and ideally also with a descriptive title. I think that makes it easier to keep the overview.

OK, duly noted, sorry...but yes the title was an effort to make a pinned thread for all bugs, but I can make individual ones, thanks for all your time!
« Last Edit: April 05, 2024, 02:54:07 pm by Meridian »

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 11503
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: "Facility In Use" message without detail
« Reply #5 on: April 05, 2024, 02:14:46 pm »
Don't take me wrong, I don't mind, but would it be OK if this thread's name was at least slightly different, for example "BAI bugs, crashes, typos, bad taste"? It's just confusing to see both in my unread topics and I can't tell them apart.
« Last Edit: April 05, 2024, 02:54:12 pm by Meridian »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8694
    • View Profile
Re: "Facility In Use" message without detail
« Reply #6 on: April 05, 2024, 02:54:32 pm »
renamed