Author Topic: Mod Errors  (Read 438 times)

Offline Dertrend

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Mod Errors
« on: January 03, 2021, 09:21:56 pm »
I tried to install two mod packs but I keep running into problems that I cannot overcome.  I have successfully installed OpenXcom and that works. 

I tried to install The X-COM Files and I have put it into the correct folder that the system uses in my users/documents/openxcom/mods folder.  OpenXcom can see the mod and when I try to active it in the mod screen I get an error that the mod is already in use which does not make much sense to me.

I also tried to install another mod pack called the Final Mod Pack however this would not load due to an error "Resources/FinalModPack/Weapons_Compilation/Minigun/Sounds/fire.wav:Mix_LoadWAV_RW with NULL src"

Does anyone know how to fix either of these problems as these seem to be the two big mod expansions with new content?

Thanks for any help you can give.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6798
  • OXCE developer
    • View Profile
    • My Wiki
Re: Mod Errors
« Reply #1 on: January 03, 2021, 10:17:07 pm »
can you provide the log file?

Offline Dertrend

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: Mod Errors
« Reply #2 on: January 03, 2021, 10:24:06 pm »
This is the log information for the Final Mod Pack

[03-01-2021_11-31-20]   [INFO]   OpenXcom Version: 1.0 git 2020-12-30 09:12
[03-01-2021_11-31-20]   [INFO]   Platform: Windows
[03-01-2021_11-31-20]   [INFO]   Data folder is:
[03-01-2021_11-31-20]   [INFO]   Data search is:
[03-01-2021_11-31-20]   [INFO]   - C:\Users\Ian.Ian-PC\Documents\OpenXcom\
[03-01-2021_11-31-20]   [INFO]   - D:\Games\XCOM\OpenXcom
[03-01-2021_11-31-20]   [INFO]   - D:\Games\XCOM\OpenXcom
[03-01-2021_11-31-20]   [INFO]   User folder is: C:\Users\Ian.Ian-PC\Documents\OpenXcom\
[03-01-2021_11-31-20]   [INFO]   Config folder is: C:\Users\Ian.Ian-PC\Documents\OpenXcom\
[03-01-2021_11-31-20]   [INFO]   Options loaded successfully.
[03-01-2021_11-31-21]   [INFO]   SDL initialized successfully.
[03-01-2021_11-31-21]   [INFO]   SDL_mixer initialized successfully.
[03-01-2021_11-31-21]   [INFO]   requested file not found: openxcom.png
[03-01-2021_11-31-21]   [INFO]   Detected locale: C
[03-01-2021_11-31-21]   [INFO]   Attempting to set display to 640x400x8...
[03-01-2021_11-31-21]   [INFO]   Display set to 640x400x8.
[03-01-2021_11-31-21]   [INFO]   Loading data...
[03-01-2021_11-31-21]   [INFO]   Scanning standard mods in 'standard'...
[03-01-2021_11-31-21]   [INFO]   Scanning user mods in 'C:\Users\Ian.Ian-PC\Documents\OpenXcom\mods'...
[03-01-2021_11-31-21]   [INFO]   Mapping resource files...
[03-01-2021_11-31-21]   [INFO]   Resources files mapped successfully.
[03-01-2021_11-31-21]   [INFO]   Active mods:
[03-01-2021_11-31-21]   [INFO]   - xcom1 v1.0
[03-01-2021_11-31-21]   [INFO]   Loading rulesets...
[03-01-2021_11-31-22]   [INFO]   Loading fonts... Font.dat
[03-01-2021_11-31-22]   [INFO]   Data loaded successfully.
[03-01-2021_11-31-22]   [INFO]   Loading language...
[03-01-2021_11-31-22]   [INFO]   Language loaded successfully.
[03-01-2021_11-31-22]   [INFO]   OpenXcom started successfully!
[03-01-2021_11-31-22]   [INFO]   Playing flx, 320x200, 890 frames
[03-01-2021_11-31-22]   [INFO]   Using software scaling routine. For best results, try an OpenGL filter.
[03-01-2021_11-31-23]   [INFO]   SDL_mixer initialized successfully.
[03-01-2021_11-31-24]   [INFO]   Scanning standard mods in 'standard'...
[03-01-2021_11-31-24]   [INFO]   Scanning user mods in 'C:\Users\Ian.Ian-PC\Documents\OpenXcom\mods'...
[03-01-2021_11-31-31]   [INFO]   SDL_mixer initialized successfully.
[03-01-2021_11-31-31]   [INFO]   Loading data...
[03-01-2021_11-31-31]   [INFO]   Scanning standard mods in 'standard'...
[03-01-2021_11-31-31]   [INFO]   Scanning user mods in 'C:\Users\Ian.Ian-PC\Documents\OpenXcom\mods'...
[03-01-2021_11-31-31]   [INFO]   Mapping resource files...
[03-01-2021_11-31-32]   [INFO]   Resources files mapped successfully.
[03-01-2021_11-31-32]   [INFO]   Active mods:
[03-01-2021_11-31-32]   [INFO]   - xcom1 v1.0
[03-01-2021_11-31-32]   [INFO]   - final_mod_pack_2.8c v1.0
[03-01-2021_11-31-32]   [INFO]   Loading rulesets...
[03-01-2021_11-31-32]   [INFO]   Loading fonts... Font.dat
[03-01-2021_11-31-32]   [INFO]   requested file not found: Resources/Weapons_Compilation/Minigun/Sounds/fire.wav
[03-01-2021_11-31-32]   [ERROR]   Resources/Weapons_Compilation/Minigun/Sounds/fire.wav:Mix_LoadWAV_RW with NULL src

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6798
  • OXCE developer
    • View Profile
    • My Wiki
Re: Mod Errors
« Reply #3 on: January 03, 2021, 10:35:49 pm »
[03-01-2021_11-31-32]   [INFO]   Active mods:
[03-01-2021_11-31-32]   [INFO]   - xcom1 v1.0
[03-01-2021_11-31-32]   [INFO]   - final_mod_pack_2.8c v1.0

This is not how a Final Mod Pack mod ID looks like... it should look like this:

Code: [Select]
[03-01-2021_21-30-35] [INFO] - final-mod-pack v2.8

Did you maybe extract it into a subdirectory?

It should be in `openxcom/mods/Final Mod Pack/` folder
without any extra subfolders between `mods` and `Final Mod Pack` folders
« Last Edit: January 03, 2021, 10:45:50 pm by Meridian »

Offline Dertrend

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: Mod Errors
« Reply #4 on: January 04, 2021, 01:26:32 am »
@Meridian - Thank you kindly sir.  You are a gentleman and a scholar.   :)  The mod appears to fully functional!

Incidentally after my earlier failed mod attempt I took the time to play a regular veteran game as its been 2 decades since I last played.  Not a single solder made it 10 feet from the landing craft.