aliens

Author Topic: SEGMENTATION FAULT!  (Read 516 times)

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
SEGMENTATION FAULT!
« on: April 25, 2020, 02:04:02 am »
So, see attachments.
There you will find the log, mods I used and my save file on the "crash.zip" file.
I am working on a submod for XCF and, when the research "Breeding" is completed and I click on "show report" it crashes.
Could I be doing something wrong as a modder?

Edit: sorry for all caps, I am freaking out.
« Last Edit: April 25, 2020, 02:18:18 am by Thermite »

Offline vadracas

  • Colonel
  • ****
  • Posts: 279
  • Just another player/modder combo.
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #1 on: April 25, 2020, 02:23:59 am »
So, see attachments.

Where are the attachments? Either way, based on the fact that it is a seg-fault, my guess is a bad index number or something similar. But no way to know without the mod attached and I don't see it.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #2 on: April 25, 2020, 02:46:33 am »
Where are the attachments? Either way, based on the fact that it is a seg-fault, my guess is a bad index number or something similar. But no way to know without the mod attached and I don't see it.

Did in a haste, sorry.
I removed the XCF mod folder, because it was taking forever to upload.
Edit: XCF version is 1.3.2 (or commit dd39380a if you use git).
« Last Edit: April 25, 2020, 02:59:30 am by Thermite »

Offline vadracas

  • Colonel
  • ****
  • Posts: 279
  • Just another player/modder combo.
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #3 on: April 25, 2020, 03:45:36 am »
Haven't read the bible section on ufoPaedia type id's, but that's where I think you're error is. Might want to do some digging.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #4 on: April 25, 2020, 05:18:43 am »
Haven't read the bible section on ufoPaedia type id's, but that's where I think you're error is. Might want to do some digging.
Solarious said to use type 4.
*A*

Online Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 6509
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: SEGMENTATION FAULT!
« Reply #5 on: April 25, 2020, 09:11:50 am »
The item's bigSprite is missing.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #6 on: April 25, 2020, 10:15:36 pm »
The item's bigSprite is missing.
How do I do that?
When I used:
Code: [Select]
items:
  - type: STR_BREEDING
    bigSprite:
        mod: master
        index: 297
    weight: 0
    invWidth: 2
    invHeight: 3

It still gave the same problem.
O_o

Online Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 6509
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: SEGMENTATION FAULT!
« Reply #7 on: April 25, 2020, 10:38:38 pm »
1/ XCF is not the master (xcom1 is master)
2/ use 2 spaces for indentation, not 4

Code: [Select]
items:
  - type: STR_BREEDING
    bigSprite:
      mod: x-com-files
      index: 297
    weight: 0
    invWidth: 2
    invHeight: 3
  - type: STR_BREEDING_RAT
    bigSprite: { mod: x-com-files, index: 297 }
    weight: 0
    invWidth: 2
    invHeight: 3
« Last Edit: April 25, 2020, 10:43:01 pm by Meridian »

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: SEGMENTATION FAULT!
« Reply #8 on: April 25, 2020, 10:45:22 pm »
1/ XCF is not the master (xcom1 is master)
2/ use 2 spaces for indentation, not 4

Code: [Select]
items:
  - type: STR_BREEDING
    bigSprite:
      mod: x-com-files
      index: 297
    weight: 0
    invWidth: 2
    invHeight: 3
  - type: STR_BREEDING_RAT
    bigSprite: { mod: x-com-files, index: 297 }
    weight: 0
    invWidth: 2
    invHeight: 3

thanks!