aliens

Author Topic: Abort trap 6 (OSX 10.12)  (Read 3215 times)

Offline Grub

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Abort trap 6 (OSX 10.12)
« on: April 14, 2017, 06:00:22 pm »
Hello, whenever I try to run openXcom I receive the abort trap 6. I have a build of the Xcode(I don't know what to do with it, or if it makes a difference I have added the TFTD files required).

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8565
    • View Profile
Re: Abort trap 6 (OSX 10.12)
« Reply #1 on: April 14, 2017, 06:15:06 pm »
If I read correctly, it says it can't find the SDL_gfx library.

To run OpenXcom, you need the following libraries (either statically or dynamically linked):
 * SDL (libsdl1.2)
 * SDL_mixer (libsdl-mixer1.2)
 * SDL_image (libsdl-image1.2)
 * SDL_gfx (libsdl-gfx1.2), version 2.0.22 or later
 * yaml-cpp, (libyaml-cpp), version 0.5.1 (0.5.2 does not work, use latest git HEAD if you want newer version)

Unfortunately, I'm not an OSX user... no idea how to help you.
Maybe someone else could jump in.

Offline Grub

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Abort trap 6 (OSX 10.12)
« Reply #2 on: April 14, 2017, 06:33:39 pm »
I hadn't seen that I was using yaml-cpp version 0.5.3! Can I define what I want to brew install or use an archive somewhere

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8565
    • View Profile
Re: Abort trap 6 (OSX 10.12)
« Reply #3 on: April 14, 2017, 06:35:51 pm »
I hadn't seen that I was using yaml-cpp version 0.5.3! Can I define what I want to brew install or use an archive somewhere

0.5.3 should work fine.

Only 0.5.2 was buggy.

Offline Grub

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Abort trap 6 (OSX 10.12)
« Reply #4 on: April 14, 2017, 08:22:21 pm »
I re-downloaded the homebrew files. Unfortunately, still reads the same message.