Author Topic: increase/decrease button no longer work with mouse wheel ?  (Read 1785 times)

Offline Ascadix

  • Captain
  • ***
  • Posts: 77
  • My English is as good as French schools ... :-p
    • View Profile
increase/decrease button no longer work with mouse wheel ?
« on: October 09, 2016, 10:29:16 pm »
Hello,

a little pb i have since some time  (before the summer holidays).

Actually, build 2016-09-25 on Win 7 U amd64, fresh install of the OS.

In OpenXcom, mouse wheel work for scroling in long list, but there is no effect when scroling while cursor is on an increase/ decrease button.

What can i do for this ?
I have the pb with the basic Windows mouse driver as well as the OEM driver.


Another question ... is there any key-combination to jump quantity by huge amount ( like : ctrl-clic -> +/- 100 items ) ?
Thanks
« Last Edit: October 09, 2016, 10:47:13 pm by Ascadix »

Online R1dO

  • Colonel
  • ****
  • Posts: 368
    • View Profile
    • Email
Re: increase/decrease button no longer work with mouse wheel ?
« Reply #1 on: October 10, 2016, 12:52:24 am »
...
In OpenXcom, mouse wheel work for scroling in long list, but there is no effect when scroling while cursor is on an increase/ decrease button.

What can i do for this ?

...

Another question ... is there any key-combination to jump quantity by huge amount ( like : ctrl-clic -> +/- 100 items ) ?

It might sound a bit silly .. but the answer to your first question would be:
 "move the cursor away from those buttons and try scrolling again."
The reason for this is related to your 2nd question.

Instead of a key-combo it is possible to assign a quantity per 'click'  to the mousewheel that is used when increasing/decreasing numbers while the mouse pointer is on such a button. See description of options and look for "changeValueByMouseWheel" in the table.

Offline Ascadix

  • Captain
  • ***
  • Posts: 77
  • My English is as good as French schools ... :-p
    • View Profile
Re: increase/decrease button no longer work with mouse wheel ?
« Reply #2 on: October 10, 2016, 01:25:17 am »
See description of options and look for "changeValueByMouseWheel" in the table.

Yesss  :D

Thank you.

I don't remember having changed this value a long time ago, but since it is "0" by default and i have re-installed  OpenXcom in new folder to support new mod folder tree, i've probably lost mouse wheel at that time.