aliens

Author Topic: OpenXcom just not working at all [FIXED]  (Read 8325 times)

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
OpenXcom just not working at all [FIXED]
« on: April 09, 2015, 11:37:02 pm »
I've tried everything i can think of but nope, i deleted the whole OpenXcom folder, got a clean install of Xcom from Steam and re-downloaded the milestone with no nightlies but still it just. wont. work! basically when i click on New Battle or New game and choose the difficulty the game crashes with "OpenXcom has stopped working" and the usual garbage under it. Help??? :(
« Last Edit: April 10, 2015, 02:45:57 pm by bloodman123726 »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7363
    • View Profile
Re: OpenXcom just not working at all
« Reply #1 on: April 09, 2015, 11:45:25 pm »
Can you attach a screenshot, complete error/exception message text, openxcom.log file... and/or anything else you can find? It's hard to help without anything to start with...

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #2 on: April 09, 2015, 11:46:47 pm »
double check any shortcuts to make sure they're not pointing to a broken install, check my documents/openxcom/ and see what's going on in there.

if you are using the nightly, you no longer need xcom1ruleset.rul and can delete it, as the ruleset is now in a folder structure.

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
Re: OpenXcom just not working at all
« Reply #3 on: April 09, 2015, 11:58:38 pm »
ok i'll add an attachment on what happens, also i cant use any nightly as it doesnt work as well

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #4 on: April 10, 2015, 12:10:52 am »
can i see what's in your data folder? (expanded tree view if possible)

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #5 on: April 10, 2015, 12:19:19 am »
where's your vanilla game data?

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
Re: OpenXcom just not working at all
« Reply #6 on: April 10, 2015, 12:25:40 am »
what do you mean i dragged everything from steam folder to this

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #7 on: April 10, 2015, 12:32:22 am »
here's what it should look like:

if you're getting in to the main menu, then it is reading the data from _somewhere_ so the question is, where?

and in that location, is there an older (or newer) ruleset that may be overriding the one you WANT to use?
« Last Edit: April 10, 2015, 12:34:46 am by Warboy1982 »

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
Re: OpenXcom just not working at all
« Reply #8 on: April 10, 2015, 12:36:00 am »
so should i drag all of the xcom files into data

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #9 on: April 10, 2015, 12:37:11 am »
i'd suggest locating the data that already exists somewhere else, and purging it first.

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
Re: OpenXcom just not working at all
« Reply #10 on: April 10, 2015, 12:41:20 am »
i had a spare copy of openxcom and another folder with PirateZ installed in it, i deleted both of them, recycled them and launched openxcom yet the issue still remains. :/

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #11 on: April 10, 2015, 12:42:42 am »
check my documents/openxcom/

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #12 on: April 10, 2015, 12:49:53 am »
so then where is the data??

Offline bloodman123726

  • Sergeant
  • **
  • Posts: 30
    • View Profile
Re: OpenXcom just not working at all
« Reply #13 on: April 10, 2015, 01:10:27 am »
i was looking around for the data and i found a crash report, hope this helps

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
    • Email
Re: OpenXcom just not working at all
« Reply #14 on: April 10, 2015, 01:47:16 am »
just a crazy theory, but maybe it doesn't like being run from the desktop?