aliens

Author Topic: No Mod Segmentation Fault  (Read 416 times)

Offline Rivendare

  • Squaddie
  • *
  • Posts: 5
    • View Profile
No Mod Segmentation Fault
« on: August 04, 2021, 09:13:29 am »
Hello Folks,
I just installed OpenXcom (1618) and pasted TFD (bought on Steam) in.
without adding any mods, when I try to start the game it says: "OpenXcom has crushed:segmentation fault. This usually indicates something missing in a mod."

I tried several times in last 2 days for some reason it worked yesterday! I did nothing different. Today the same error. What are your suggestions? Thank you upfront.

[04-08-2021_09-07-50]   [INFO]   OpenXcom Version: 1.0 git 2021-06-11 16:18
[04-08-2021_09-07-50]   [INFO]   Platform: Windows
[04-08-2021_09-07-50]   [INFO]   Data folder is:
[04-08-2021_09-07-50]   [INFO]   Data search is:
[04-08-2021_09-07-50]   [INFO]   - C:\Users\Rivendare\Documents\OpenXcom\
[04-08-2021_09-07-50]   [INFO]   - H:\OpenXcom
[04-08-2021_09-07-50]   [INFO]   - H:\OpenXcom
[04-08-2021_09-07-50]   [INFO]   User folder is: C:\Users\Rivendare\Documents\OpenXcom\
[04-08-2021_09-07-50]   [INFO]   Config folder is: C:\Users\Rivendare\Documents\OpenXcom\
[04-08-2021_09-07-50]   [INFO]   Options loaded successfully.
[04-08-2021_09-07-50]   [INFO]   SDL initialized successfully.
[04-08-2021_09-07-51]   [FATAL]   A fatal error has occurred: Segmentation fault. This usually indicates something missing in a mod.
[04-08-2021_09-07-51]   [FATAL]   0x54eb20 OpenXcom::CrossPlatform::stackTrace(void*)
[04-08-2021_09-07-51]   [FATAL]   0x5523f0 OpenXcom::CrossPlatform::crashDump(void*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
[04-08-2021_09-07-51]   [FATAL]   0x40dca0 signalLogger(int)
[04-08-2021_09-07-51]   [FATAL]   0x87bac0 xbrz::nearestNeighborScale(unsigned int const*, int, int, int, unsigned int*, int, int, int, xbrz::SliceType, int, int)
[04-08-2021_09-07-51]   [FATAL]   0x75dde880 UnhandledExceptionFilter
[04-08-2021_09-07-51]   [FATAL]   0x772e8c40 RtlCaptureStackContext
[04-08-2021_09-07-51]   [FATAL]   0x772c7960 RtlGetAppContainerNamedObjectPath
[04-08-2021_09-08-43]   [FATAL]   OpenXcom has crashed: Segmentation fault. This usually indicates something missing in a mod.
More details here: C:\Users\Rivendare\Documents\OpenXcom\openxcom.log
If this error was unexpected, please report it to the developers.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7000
  • OXCE developer
    • View Profile
    • My Wiki
Re: No Mod Segmentation Fault
« Reply #1 on: August 04, 2021, 09:45:49 am »
is that the whole log?

Offline Rivendare

  • Squaddie
  • *
  • Posts: 5
    • View Profile
Re: No Mod Segmentation Fault
« Reply #2 on: August 04, 2021, 10:39:40 am »
Yes sir.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7000
  • OXCE developer
    • View Profile
    • My Wiki
Re: No Mod Segmentation Fault
« Reply #3 on: August 04, 2021, 10:47:08 am »
My (probably bad) guess is your audio hardware failed to initialize.

Do you have audio on your PC?

Can you upload also your options.cfg file?
« Last Edit: August 04, 2021, 10:52:54 am by Meridian »

Offline Rivendare

  • Squaddie
  • *
  • Posts: 5
    • View Profile
Re: No Mod Segmentation Fault
« Reply #4 on: August 04, 2021, 11:10:40 am »
I love it when I can point people to the right direction with a single touch.. You did the same thing today. Yes, I had audio, matter of fact I had multiple audio drivers due to my MIDI Controllers and music creation software. I just switched them and it works now.. Weird that the error message is talking about mods.
Thank you for your help!