Author Topic: Another Final Mod Pack Help Post  (Read 3541 times)

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Another Final Mod Pack Help Post
« on: June 27, 2021, 01:40:29 pm »
So I've installed the latest nightly it says "1.0 git 2021-06-11 16:18" . I have also installed the latest Final Mod Pack 2.8e version.

I created a mods folder inside the OpenXcom folder and added the Final Mod Pack. That is the only mod I have added so there isn't anything else. However when I open up the game it doesn't register the mods. Well it does register 21 of the mods but not all of them, so no new aliens or weapons or tech.

Not sure if I've downloaded or done something wrong and any help would be appreciated.

Offline Dogbarian

  • Captain
  • ***
  • Posts: 93
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #1 on: June 29, 2021, 09:46:29 am »
Check your folder structure (I had an extra folder as a result of unzipping, which interfered). Looking down the path from OpenXCOM folder, you should have "user", then "mods", then "Final Mod Pack", that folder should then have all of the various folders from FMP.  Actually, from what you said, I think your "mods" folder is too high, move it down inside "user".

Then after you launch the game, go to Mods button from title screen, the Final Mod Pack should be one of the last entries, activate it, when you press OK, game should restart and the title screen will say Final Mod Pack.

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #2 on: June 30, 2021, 06:54:22 pm »
Maybe I have done something wrong then. I don't have a "user" folder so I made the "mods"folder in the OpenXcom one. I'll need to try re downloading it all again.

Offline R1dO

  • Colonel
  • ****
  • Posts: 438
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #3 on: June 30, 2021, 09:06:19 pm »
The "user" folder route is only needed if you go for a contained installation (everything in one folder which you can move around at will).
It was popularized by the bigger OXCE mods that included the game, but i am not sure if they still use that approach.

If you put the mod under the "openxcom/mods" folder (location of "openxcom" depends on your OS and installation choices) it should be available to the game.
Since you refer to "nightly" i assume you are using OXC (not OXCE). In that case make sure to unzip FMP under mods, for as far as i know OXC does not support zipped mods.

If that still fails. Search your system for a file called "openxcom.log" and attach that to your post. That might allow us to get a better understanding what goes wrong.

Good luck

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #4 on: July 02, 2021, 09:12:23 pm »
Thanks for the replies.

So I still can't get it to work. I uninstalled everything then re installed it all. I downloaded the latest nightly from the OpenXcom site, this is the same version as last time - "1.0 git 2021-06-11 16:18". I made a mods folder in the OpenXcom folder, downloaded the latest Final Mod Pack version - 2.8e version - and saved it in the mods folder.

But it does not load the Final Mod Pack. I tried it while the mod was zipped and unzipped and it didn't work either way. I have attached the "openxcom.log" here if that makes it easier to explain.

Offline The Martian

  • Commander
  • *****
  • Posts: 754
  • "It implores you to listen to its arguments..."
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #5 on: July 02, 2021, 10:17:09 pm »
The "mods" folder needs to be inside a "user" folder inside the "openxcom" folder.


Here is the configuration I use:


Both "user" & "mods" folders did not exist when I first unzipped OpenXcom Extended, they needed to be created.

In this case "Extended-7.0-08d9eb908-2021-03-13-bionic-x86_64" is the folder created by unzipping the latest release of OXCE, but for your installation just treat that folder as the name of whatever your OpenXcom install's directory is called.

Your folder structure should look like this:
../Extended-7.0-08d9eb908-2021-03-13-bionic-x86_64/user/mods/

Then place mods like the Final Mod Pack inside the newly created "mods" directory.

They 'may' be capitalisation sensitive (I'm not sure) so make sure both "user" & "mods" folders are lower case.


As an added bonus to this setup the openxcom.log file and any screenshots you take will be funneled into the "user" folder for easy access.





That is the only mod I have added so there isn't anything else. However when I open up the game it doesn't register the mods. Well it does register 21 of the mods but not all of them, so no new aliens or weapons or tech.

I've seen someone else have trouble with only some of the mods loading and they were accidentally deleting the metadata.yml file in the folder for each mod.

Can you confirm that the mods that are not being detected by OpenXcom have a file called "metadata.yml" inside the first layer of their folder structure:
« Last Edit: July 02, 2021, 11:57:01 pm by The Martian »

Offline R1dO

  • Colonel
  • ****
  • Posts: 438
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #6 on: July 02, 2021, 10:22:51 pm »
Just to be sure.
With "... not load the Final Mod Pack" you mean it is not visible in the mods section (as shown in the attachment)?

As for the log you attached, i cannot see anything obviously wrong there.
To rule out installation errors, could you attach the output of the following powershell command (should create a file on your desktop):

Code: [Select]
Get-ChildItem -Path C:\Users\Rybus\Documents\OpenXcom -Recurse -Force | Out-File -FilePath C:\Users\Rybus\Desktop\myOpenXcom.txt

If you are uncomfortable pasting random code from the internet, you can check the commands using the following documentation.
* https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.management/get-childitem?view=powershell-7.1
* https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.utility/out-file?view=powershell-7.1

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #7 on: July 03, 2021, 12:21:03 am »
Thank you all very much! It was the fact that the users folder was missing that was the issue. I created a user folder and placed the mods folder inside of this and that fixed it. Turns out it was an easy fix.

Again thanks for the help!

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #8 on: July 06, 2021, 11:47:30 pm »
So back again. Adding in the "user" folder as suggested by The Martian solved the issue, I had the same folder structure as they said and the Final Mod Pack was showing up and could be selected and the game was working.

However it did not allow the game to save it would keep saying "failed to save Save1.sav". The issue seems to be with the user folder, when I delete this the game could save but the mods wouldn't be registering. Even if I deleted the mods and added in an empty user folder as mentioned the game could not save. Also the openxcom.log would say it was in the user folder but it would not appear so I couldn't check that.

Basically I had the folder set up suggested by The Martian and it allowed the mods to work but the game couldn't save. Or I could remove the user folder and the game saves but mods don't work. Any help would be appreciated.

UPDATE
The same issue is happening however I have found out that anytime I try to save a game it creates an OpenXcom folder in My Documents. So my OpenXcom is saved to "This PC > Acer (C:) > Program Files (x86) > OpenXcom" but whenever I save a game it makes a new folder OpenXcom folder found here in "This PC > Documents > OpenXcom". This folder has the save games and the log that I attached.
« Last Edit: July 07, 2021, 12:08:40 am by Rybus »

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 11503
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Another Final Mod Pack Help Post
« Reply #9 on: July 07, 2021, 02:39:14 pm »
Don't install anything in Program Files? :)

Offline Rybus

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: Another Final Mod Pack Help Post
« Reply #10 on: July 07, 2021, 10:44:20 pm »
Thank you that sorted it! It all works now