aliens

Author Topic: Huge FPS hit with 7.5.8, can you help me pinpoint the problem?  (Read 335 times)

Offline osd_daedalus

  • Sergeant
  • **
  • Posts: 31
    • View Profile
    • Email
Hello!
I'm not sure if what I am reporting is a problem with OXCE, XCom-Files or my configuration... so I'll post here anyway:

When I was using OXCE 6.8.4 all was working like a champ. Now that I'm using OXCE 7.5.8, I am experiencing lots of FPS loss especially in battlescape, which looks like to be Z-level and resource dependant. While in vanilla OXCE this is somewhat negligible, in XCF many parts are almost unplayable (i.e.
Spoiler:
the alien moon satellite map
, dropping up to 2-3FPS when camera is on the turret and the wall). I remember not to have problems like this before with areas with many Z levels like
Spoiler:
the Syndicate tower
etc...

My specs are: Intel i5 11400F, Nvidia GTX 970 (yea, that's due to crazy RTX prices :P), 16GB DDR4 RAM . Running Kubuntu 21.04

What I have done so far:
- of course, updated OXCE and XCF. To be honest, I cloned again the repo as I did some mishaps before
- updated Kubuntu from 20.04 to 21.10
- updated NVidia drivers to 510
- removed the .config/openxcom folder in home and let OXCE recreate them
- turned on and off VSync, Lazy loading, tried filters...

On a side note, getting tons of segfaults on loading XCF or quitting OXCE when XCF is loaded. Looks like is something with fluidsynth or anyway audio-related...
This is the log in the latter case:
Code: [Select]
[31-03-2022_17-40-14] [INFO] OpenXcom Version: Extended 7.5.8 (v2022-03-24)
[31-03-2022_17-40-14] [INFO] Platform: Linux
[31-03-2022_17-40-14] [INFO] Data folder is:
[31-03-2022_17-40-14] [INFO] Data search is:
[31-03-2022_17-40-14] [INFO] - /home/deda/.local/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /usr/share/plasma/openxcom/
[31-03-2022_17-40-14] [INFO] - /home/deda/.local/share/flatpak/exports/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /var/lib/flatpak/exports/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /usr/local/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /usr/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /var/lib/snapd/desktop/openxcom/
[31-03-2022_17-40-14] [INFO] - /usr/local/share/openxcom/
[31-03-2022_17-40-14] [INFO] - /usr/share/openxcom/
[31-03-2022_17-40-14] [INFO] - ./
[31-03-2022_17-40-14] [INFO] User folder is: ./user/
[31-03-2022_17-40-14] [INFO] Config folder is: /home/deda/.config/openxcom/
[31-03-2022_17-40-14] [INFO] Options loaded successfully.
[31-03-2022_17-40-14] [INFO] SDL initialized successfully.
[31-03-2022_17-40-14] [INFO] SDL_mixer initialized successfully.
[31-03-2022_17-40-14] [INFO] Attempted locale: C.UTF-8
[31-03-2022_17-40-14] [INFO] Detected locale: C.UTF-8
[31-03-2022_17-40-14] [INFO] Attempting to set display to 1024x768x8...
[31-03-2022_17-40-14] [INFO] Display set to 1024x768x8.
[31-03-2022_17-40-14] [INFO] Loading data...
[31-03-2022_17-40-14] [INFO] Scanning standard mods in ''...
[31-03-2022_17-40-14] [INFO] Scanning user mods in './user/'...
[31-03-2022_17-40-14] [INFO] Active mods:
[31-03-2022_17-40-14] [INFO] - x-com-files v2.4
[31-03-2022_17-40-14] [INFO] - poetsreversedstatstrings v1.1
[31-03-2022_17-40-14] [INFO] - x-com-resound v2.30
[31-03-2022_17-40-16] [INFO] Loading begins...
[31-03-2022_17-40-16] [INFO] Pre-loading rulesets...
[31-03-2022_17-40-16] [INFO] Loading vanilla resources...
[31-03-2022_17-40-17] [INFO] Loading rulesets...
[31-03-2022_17-40-21] [INFO] Loading rulesets done.
[31-03-2022_17-40-21] [INFO] Loading fonts... Font.dat
[31-03-2022_17-40-21] [INFO] Lazy loading: 0
[31-03-2022_17-40-21] [INFO] Loading extra resources from ruleset...
[31-03-2022_17-40-30] [INFO] Loading custom palettes from ruleset...
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_DGOOD_ACID
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_DGOOD_SEA
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_DGOOD_SPACE
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_HEHEXD
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_MARS
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_MARS_LITE
[31-03-2022_17-40-30] [INFO] Creating a new palette: PAL_RED_SUN
[31-03-2022_17-40-30] [INFO] Making palette backups...
[31-03-2022_17-40-30] [INFO] After load.
[31-03-2022_17-40-30] [INFO] Supressed Error for 'STR_WESTMEN_INFORMANT': This unit can be recovered (in theory), but there is no corresponding item to recover.
[31-03-2022_17-40-30] [INFO] Supressed Error for 'STR_XCOM_BUZZER_UNIT': This unit can be recovered (in theory), but there is no corresponding item to recover.
[31-03-2022_17-40-30] [INFO] Supressed Error for 'STR_XCOM_CYBERMITE_UNIT': This unit can be recovered (in theory), but there is no corresponding item to recover.
[31-03-2022_17-40-30] [INFO] Loading ended.
[31-03-2022_17-40-30] [INFO] Data loaded successfully.
[31-03-2022_17-40-30] [INFO] Loading language...
[31-03-2022_17-40-30] [INFO] Language loaded successfully.
[31-03-2022_17-40-30] [INFO] OpenXcom started successfully!
[31-03-2022_17-40-30] [INFO] Playing flx, 320x200, 890 frames
[31-03-2022_17-40-30] [INFO] Using software scaling routine. For best results, try an OpenGL filter.
[31-03-2022_17-40-31] [INFO] SDL_mixer initialized successfully.
[31-03-2022_17-41-44] [INFO] Attempting to set display to 1024x768x8...
[31-03-2022_17-41-44] [INFO] Display set to 1024x768x8.
[31-03-2022_17-43-47] [FATAL] A fatal error has occurred: Segmentation fault.
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::CrossPlatform::stackTrace(void*)+0x3a) [0x55de86a9a491]
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::CrossPlatform::crashDump(void*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)+0x161) [0x55de86a9aa73]
[31-03-2022_17-43-47] [FATAL] ./openxcom(signalLogger(int)+0x58) [0x55de867df14e]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libc.so.6(+0x42520) [0x7f9fb4b70520]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libfluidsynth.so.2(+0x1169c) [0x7f9fb450769c]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libfluidsynth.so.2(delete_fluid_synth+0x5d) [0x7f9fb45254cd]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libSDL_mixer-1.2.so.0(fluidsynth_freesong+0x3f) [0x7f9fb5150b1f]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libSDL_mixer-1.2.so.0(Mix_FreeMusic+0x107) [0x7f9fb5143b67]
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::Music::~Music()+0x40) [0x55de86ae20ce]
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::Music::~Music()+0x1c) [0x55de86ae2114]
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::Mod::~Mod()+0x2e0) [0x55de86da77cc]
[31-03-2022_17-43-47] [FATAL] ./openxcom(OpenXcom::Game::~Game()+0x11c) [0x55de86ac9a94]
[31-03-2022_17-43-47] [FATAL] ./openxcom(main+0x1b4) [0x55de867df45c]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libc.so.6(+0x29fd0) [0x7f9fb4b57fd0]
[31-03-2022_17-43-47] [FATAL] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0x7d) [0x7f9fb4b5807d]
[31-03-2022_17-43-47] [FATAL] ./openxcom(_start+0x25) [0x55de867ae4a5]
[31-03-2022_17-43-49] [FATAL] OpenXcom has crashed: Segmentation fault.
Log file: ./user/openxcom.log
If this error was unexpected, please report it on OpenXcom forum or discord.
The following can help us solve the problem:
1. a saved game from just before the crash (helps 98%)
2. a detailed description how to reproduce the crash (helps 80%)
3. a log file (helps 10%)
4. a screenshot of this error message (helps 5%)

Can you help me pinpointing the issue?
Thank you!

Offline osd_daedalus

  • Sergeant
  • **
  • Posts: 31
    • View Profile
    • Email
Re: Huge FPS hit with 7.5.8, can you help me pinpoint the problem?
« Reply #1 on: March 31, 2022, 09:21:01 pm »
Aaaaandd... as always, after hitting my head very hard for 3 days, just as I post on forum I found the solution!

It's... I used to run cmake ..
I had to run cmake .. -DCMAKE_BUILD_TYPE=Release -DDEV_BUILD=OFF -DBUILD_PACKAGE=OFF

Much likely I was going so slow because I was playing a debug build...

Moral: always read at the sticky post!

BTW: the instructions on Linux compiling, as per https://openxcom.org/forum/index.php/topic,7048.msg111476.html#msg111476 ,  are somewhat outdated.
You don't need in Kubuntu 21.10 to compile separately yaml-cpp... if you do that you are going to get a lot of errors at the end of the source building.
Moreover, looks like there is no more need to create a build folder, it seems all is build in the bin folder.