aliens

Author Topic: New compatibility issues with Wine?  (Read 149 times)

Offline thevideogameraptorboggle

  • Colonel
  • ****
  • Posts: 165
    • View Profile
New compatibility issues with Wine?
« on: April 08, 2021, 08:46:17 pm »
I'm coming back to my XPiratez save after a long hiatus, only to find that the game refuses to boot. I upgraded my save exactly as described, and now I think it might be a compatibility issue with Open Xcom Extended. Is anyone else using Extended with wine and can help me?

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6793
  • OXCE developer
    • View Profile
    • My Wiki
Re: New compatibility issues with Wine?
« Reply #1 on: April 08, 2021, 08:56:30 pm »
Post a screenshot of the error message, and/or a log file, and/or anything that can help.

Just saying it doesn't work really doesn't help.

Offline thevideogameraptorboggle

  • Colonel
  • ****
  • Posts: 165
    • View Profile
Re: New compatibility issues with Wine?
« Reply #2 on: April 08, 2021, 10:53:08 pm »
Post a screenshot of the error message, and/or a log file, and/or anything that can help.

Just saying it doesn't work really doesn't help.

There is no error message and there is no log. It simply refuses to boot.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6793
  • OXCE developer
    • View Profile
    • My Wiki
Re: New compatibility issues with Wine?
« Reply #3 on: April 08, 2021, 10:56:09 pm »
There is no error message and there is no log. It simply refuses to boot.

Then it's a system issue, I would guess 64bit OpenXcom vs 32bit Windows/Wine.
Try 32bit version of OpenXcom: https://openxcom.org/forum/index.php/topic,5258.0.html

Offline thevideogameraptorboggle

  • Colonel
  • ****
  • Posts: 165
    • View Profile
Re: New compatibility issues with Wine?
« Reply #4 on: April 08, 2021, 11:44:33 pm »
Then it's a system issue, I would guess 64bit OpenXcom vs 32bit Windows/Wine.
Try 32bit version of OpenXcom: https://openxcom.org/forum/index.php/topic,5258.0.html

It seems to work, but I don't know how to get it to recognize Piratez.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6793
  • OXCE developer
    • View Profile
    • My Wiki
Re: New compatibility issues with Wine?
« Reply #5 on: April 09, 2021, 12:06:15 am »
It seems to work, but I don't know how to get it to recognize Piratez.

Piratez is just a mod, installed/recognized like any other mod.

Default Piratez download comes pre-packaged with OXCE, which makes everything more complicated, but you have basically two options:

Option 1:
- extract default Piratez package, and replace only the EXE file (replace the provided 64bit EXE with the 32bit EXE)
- run and enable Piratez mod (in the mods menu)

Option 2:
- install OXCE (and test if it runs)
- extract ONLY the mod from the Piratez download package (located in folder /user/mods/Piratez) and install it like any other mod