aliens

Author Topic: A few problems I noticed  (Read 866 times)

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
A few problems I noticed
« on: April 17, 2020, 07:24:31 pm »
1st: The UAC craft cannon is, on the buy menu, listed as STR_CRAFT_SYSTEM, which isn't defined for neither en-US nor en-UK, maybe a typo on either the translations or the cannon entry, also would recommend listing it as STR_CRAFT_ARMAMENT, since it fits better with it's purpose.

2nd: Whenever a Red Ops soldier is interrogated, only the combat analysis of the male model is unlocked, making so that I can't know the stats of female Red Ops soldiers while on the battlefield by middle clicking them.

3rd: this made me wheeze, maybe it was already fixed, but a tire dump in the middle of the road feels funny. (See first attachment)

Offline xcomfan

  • Colonel
  • ****
  • Posts: 308
    • View Profile
Re: A few problems I noticed
« Reply #1 on: April 17, 2020, 07:29:04 pm »
Please provide a  .sav file to find out in whar map it is :)

Online ohartenstein23

  • Commander
  • *****
  • Posts: 1855
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: A few problems I noticed
« Reply #2 on: April 17, 2020, 07:45:01 pm »
It's not a map problem, it's an OXCE problem. If you update your OXCE, future missions should not have tire dumps at crossroads, but it won't fix the mission you posted the picture about.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: A few problems I noticed
« Reply #3 on: April 17, 2020, 10:51:11 pm »
Please provide a  .sav file to find out in whar map it is :)
It's not a map problem, it's an OXCE problem. If you update your OXCE, future missions should not have tire dumps at crossroads, but it won't fix the mission you posted the picture about.

It wasn't a complaint about the save file, per se, but more of a complaint about the crossroads problem.

Offline vadracas

  • Colonel
  • ****
  • Posts: 279
  • Just another player/modder combo.
    • View Profile
Re: A few problems I noticed
« Reply #4 on: April 17, 2020, 11:03:18 pm »
They can't identify the problem easily without the save...

Online ohartenstein23

  • Commander
  • *****
  • Posts: 1855
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: A few problems I noticed
« Reply #5 on: April 17, 2020, 11:18:16 pm »
I'm saying I know exactly what the problem was because I wrote the code to fix it in OXCE. It is fixed, but you won't see it in that specific saved mission. The bug created a corrupted battlescape map, so you will have to start a new mission with a new map for it to be fixed.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: A few problems I noticed
« Reply #6 on: April 18, 2020, 02:44:22 am »
I'm saying I know exactly what the problem was because I wrote the code to fix it in OXCE. It is fixed, but you won't see it in that specific saved mission. The bug created a corrupted battlescape map, so you will have to start a new mission with a new map for it to be fixed.

So...
As surprising as it might be...
I am using the latest version.
Also, this is the XCom Files subforum, I think I was using an unfinished build of the sprites set...

Online Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 9914
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: A few problems I noticed
« Reply #7 on: April 19, 2020, 06:52:40 pm »
No, pretty sure the problem is fixed. It's been for some time. Your OXCE version is not up to date.

The strings should be fixed now, courtesy of Emil J. Schroeder.

The RedOps code dates back before paperdoll vision was a thing and also examination articles... I just have to refactor it.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: A few problems I noticed
« Reply #8 on: April 21, 2020, 02:30:43 pm »
No, pretty sure the problem is fixed. It's been for some time. Your OXCE version is not up to date.

The strings should be fixed now, courtesy of Emil J. Schroeder.

The RedOps code dates back before paperdoll vision was a thing and also examination articles... I just have to refactor it.

It is 6.4.2
It is the latest version, basically.
I was using an experimental version of XCF, though

Online ohartenstein23

  • Commander
  • *****
  • Posts: 1855
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: A few problems I noticed
« Reply #9 on: April 21, 2020, 02:50:46 pm »
6.4.2 is the latest release version, but it is not the latest version available, 6.4.4 is: https://lxnt.wtf/oxem/#/Extended

Online Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 9914
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: A few problems I noticed
« Reply #10 on: April 22, 2020, 01:26:19 pm »
6.4.2 is the latest release version, but it is not the latest version available, 6.4.4 is: https://lxnt.wtf/oxem/#/Extended

Eh? It hasn't been released yet? Oops.

Offline Thermite

  • Colonel
  • ****
  • Posts: 144
    • View Profile
Re: A few problems I noticed
« Reply #11 on: April 25, 2020, 01:49:44 am »
6.4.2 is the latest release version, but it is not the latest version available, 6.4.4 is: https://lxnt.wtf/oxem/#/Extended

That explains things