aliens

Author Topic: Trying to install OXCE V5.6.2 on Linux Mint?  (Read 5953 times)

Offline R1dO

  • Colonel
  • ****
  • Posts: 374
    • View Profile
    • Email
Re: Trying to install OXCE V5.6.2 on Linux Mint?
« Reply #15 on: September 03, 2019, 09:29:52 pm »
Just for some background.

It is expected that the following commands fail:
Code: [Select]
bash OpenXcomEx
bash OpenXcomEx.desktop
The reason is that "bash" expects to run script files. The first is a binary, the second is a file which tells your GUI how to run the associated binary.

The ".desktop" file is a (quickly written) workaround for a known bug in linux desktop environments dealing with some forms of binaries as created by modern "gcc", it is *NOT* a fault of  OXC(E).
The file is only necessary if you want to be able to run the program via double clicking from a file-manager application (shell as described by Meridian always work).

Offline The Martian

  • Commander
  • *****
  • Posts: 609
  • "It implores you to listen to its arguments..."
    • View Profile
Re: Trying to install OXCE V6.4.2 on Linux Mint?
« Reply #16 on: April 25, 2020, 09:34:56 am »
If you are trying to run OpenXcom Extended (V6.4.2) and get the following error when launching (From the terminal):
Code: [Select]
./OpenXcomEx: error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory

Try installing the prerequisites you would need to compile OXCE (Information can be found: HERE )
Code: [Select]
apt install git cmake build-essential libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-gfx1.2-dev zlib1g-dev
Once those libraries are installed try to launch OpenXcomEx again, it worked for me so hopefully it will work for anyone else who gets stuck with that error message.