Author Topic: Annoying game crash problem.  (Read 47 times)

Offline wcho035

  • Colonel
  • ****
  • Posts: 107
    • View Profile
Annoying game crash problem.
« on: September 11, 2019, 08:58:37 pm »
Hey guys, I have an annoying problem with this should be simple and obvious code in my starting condition.

For example.

startingConditions:
  - type: STR_UNDERWATERTEST
    defaultArmor:
      STR_SOLDIER:
        STR_NONE_UC : 100
    forbiddenCraft:
      - STR_MI_24_HIND          
    forbiddenArmors:   
      - STR_STANDARD_UC
    forbiddenSoldierTypes   
      - STR_DOGE
  - type: STR_UNDERWATERTESTMIDDEEP   
    defaultArmor:
      STR_SOLDIER:
        STR_NONE_UC : 100
    forbiddenCraft:
      - STR_MI_24_HIND          
    forbiddenArmors:   
      - STR_STANDARD_UC
    forbiddenSoldierTypes   
      - STR_DOGE

This is a simple code with two different type of starting condition. However, the game will boot up properly with only one type
working. If I stack more than two, this error happens. It says illegal map value. I uses a Notepad++ and the same error still persist.

Any clue is to why? I now currently have to have 2 separate startingcondition.ruls to prevent the game from crashing.
« Last Edit: September 11, 2019, 09:03:58 pm by wcho035 »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5171
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Annoying game crash problem.
« Reply #1 on: September 11, 2019, 10:04:22 pm »
Missing ":" after "forbiddenSoldierTypes"

Also, please use the ruleset validator, it will make your life easier.

Offline wcho035

  • Colonel
  • ****
  • Posts: 107
    • View Profile
Re: Annoying game crash problem.
« Reply #2 on: September 11, 2019, 10:09:07 pm »
Hey thanks again Meridian. Didn't notice of the small typo mistake.