Author Topic: Clicking on 'enemy 1' icon jumps to alien and then back  (Read 1149 times)

Offline Sander Bouwhuis

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Clicking on 'enemy 1' icon jumps to alien and then back
« on: August 14, 2019, 12:09:27 am »
Regularly, when I detect a new alien, clicking with the left mouse button on the red '1' icon fails.
The screen will jump to the alien and then immediately jump back to the soldier (all in much less than 1 second).
I then have to click the '1' icon a second time for the screen to jump to and stay on the alien.

Could this please be fixed?

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6595
  • OXCE developer
    • View Profile
    • My Wiki
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #1 on: August 14, 2019, 12:16:07 am »
OXC or OXCE?

(btw. I can't reproduce on either)

Offline Sander Bouwhuis

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #2 on: August 14, 2019, 11:09:50 am »
I'm currently playing on OXCE.

I'll provide a savegame tonight.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6595
  • OXCE developer
    • View Profile
    • My Wiki
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #3 on: August 14, 2019, 11:23:28 am »
I'm currently playing on OXCE.

I'll provide a savegame tonight.

Can you record a video showing what is happening?

Offline Sander Bouwhuis

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #4 on: August 14, 2019, 10:28:18 pm »
Sure, can you tell me how? Is there a program I can use to record video from X-Com?

Also, I downloaded the newest OpenXComExtended which claimed to be 2019-08-11, but when I start the game it says 2019-08-03. Is this a bug, or am I doing something wrong (tried downloading it 3 times with overwriting files).

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6595
  • OXCE developer
    • View Profile
    • My Wiki
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #5 on: August 14, 2019, 11:26:16 pm »
Sure, can you tell me how? Is there a program I can use to record video from X-Com?

Any video recording software should work... if you don't know how, just let it go.

Also, I downloaded the newest OpenXComExtended which claimed to be 2019-08-11, but when I start the game it says 2019-08-03. Is this a bug, or am I doing something wrong (tried downloading it 3 times with overwriting files).

Everything is ok, date in-game is not updated with every build.

Offline Sander Bouwhuis

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: Clicking on 'enemy 1' icon jumps to alien and then back
« Reply #6 on: August 14, 2019, 11:48:04 pm »
I tried Windows 'game bar', but it said it couldn't record the desktop (didn't recognize X-Com as a game?)
I tried Fraps, which could record. There was sound, but the screen was black (also couldn't record X-Com screen).

On a landed battleship mission I had it once. I think the icon was pink(?)
My soldier was on an elevator, and when I pressed the '1' icon it shortly jumped one level above the soldier and then jumped back down again. My soldier saw either a sectoid or one of those flying saucers (2x2 tiles) that explode when you kill them.

If you can't reproduce it, then never mind. I hate to take time from you. I already reported 4 bugs in the last week or so (all but this one got fixed!)