Author Topic: [SOLVED!] Game crashes at reaching June 1st 1999 (game time)  (Read 898 times)

Offline ThunderFromAbove

  • Sergeant
  • **
  • Posts: 18
    • View Profile
[SOLVED!] Game crashes at reaching June 1st 1999 (game time)
« on: November 28, 2018, 06:55:17 pm »
Hi folks,

hopefully there`s someone who can help me with my problem, that suddenly has arisen. Please forgive me, if this is the wrong forum...

So far the game ran quite smoothly. But at the turning of May 31st to June 1st it crashes again and again. The error message reads as follows:

"OpenXcom has crashed. Segmentation fault. This usually indicates something missing in a mod. More details here: E:\OpenXcom\user\openxcom.log
If this error was unexpected, please report it to the developers"


Well... Yes, it was "unexpected" - and also quite annoying. I attach the log file (to me the content of the file doesn`t mean anything).

I even tried to completely reinstall the game (using the newest availlable nightly 2018_11_22_0509.zip). Unfortunately it didn`t cure the problem: After loading the latest savegame and progress towards the turning of month May: The game still crashes.  :(

Any idea what I can do? I`d hate to start a new game, because I´ve already invested a lot of time to bring my troops to the present level of experience. Do you need any more information to narrow down the problem? But please be "patient", as I´m not very versed with the technical side of computers.... I`m always extremely happy, if everthing runs smoothly without any need of manual interference from me... (shame on me...!)   :-[

Thanks a lot in advance for any useful advice!
Kind regards
Thunder
« Last Edit: November 30, 2018, 03:35:54 pm by ThunderFromAbove »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5483
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Game crashes at reaching Juni 1st 1999 (game time)
« Reply #1 on: November 28, 2018, 06:56:52 pm »
Hi,

attach your save, it will help more.

Also looks like whatever mods you're using, they are not loading correctly...

M.
« Last Edit: November 28, 2018, 06:58:41 pm by Meridian »

Offline ThunderFromAbove

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Game crashes at reaching Juni 1st 1999 (game time)
« Reply #2 on: November 28, 2018, 07:14:03 pm »
Hi,

thanks for your quick reply! Yes, I was aware about the "error" references in the log file, because I tried to reinstall the game this time without any mods - as I hoped to avoid the problems this way, but which did not help at all...  :'(  Now I copied all the previously installed mods again into the "user" folder. But the crash still occures.

Attached now the "new" openxcom(2).log (showing the "result" after re-installing the previous mods) and the requested save game.

Kind regards
Thunder

Offline ThunderFromAbove

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Game crashes at reaching June 1st 1999 (game time)
« Reply #3 on: November 28, 2018, 07:41:44 pm »
Addition:
I don`t know, if it helps, but just in case it gives additional clues, here is also an attachment of the "options.cfg" file

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2131
    • View Profile
Re: Game crashes at reaching June 1st 1999 (game time)
« Reply #4 on: November 30, 2018, 02:21:43 am »
Were you playing around with mods? Your save data is missing the Pacific region, thus the crash. I assume you only enabled the Terrain Pack later in the game.
I've tried to patch up the missing stuff, but no guarantees. In the future, don't change major mods in the middle of a game.

Offline ThunderFromAbove

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Game crashes at reaching June 1st 1999 (game time)
« Reply #5 on: November 30, 2018, 03:35:06 pm »
Dear SupSuper,

THANKS!!!!

Your patch worked like a miracle! That was - as your nickname suggested - absolutely SUPER;D ;D ;D

You´re right: I turned some of the mods on or off quite frequently during gameplay. But so far I did not notice any problems with this. Until now....  :-[  I especially quite often turn on or off "new UFO types", "YetMoreUFOs 0.6" and "Solars New Ufos" because after shooting down a UFO it happens relatively often with those mods enabled, that at least one of the powersources is still intact and I can capture the Elerium.

And the reason for disable the Terrain Pack is, that saving and loading during a battle is quite slow with it enabled...

I`m sorry to have caused any inconvenience because of my (unintentional...!) foolishness!

Thanks again for your help und kind regards
Thunder
« Last Edit: November 30, 2018, 03:46:08 pm by ThunderFromAbove »