Author Topic: [Solved, but advises are welcome] Intro: font colour and music  (Read 334 times)

Offline tkzv

  • Commander
  • *****
  • Posts: 555
    • View Profile
[Solved, but advises are welcome] Intro: font colour and music
« on: November 21, 2018, 12:48:53 am »
I made the following intro:
Code: [Select]
cutscenes:
  - delete: intro
  - type: intro
    useUfoAudioSequence: true
    slideshow:
      transitionSeconds: 30
      slides:
        - imagePath: cutscenes/1.png
          caption: STR_INTRO0
          captionColor: 253
        - imagePath: cutscenes/2.png
          ...
1. Slides show correctly, although there are small colour glitches. Is there any way to get rid of them? Besides using the same palette for all slides.

2. Text uses the same palette, and more than one colour. Not much of a problem for one of the standard palettes, but troublesome for autogenerated palettes with random colour order. Is there a way to set all colours the text uses? If no, which colours will appear for filling, border and corners relative to 253?

ANSWER: For "captionColor: 0" the font seems to use colours:
1 for solid fill,
2 for anti-aliased pixels which are closer to fill colour, e.g. rounded parts,
4 for anti-aliased pixels which are closer to border colour, sort of serifs,
5 for border.
See the attached "font-drawing.png" and "font-drawingX10.png" (palette is at the bottom, orange is for unused colours).

I guess, for 253 it would be 254, 255, 1 and 2.

3. Is it possible to set custom intro music?

ANSWER: Yes. "Land of Sand - DUNE Total Conversion" has a good example. https://openxcom.org/forum/index.php/topic,2957.0.html

Spoiler:
I set "useUfoAudioSequence: true" and tried
Code: [Select]
extraSounds:
  - type: INTRO.CAT
    files:
      0: music/music.wav
      1: music/music.wav
...
      99: music/music.wav
with 11kHz and 8kHz 16- and 8-bit, stereo and mono. I got no sound.

P.S. I used ruleset reference for OXC nightly, but I'm running OXCE+.

P.P.S. There's no intro sound even without extraSounds.rul file.

Working music example:
A. Put music files to "SOUND" directory. OGG and MOD worked fine, but WAVs were distorted.

B. Describe the music files:
Code: [Select]
musics:
  # SOUND/CONSPIRI.MOD
  - type: CONSPIRI
    normalization: 2
  # SOUND/music-stereo.wav
  - type: music-stereo
    normalization: 2
  # SOUND/fog.ogg
  - type: fog
    normalization: 2
"type" is the name of a file in "Sound" folder without extension. I don't know what "normalization" is for, but the music seems the same without it or with different values.

C. Refer to them in the cutscenes section:
Code: [Select]
cutscenes:
  - delete: intro
  - type: intro
    slideshow:
      musicId: CONSPIRI
      slides:
        - imagePath: cutscenes/dump-1.png
          caption: STR_INTRO0
          captionColor: 253
          transitionSeconds: 10
        - imagePath: cutscenes/dump-2.png
...
« Last Edit: December 10, 2018, 01:29:57 am by tkzv »