Author Topic: Freeze with OXCE during Area51  (Read 1122 times)

Offline Fox Mulder

  • Squaddie
  • *
  • Posts: 7
    • View Profile
Freeze with OXCE during Area51
« on: October 09, 2018, 04:07:15 pm »
Quote from: Fox Mulder on Today at 03:11:39 pm
Hi, Hobbes, I went in a freeze after having mind controlled a snakeman engineer with blaster launcher; trying to fire, the game freeze for some second, than moving the alien freezed again, trying to close the game with "x" a popup message appeared with: OpenXcom has crashed: Segmentation fault. This usually indicates something missing in a mod. Looking in the openxcom.log I found:
[09-10-2018_14-03-10]   [FATAL]   A fatal error has occurred: Segmentation fault. This usually indicates something missing in a mod.
[09-10-2018_14-03-10]   [FATAL]   ??
[09-10-2018_14-03-10]   [FATAL]   ??
[09-10-2018_14-03-10]   [FATAL]   0x77ce5030 RtlKnownExceptionFilter
[09-10-2018_14-03-10]   [FATAL]   0x77ca979f RtlInitializeExceptionChain
[09-10-2018_14-09-21]   [FATAL]   OpenXcom has crashed: Segmentation fault. This usually indicates something missing in a mod.
Hope this can help

Edit: If I didn't try to mind control anyone it works, saves too, now crashes always when clicking abandon game and the yes for exit
EndQuote

Hi,

From your description this involves none of the mod's content, since Mind Control, Snakemen and Blaster Launchers are a part of the vanilla game and I have changed nothing regarding them. You should report this to the OXC developers instead (or OXCE, if you are using it)

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 6814
  • OXCE developer
    • View Profile
    • My Wiki
Re: Freeze with OXCE during Area51
« Reply #1 on: October 09, 2018, 04:13:29 pm »
can you attach the save?

Offline Fox Mulder

  • Squaddie
  • *
  • Posts: 7
    • View Profile
Re: Freeze with OXCE during Area51
« Reply #2 on: October 10, 2018, 01:23:17 pm »
Yes, if needed, but now it is not happening anymore, I only stopped to use mind control. One last thing, debug mode was active. I will try to reload the mission where it happened and if it happens again I will post the .sav

Edit: I reloaded the mission and when I tried to save, the game has been saved, when click on abandon and then on yes it crashed. This is the .sav made before crashing
« Last Edit: October 10, 2018, 01:34:19 pm by Fox Mulder »