aliens

Author Topic: OXCE v7.8 MacOS  (Read 27092 times)

Offline Fox Mulder

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: OXCE v7.4.2 MacOS
« Reply #30 on: January 18, 2022, 09:54:50 pm »
Ok, for now I fixed the problem,
I used the 32 bit windows version on Macos Monterey, using a "wrapper" made with the porting kit by Paulthetall from his site.
Only the size.. from original 35 mb to 750mb, but it makes a sort of box for wine. Not the best like before, but I like to play with Area51 and OXCE and for now this is the simplest way, other would be use a virtualized win or a bootcamp


Offline nl255

  • Squaddie
  • *
  • Posts: 8
    • View Profile
Re: OXCE v7.4 MacOS
« Reply #31 on: April 01, 2022, 04:22:07 pm »
No sorry, BigSur and Monterey are not supported at all... and likely won't be supported for a long time.
(There's no fix for it, Apple just dropped support for the technology we use; and upgrading to newer technology is difficult.)

End of January is just when I will update the package from 7.1.4 to 7.4 (or the newest at that time).
Support is only for Catalina and older.

Is it just the use of SDL 1.2 (instead of SDL 2) that is the problem or are there other things that make it not work?

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 7729
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #32 on: April 01, 2022, 04:51:37 pm »
Is it just the use of SDL 1.2 (instead of SDL 2) that is the problem or are there other things that make it not work?

I assume it is just the use of SDL 1.2, yes.

But I can't upgrade my Macbook higher than 10.15 (Catalina), so can't be 100% sure.

Offline domq

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #33 on: April 01, 2022, 07:41:24 pm »
Hey Meridian, many thanks for your work on this game!

Just FYI, I just successfully built and ran OpenXCom on the latest Mac OS X Monterey 12.3.1 (21E258); see attached. I used the Mac OS X-specific instructions from README-OSX.md at the OpenXcom/OpenXcom GitHub depot, under § “Make” (I can't afford Xcode disk-space-wise). I would post a link but...


Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 7729
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #34 on: April 01, 2022, 07:57:13 pm »
Maybe it magically started working, but there's no way for me to know.

If someone else can confirm, that would give us hope.
(Until now, I had only negative reports.)

Offline domq

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #35 on: April 01, 2022, 09:15:43 pm »
Would you like me to upload the binary somewhere?

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 7729
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #36 on: April 01, 2022, 09:28:13 pm »
yes please

you should be able to upload here as well, after two posts you have full posting rights
« Last Edit: April 01, 2022, 09:51:32 pm by Meridian »

Offline domq

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #37 on: April 01, 2022, 11:21:43 pm »
Here you go! As per usual, one should populate /Applications/openxcom.app/Contents/Resources/UFO/ with a legitimately-owned copy of the original game after installing.

(The previous, deleted message was me forgetting that I should not upload an image containing a populated copy of this directory. D'oh!)

Offline Fox Mulder

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #38 on: April 02, 2022, 03:22:39 pm »
Good work domq!
I downloaded it and can confirm it works perfectly on my monterey 12.3, also with Area51 and Area51 patch
I'm happy to have checked often to see if something changed.
Thank You domq, now I can trash the 750mb wrapper I built to play it like a porting and start to play it again in native macos

Only a question.. why it says 7.5.8 and in the site there is 7.5.3?
« Last Edit: April 02, 2022, 03:36:50 pm by Fox Mulder »

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 7729
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #39 on: April 02, 2022, 03:39:56 pm »
Good work domq!
I downloaded it and can confirm it works perfectly on my monterey 12.3

That's good news!

Only a question.. why it says 7.5.8 and in the site there is 7.5.3?

That's just because he built the newest (not yet officially released) version.

Offline Fox Mulder

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #40 on: April 02, 2022, 04:00:16 pm »
Obviously a great Thank You also to You, Meridian, for all your patience and good work!
There is a small thing, ininfluent on the game, just to let You and domq know.. if I use a resolution greater than 1440x810, on the right of the geoscape, up, over the Intercept button, it is shown a "50:20" ...? I repeat it is ininfluent, also because I prefer the 1440x810 and in this resolution it is not visible, just a curiosity. There is also on older version, windows and mac (Mojave) before 7.5.3, so it is not domq work related.


« Last Edit: April 02, 2022, 04:07:35 pm by Fox Mulder »

Offline Fox Mulder

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #41 on: April 02, 2022, 04:10:03 pm »
Here is an img:

Offline Meridian

  • Global Moderator
  • Commander
  • ***
  • Posts: 7729
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #42 on: April 02, 2022, 04:10:47 pm »
Here is an img:

That is actually a feature.
It shows you the number of unassigned scientists and engineers.

Offline Fox Mulder

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #43 on: April 02, 2022, 04:12:17 pm »
Thank You again Meridian for the info

Offline nl255

  • Squaddie
  • *
  • Posts: 8
    • View Profile
Re: OXCE v7.5.3 MacOS
« Reply #44 on: April 02, 2022, 05:46:42 pm »
Hey Meridian, many thanks for your work on this game!

Just FYI, I just successfully built and ran OpenXCom on the latest Mac OS X Monterey 12.3.1 (21E258); see attached. I used the Mac OS X-specific instructions from README-OSX.md at the OpenXcom/OpenXcom GitHub depot, under § “Make” (I can't afford Xcode disk-space-wise). I would post a link but...

Are you using the same sdl 1.2 to sdl 2.0 translation layer (https://github.com/libsdl-org/sdl12-compat) that I am using on my retro handheld (aarch64/linux/kmsdrm) port?