Author Topic: [SOLVED] Trouble with creating a bundle of OXCE+ on MacOS  (Read 3073 times)

Offline UnholyAngel

  • Sergeant
  • **
  • Posts: 28
    • View Profile
[SOLVED] Trouble with creating a bundle of OXCE+ on MacOS
« on: July 30, 2018, 02:10:58 pm »
I've been building my own executables for OSX of OXCE+ for a while and with the most recent version the process fails at the when it tries to create a bundle.

Could help me to make sense of the error message I get?

Code: [Select]
[100%] Linking CXX executable ../openxcom.app/Contents/MacOS/openxcom
-- fixup_bundle
--   app='/Users/***/Documents/OpenXcomExPlus\ Git/build/openxcom.app'
--   libs=''
--   dirs=''
--   ignoreItems=''
-- warning: *NOT* handled - directory/file does not exist...
CMake Error at /usr/local/Cellar/cmake/3.11.1/share/cmake/Modules/BundleUtilities.cmake:966 (message):
  error: fixup_bundle: not a valid bundle
Call Stack (most recent call first):
  /Users/***/Documents/OpenXcomExPlus Git/cmake/modules/PostprocessBundle.cmake:33 (fixup_bundle)


-- fixup_bundle: done
make[2]: *** [openxcom.app/Contents/MacOS/openxcom] Error 1
make[2]: *** Deleting file `openxcom.app/Contents/MacOS/openxcom'
make[1]: *** [src/CMakeFiles/openxcom.dir/all] Error 2
make: *** [all] Error 2
« Last Edit: February 02, 2023, 09:43:31 pm by Meridian »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8709
    • View Profile
Re: Trouble with creating a bundle of OXCE+ on MacOS
« Reply #1 on: July 30, 2018, 02:25:41 pm »
Hi,

there have been changes in the recent nightlies... which I am continually cherry-picking... just now I pushed 6 more commits from OXC.
Please try if it works now.

If not, try to contact "rcreasey" on OpenXcom Discord channel; or on Github: http://github.com/rcreasey
He also recently updated the build notes, maybe worth reading: https://www.ufopaedia.org/index.php/Compiling_with_Xcode_(OpenXcom)

M.

Offline UnholyAngel

  • Sergeant
  • **
  • Posts: 28
    • View Profile
Re: Trouble with creating a bundle of OXCE+ on MacOS
« Reply #2 on: July 30, 2018, 04:49:46 pm »
Pulling the newest versiot from git ... didn't help.

Updating cmake to the current version ... didn't help.

Removing one stupid space from (that never was an issue before) from the directory name

... and suddenly it works like a charm.

So frustrated grumbling aside it works now.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8709
    • View Profile
Re: Trouble with creating a bundle of OXCE+ on MacOS
« Reply #3 on: July 30, 2018, 10:51:48 pm »
Which directory name?

Offline UnholyAngel

  • Sergeant
  • **
  • Posts: 28
    • View Profile
Re: Trouble with creating a bundle of OXCE+ on MacOS
« Reply #4 on: July 30, 2018, 11:57:04 pm »
The directory I have the have my local git clone in used to named "OpenXcomExPlus Git" renaming it to "OpenXcomExPlusGit" resolved my problem.

At least I think so since everything else was unchanged.