Author Topic: 40k Bug/crashes/problem´s report  (Read 31043 times)

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 557
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #195 on: March 04, 2020, 11:42:02 am »
send save, screenshot. what inventory, what mission?

Offline Irismono

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #196 on: March 04, 2020, 10:48:15 pm »
send save, screenshot. what inventory, what mission?

It seems to be any mission, any inventory set up, and only occurs when I try to change what soldier I'm looking at. I'm going to try a reinstall first just in case something extracted wrong, If I still have issues I'll provide a save file.

Edit: Alright, turns out I installed it wrong, it's working now, my space marines are being crushed by Orks.
« Last Edit: March 04, 2020, 11:54:28 pm by Irismono »

Offline lizard_mem

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #197 on: March 08, 2020, 12:44:47 pm »
minor boo-boo. looking under resources_ig when the ork convoy png is under resources. occurs on interception

Offline lizard_mem

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #198 on: March 09, 2020, 07:02:21 am »
fixed the ork convoy image temporarily by putting the file into where it was looking, but now i've discovered some issues with intercepting orks. provided save file has a load of orks buzzin' about and i usually can't shoot em all down without a crash. sorry if these issues are already known, i aint a community person.

Offline Guardsman #4287

  • Squaddie
  • *
  • Posts: 1
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #199 on: March 29, 2020, 12:25:30 am »
I have started a new month and already in the first 30-50 mins, it keeps crashing. Her are the issues below.

Offline N00b45454

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #200 on: April 01, 2020, 06:30:00 pm »
My game seems to crash whenever I load a save while doing an enemy base attack mission. I'm not sure whether it is an issue with the mod or with OXCE. The only save file that doesn't crash is the one in the geoscape prior to attacking the base.

Not sure if it helps but I am using the imperial guard faction for the playthrough.


Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 557
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #201 on: April 01, 2020, 07:14:18 pm »
If you're getting a crash with an error that says something along the lines OpenXcom has crashed: vector::_M_range_check: __n (which is 1) >= this->size() (which is 1) updating OXCE (the date should be after 2020-02-06) to a newer version may help.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 557
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #202 on: April 01, 2020, 07:14:59 pm »
My game seems to crash whenever I load a save while doing an enemy base attack mission. I'm not sure whether it is an issue with the mod or with OXCE. The only save file that doesn't crash is the one in the geoscape prior to attacking the base.

Not sure if it helps but I am using the imperial guard faction for the playthrough.


Send Save

Offline N00b45454

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #203 on: April 01, 2020, 07:30:16 pm »


Send Save

Here are my saves, as well as the log.
ScapeB being the save during the base raid.
Geoscape is the save prior to doing the mission.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 557
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #204 on: April 01, 2020, 08:23:14 pm »
i see, this bug happen before, the one who resolved was oarthstein23, i will tell him to get help u when we gets here

Offline N00b45454

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #205 on: April 01, 2020, 08:30:02 pm »
i see, this bug happen before, the one who resolved was oarthstein23, i will tell him to get help u when we gets here

Alright, thanks for looking at it. In the meantime I'll just ignore the enemy base and do some other missions.

Offline N00b45454

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #206 on: April 01, 2020, 11:00:04 pm »
I'm not sure whether this issue I have is save-dependent but I'm giving up on the save I attached in the previous message. I'm not sure whether this issue may reappear in my new save, however, I'm giving up this current imperial guard run and starting a new one. It's not due to how I'm now going up against terminators while my swarm of imperial guards only have lascarbines and a few bolters, but the fact that I discovered another base other than the bugged base indicating that there are 5 other enemy bases, one of which is filled with terminators, excluding the traitor guard one.

Online ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1828
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #207 on: April 03, 2020, 04:15:06 am »
snip

It will happen any time you try to load a save from any tier 2 or tier 3 traitor guard base in battlescape, there's a bug in the map script. I'm working on a fix, looking both at my OXCE code that touches this and my map script, but it won't fix your save file ScapeB or any other battlescape save with this bug. It will allow you to start new missions and save/load them. I'll post the fix here once I have time/energy to fix it.

Edit: Replace the mapScripts_40k.rul file in the 40k/Ruleset folder with the one below to fix the problem.

Offline ShinobiShiba

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #208 on: April 17, 2020, 03:49:18 am »
So i've recently installed this mod and randomly if i quit the game and relaunch it again. It breaks Openxcom Extended and i'm no longer able to play the 40k mod unless i delete Extended Xcom entirely and reinstall. So i can't even get to the main menu.


Online ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1828
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #209 on: April 17, 2020, 04:07:03 am »
Do you have the latest version of the mod (version 024)? That bug is from some missing resources in the mod, but I was pretty sure we fixed that in the current release version.