Author Topic: Using latest linux executable with xpiratez  (Read 758 times)

niculinux

  • Guest
Using latest linux executable with xpiratez
« on: January 19, 2019, 11:14:31 am »
Since the executable provided with the game is the one for windows, using some updated one in linux may cause trouble or the game/mod won't start at all.

For examplle, using the latest Extended 5.2 (v2019-01-16) cause the error at the bottom of the log and game quits.

Code: [Select]
[19-01-2019_10-07-29] [INFO] OpenXcom Version: Extended 5.2 (v2019-01-16)
[19-01-2019_10-07-29] [INFO] Platform: Unix-like
[19-01-2019_10-07-29] [INFO] Data folder is:
[19-01-2019_10-07-29] [INFO] Data search is:
[19-01-2019_10-07-29] [INFO] - /home/nicola/.local/share/openxcom/
[19-01-2019_10-07-29] [INFO] - /etc/xdg/lubuntu/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/local/share/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/share/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/share/gdm/openxcom/
[19-01-2019_10-07-29] [INFO] - /var/lib/menu-xdg/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/share/Lubuntu/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/local/share//openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/share//openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/local/share/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/share/openxcom/
[19-01-2019_10-07-29] [INFO] - /usr/local/share/openxcom//
[19-01-2019_10-07-29] [INFO] - ./
[19-01-2019_10-07-29] [INFO] User folder is: ./user/
[19-01-2019_10-07-29] [INFO] Config folder is: /home/nicola/.config/openxcom/
[19-01-2019_10-07-29] [INFO] Options loaded successfully.
[19-01-2019_10-07-29] [INFO] SDL initialized successfully.
[19-01-2019_10-07-29] [INFO] SDL_mixer initialized successfully.
[19-01-2019_10-07-29] [INFO] requested file not found: openxcom.png
[19-01-2019_10-07-29] [INFO] Attempted locale: C.UTF-8
[19-01-2019_10-07-29] [INFO] Detected locale: C.UTF-8
[19-01-2019_10-07-29] [INFO] Attempting to set display to 1280x971x8...
[19-01-2019_10-07-29] [INFO] Display set to 1280x971x8.
[19-01-2019_10-07-29] [INFO] Loading data...
[19-01-2019_10-07-29] [INFO] Scanning standard mods in 'standard'...
[19-01-2019_10-07-29] [INFO] Scanning user mods in './user/mods'...
[19-01-2019_10-07-29] [INFO] reservedSpace for: piratez is: 4
[19-01-2019_10-07-29] [INFO] reservedSpace for: xcom1 updated to: 4
[19-01-2019_10-07-29] [INFO] Mapping resource files...
[19-01-2019_10-07-29] [INFO] Resources files mapped successfully.
[19-01-2019_10-07-29] [INFO] Loading rulesets...
[19-01-2019_10-07-38] [ERROR] Error linking 'STR_ENVIRO_COLD' in startingConditions: Armor STR_STR_SCOUT_OUTFIT_UC not found

I have an installation of xpiratez on a linux machine but accidentally erased the 27/12/2018 executable (required by 0.99J10), once i get from Stoddart's builds page, but i've noticed that the linux ones are constantly updated than the win one, so no way to get an older version for linux?

Also, attached a screenshot.

Edit: vannilla openxcom starts without problems.
« Last Edit: January 19, 2019, 11:24:00 am by niculinux »

Offline Stoddard

  • Colonel
  • ****
  • Posts: 457
  • in a fey mood
    • View Profile
    • Linux builds & stuff
Re: Using latest linux executable with xpiratez
« Reply #1 on: January 19, 2019, 01:21:05 pm »
I play with with the latest code available and I had no problems yesterday.

i think I saw this one "STR_ENVIRO_COLD blah blah STR_STR_blah blah" and it's just a typo in the mod.
Do a search on ruleset files for STR_STR_ and replace it with just STR_

niculinux

  • Guest
Re: Using latest linux executable with xpiratez
« Reply #2 on: January 26, 2019, 07:27:34 pm »
I play with with the latest code available and I had no problems yesterday.

i think I saw this one "STR_ENVIRO_COLD blah blah STR_STR_blah blah" and it's just a typo in the mod.
Do a search on ruleset files for STR_STR_ and replace it with just STR_

The problem seems to be in Piratez_Planet.rul; the STR_SCOUT_OUTFIT is written as  STR_STR_SCOUT_OUTFIT. Now ithe game starts. The typo affects 0.99J10 verison; so it you use it along a more recent executable, be sure to fix the file!

But I'd like to leave the thread unsolved, because i've also noticed that newer executables have sometimes strange behavior; fonr instance i remember the medikit applying screen in battlescape did not show the human silhouette, also primed grenades won't show the red spot.

Usin the 01-23-2019 version and all of a sudden military supply and some other prizes disappeared from manufacture?! Is it intended or it's a bug? I downloaded again the 01-12-2019 version but still the same. Save game was altered?

Edit: luckily i have a save file this time
« Last Edit: January 26, 2019, 07:38:59 pm by niculinux »

niculinux

  • Guest
Re: Using latest linux executable with xpiratez
« Reply #3 on: January 30, 2019, 01:36:47 pm »
Here, the 0.99J11 is up, here is the proper executable file, for those who want to give a shot :) (anyaway it is ubuntu only)