Author Topic: Openxcom messing with Windows language settings?  (Read 1936 times)

Offline Markus Ramikin

  • Captain
  • ***
  • Posts: 83
    • View Profile
Openxcom messing with Windows language settings?
« on: February 09, 2017, 10:44:50 pm »
I have 3 languages/keyboards installed in my system, for switching around with alt-shift. English is NOT one of them.

When I start openxcom - and as far as I can tell, only then, no other program does this - English gets added to the keyboards I can choose with alt-shift.

To make it even more weird, the English option does NOT get added to the "language preferences" list. If I go into those options to remove it, I need to manually add it first, and only then can I remove it. Then it disappears from the alt-shift list as well, at least until I play openxcom again.

This is obviously not what I would call desireable behaviour from a game...

Other info: my system is Windows 10. Openxcom display language can be English, or it can be something else, it doesn't stop the behaviour.
« Last Edit: February 09, 2017, 10:47:34 pm by Markus Ramikin »

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2334
  • Developer
    • View Profile
    • Email
Re: Openxcom messing with Windows language settings?
« Reply #1 on: February 10, 2017, 01:04:10 am »
just for the record, this is more likely an issue with SDL than openxcom.
it _MAY_ be fixed in SDL 2.0 but i'm not sure, you'd have to check their repo.
unfortunately, at the time of writing, SDL 2.0 isn't supported by openxcom in an official capacity.
there ARE 2.0 versions available (courtesy of sfalexrog) but i'm not entirely certain how up-to-date that repo is.

Offline Markus Ramikin

  • Captain
  • ***
  • Posts: 83
    • View Profile
Re: Openxcom messing with Windows language settings?
« Reply #2 on: February 11, 2017, 01:27:07 am »
Ah well, I'll just let it stay until I've had enough openxcom for a while.

Thanks for the answer!
« Last Edit: February 11, 2017, 02:03:17 am by Markus Ramikin »