aliens

Author Topic: Rasp Pi - OpenXcom screen flicker  (Read 3353 times)

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Rasp Pi - OpenXcom screen flicker
« on: December 25, 2016, 06:21:40 pm »
I was able to get Openxcom built and running on a Raspberry Pi, but when I launch the screen has significant flickering. It seems to lessen when I set the resolution t around 1024x768, but I couldn't get it 100% working. Are there any common troubleshooting steps I can try?

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7362
    • View Profile
Re: Rasp Pi - OpenXcom screen flicker
« Reply #1 on: December 25, 2016, 06:26:28 pm »
I was able to get Openxcom built and running on a Raspberry Pi, but when I launch the screen has significant flickering. It seems to lessen when I set the resolution t around 1024x768, but I couldn't get it 100% working. Are there any common troubleshooting steps I can try?

Can you make and attach a screenshot of OpenXcom video settings you're using?

EDIT: also I read on wikipedia
Quote
While operating at 700 MHz by default, the first generation Raspberry Pi provided a real-world performance roughly equivalent to 0.041 GFLOPS.[13][14] On the CPU level the performance is similar to a 300 MHz Pentium II of 1997–99.

You'll probably need something better than this to run OpenXcom.
It has higher hardware requirements than the original xcom from 1994.

Which generation of Rasp Pi do you have?
« Last Edit: December 25, 2016, 06:42:23 pm by Meridian »

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #2 on: December 25, 2016, 07:02:02 pm »
Grab of the video settings screen is attached. I should mention that the opening cutscene doesn't flicker, it only starts once the main menu comes up (and does persist in the geoscape/battlescape).

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #3 on: December 25, 2016, 07:10:01 pm »
It is a Raspberry Pi B+, so not quite first generation. It's able to run SNES emulators out of the HDMI without problems.

I've also attached "options.cfg" in case that has any more indepth settings.

« Last Edit: December 25, 2016, 07:29:17 pm by mekasha »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7362
    • View Profile
Re: Rasp Pi - OpenXcom screen flicker
« Reply #4 on: December 25, 2016, 07:57:33 pm »
Options look OK.

From what I can google, B+ is the first generation: https://www.raspberrypi.org/products/model-b-plus/
I might be wrong though.

Last thing I would check is if you have compiled OpenXcom in Debug mode or Release mode... Debug being slower... you want Release.
Other than that, I guess it's hardware.

PS: OpenXcom is not an emulator for original Xcom, it's a completely new application... you may want to try running dosbox+original xcom too, it may run a lot faster
« Last Edit: December 26, 2016, 02:40:46 am by Meridian »

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #5 on: December 25, 2016, 07:59:51 pm »
I couldn't get CMake to work, is there a way to change it to compile in debug using just the included Make file?

Offline Yankes

  • Commander
  • *****
  • Posts: 2680
    • View Profile
Re: Rasp Pi - OpenXcom screen flicker
« Reply #6 on: December 25, 2016, 11:38:49 pm »
in make you can switch in that line: https://github.com/SupSuper/OpenXcom/blob/master/src/Makefile.simple#L31
`-O2` or `-O3` is usually used release mode (from https://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html ).

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #7 on: December 26, 2016, 07:17:12 pm »
Building in release didn't fix it, but I'm going to order an RP gen 3 and see if that will handle it. Thanks for the help guys.

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2165
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #8 on: December 27, 2016, 01:41:03 am »
If it's a performance issue, you can try lowering the FPS in the settings as well.

Offline mekasha

  • Sergeant
  • **
  • Posts: 10
    • View Profile
    • Email
Re: Rasp Pi - OpenXcom screen flicker
« Reply #9 on: December 30, 2016, 12:28:28 am »
You seem to be correct. I got my RP3 today but it was the same, however lowering the FPS to 20 seems to have fixed it. It does look to be the cutoff point, as 25 still allows some tearing.