Author Topic: Bugs, crashes, typos & bad taste  (Read 179244 times)

Offline HinterDemGlas

  • Sergeant
  • **
  • Posts: 13
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1590 on: December 15, 2018, 11:17:04 am »
Re: Underwater Operations: I got the T'Leth Embassy pretty early and because I was in a tight spot I had 1 agent and 3 dogs on board. I don't remember any warnings what would happen to the dogs. I aborted the mission and haven't seen it since.

Offline Kieso

  • Squaddie
  • *
  • Posts: 7
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1591 on: December 16, 2018, 12:15:41 am »
OS: Win7 P / 32bits ServicePack1
Xcomfiles v 0.9.7.
Extended 5.1 (v2018-12-02)
Time Game September 1998

Hello
I am very happy with what I discovered in this mod. It's the first time I play it and I'm gradually discovering things. I love the variety of types of missions that force me to adapt the equipment to each one. Thanks for this work. Now, I went out for the first time an oozec mission and after shooting the killer gelatin. I got the error:
OpenXcom has crashed: Invlid surface set OOZEC.PCK for armor STR_OOZE_ARMOR: not enought frames
More details here: C: /Users/Compras/Desktop/openxcom_xfiles_0.9.7.c/user/openxcom.log

detail of openxcom.log

[15-12-2018_18-00-59]   [INFO]   OpenXcom Version: Extended 5.1 (v2018-12-02)
[15-12-2018_18-00-59]   [INFO]   Platform: Windows
[15-12-2018_18-00-59]   [INFO]   Data folder is:
[15-12-2018_18-00-59]   [INFO]   Data search is:
[15-12-2018_18-00-59]   [INFO]   - C:\Users\Compras\Documents\OpenXcom\
[15-12-2018_18-00-59]   [INFO]   - C:\Users\Compras\Desktop\openxcom_xfiles_0.9.7c
[15-12-2018_18-00-59]   [INFO]   - C:\Users\Compras\Desktop\openxcom_xfiles_0.9.7c
[15-12-2018_18-00-59]   [INFO]   User folder is: C:\Users\Compras\Desktop\openxcom_xfiles_0.9.7c\user\
[15-12-2018_18-00-59]   [INFO]   Config folder is: C:\Users\Compras\Desktop\openxcom_xfiles_0.9.7c\user\
[15-12-2018_18-00-59]   [INFO]   Options loaded successfully.
[15-12-2018_18-00-59]   [INFO]   SDL initialized successfully.
[15-12-2018_18-00-59]   [INFO]   SDL_mixer initialized successfully.
[15-12-2018_18-00-59]   [INFO]   requested file not found: openxcom.png
[15-12-2018_18-00-59]   [INFO]   Attempted locale:
[15-12-2018_18-00-59]   [INFO]   Detected locale: C
[15-12-2018_18-00-59]   [INFO]   Attempting to set display to 1024x768x8...
[15-12-2018_18-00-59]   [INFO]   Display set to 1024x768x8.
[15-12-2018_18-00-59]   [INFO]   Loading data...
[15-12-2018_18-01-00]   [INFO]   Scanning standard mods in 'standard'...
[15-12-2018_18-01-00]   [INFO]   Scanning user mods in 'C:\Users\Compras\Desktop\openxcom_xfiles_0.9.7c\user\mods'...
[15-12-2018_18-01-00]   [INFO]   reservedSpace for: xcom1 updated to: 2
[15-12-2018_18-01-00]   [INFO]   Mapping resource files...
[15-12-2018_18-01-07]   [INFO]   Resources files mapped successfully.
[15-12-2018_18-01-07]   [INFO]   Loading rulesets...
[15-12-2018_18-01-17]   [INFO]   Loading fonts... Font.dat
[15-12-2018_18-01-23]   [INFO]   Loading custom palettes from ruleset...
[15-12-2018_18-01-23]   [INFO]   Creating a new palette: PAL_DGOOD_ACID
[15-12-2018_18-01-23]   [INFO]   Creating a new palette: PAL_DGOOD_SEA
[15-12-2018_18-01-23]   [INFO]   Creating a new palette: PAL_MARS
[15-12-2018_18-01-23]   [INFO]   Creating a new palette: PAL_MARS_LITE
[15-12-2018_18-01-23]   [INFO]   Making palette backups...
[15-12-2018_18-01-54]   [INFO]   Data loaded successfully.
[15-12-2018_18-01-54]   [INFO]   Loading language...
[15-12-2018_18-01-54]   [INFO]   Language loaded successfully.
[15-12-2018_18-01-54]   [INFO]   OpenXcom started successfully!
[15-12-2018_18-01-55]   [INFO]   Using software scaling routine. For best results, try an OpenGL filter.

I hope you can tell me what to do in this case.

Thank you

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5489
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Bugs, crashes, typos & bad taste
« Reply #1592 on: December 16, 2018, 09:52:28 am »
I hope you can tell me what to do in this case.

Either wait for a new XCF version or if you know how, change the sprite definition:

Code: [Select]
  - type: OOZE.PCK
    subX: 32
    subY: 40
    width: 256
    height: 40     # <------------ this should be 80, not 40
    files:
      0: Resources/Races_Compilation/OozeRace/OOZE.png

Offline Yankes

  • Commander
  • *****
  • Posts: 2142
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1593 on: December 18, 2018, 03:59:06 pm »
Getting a crash.
"There is already TileEngine movingUnit"
Note that I have cheated to raise Guile's Energy and TUs to set this up.

What I think is happening is the Red Dawn ganger is trying to move off the open tile in the upper floor of his building, and landing on top of Guile, and this causes an error somehow.

Edit: It seems the openxcom log is useless as I booted up the game and started playing with it, and this overwrote the crash log. I am sorry.
It will be fixed in next OXCE version.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 8848
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs, crashes, typos & bad taste
« Reply #1594 on: December 18, 2018, 06:01:16 pm »
Re: Underwater Operations: I got the T'Leth Embassy pretty early and because I was in a tight spot I had 1 agent and 3 dogs on board. I don't remember any warnings what would happen to the dogs. I aborted the mission and haven't seen it since.

It's not in the mission description, but the general description of Underwater Operations:

"X-Com has the capacity to conduct undersea missions if necessary. When such a mission occurs, you can get to the scene using your standard transport. A dedicated X-Com 'Calypso' submarine will be provided on site.

Remember that the Calypso can only accommodate up to 7 agents; if you bring more, they will have to sit this assignment out.
Warning: any dogs on this mission will drown!"

Also, I hope to release an update very soon to fix the ooze problem.

Offline FiendishDrWu

  • Sergeant
  • **
  • Posts: 15
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1595 on: December 23, 2018, 09:45:01 pm »
Hi there!  I can't seem to get this to run.  I've downloaded "openxcom_xfiles_0.9.7c.zip".  First issue I'm noticing is that there isn't a file called "OpenXcomExPlus.exe"; merely "OpenXcomEx.exe".  I try that, and things start up normally.  I've tried copying both the UFO and TFTD files into their appropriate folders, and under mods I see both UFO and TFTD as mods, but XComFiles doesn't appear as an option.  I'm ready to conceed I may just be a goober, but is there somewhere else I ought to be looking for the OpenXcomExPlus.exe file other than the top level folder where I unzipped things?   

Offline tkzv

  • Commander
  • *****
  • Posts: 587
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1596 on: December 23, 2018, 11:39:23 pm »
First issue I'm noticing is that there isn't a file called "OpenXcomExPlus.exe"; merely "OpenXcomEx.exe".
It is now the correct name. They've been merged recently.

under mods I see both UFO and TFTD as mods, but XComFiles doesn't appear as an option.
Unlike Piratez it doesn't appear in the drop-down list on top. Instead select UFO and then select "X-Com Files in list of mods below. See the attached picture.

After the mod has been selected, the title screen will display the mod name. See the attached picture.

Offline FiendishDrWu

  • Sergeant
  • **
  • Posts: 15
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1597 on: December 24, 2018, 12:06:45 am »
Aha, there it is.  I feel like a goober.  Thank you, tkzv!

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 8848
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs, crashes, typos & bad taste
« Reply #1598 on: December 24, 2018, 04:43:53 am »
You know, I guess I will make it a master mod as well.

Offline bezimek

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1599 on: December 28, 2018, 09:42:54 am »
Either wait for a new XCF version or if you know how, change the sprite definition:

Code: [Select]
  - type: OOZE.PCK
    subX: 32
    subY: 40
    width: 256
    height: 40     # <------------ this should be 80, not 40
    files:
      0: Resources/Races_Compilation/OozeRace/OOZE.png

Thanks :)  I fix "extraSprites_XCOMFILES.rul"  file using notepad and game works like charm :):)




Offline Alex_D

  • Colonel
  • ****
  • Posts: 290
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1600 on: December 29, 2018, 07:46:11 am »
Hi Solarius,

I'm not sure if this error has been reported before, so it goes again just in case.

Spoiler:
Spawn location on Mummy map. I looked all over the map until the bug hunt showed me this odd location for a Male Tomb Guardian

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 8848
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs, crashes, typos & bad taste
« Reply #1601 on: December 29, 2018, 03:39:47 pm »
Hi Solarius,

I'm not sure if this error has been reported before, so it goes again just in case.

Spoiler:
Spawn location on Mummy map. I looked all over the map until the bug hunt showed me this odd location for a Male Tomb Guardian

That's... weird.
Do you have a save? I honestly can't say much from the minimap.

Offline Alex_D

  • Colonel
  • ****
  • Posts: 290
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1602 on: December 30, 2018, 08:45:07 am »
That's... weird.
Do you have a save? I honestly can't say much from the minimap.

No, sorry. I don't have a save file at this point (I over-wrote it). The unit spawned at the first corner tile of the bottom level. Fortunately I brought some pickaxes and dug an access path. Once that was done, the enemy unit quickly charged me with a sword, but was met with reaction fire from everybody waiting around.

Also I found another missing string, I believe already reported. See screenshot, just in case.

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • ***
  • Posts: 8848
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs, crashes, typos & bad taste
« Reply #1603 on: December 31, 2018, 02:16:48 pm »
Also I found another missing string, I believe already reported. See screenshot, just in case.

Not yet reported. :) Thanks!

Offline Alex_D

  • Colonel
  • ****
  • Posts: 290
    • View Profile
Re: Bugs, crashes, typos & bad taste
« Reply #1604 on: January 01, 2019, 12:25:20 am »
Not yet reported. :) Thanks!

With regard of the viper:
Spoiler:
Finally I got a Reptoid mission where the craft is supposed to be. Then I noticed the craft range is minuscule, it almost requires the mission to be next door from the base where the craft is stationed. Luckily I had a secondary base that was within range, so I transferred the whole craft there. I have yet to play the mission. Is this craft range supposedly to be that short?