Author Topic: 40k  (Read 79326 times)

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1646
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k
« Reply #390 on: June 01, 2018, 08:32:48 pm »
You should start by completely uninstalling the nightly (this is the best way to ensure you don't have bugs from pulling from the wrong data folders), then install the latest version of OXCE+ from this thread, extract it where you want it, and run the included executable.  After that, install this mod as you did before when you got it working on the nightly version.

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 40
    • View Profile
Re: 40k
« Reply #391 on: June 01, 2018, 09:46:32 pm »
I got an error message when I tried to run it.

"C:\PROGRA~1\OPENXCOM>openxcom
DOS/4GW Protected Mode Run-time Version 1.9
Copyright (c) Rational systems, Inc. 1990-1993

ERROR: failed to load `UFO: enemy Unknown / X-Com: UFO Defense`; mod disabled for next startup
GEODATA/WORLD.DAT not found
Make sure you installed OpenXcom correctly
Check the wiki documentation for more details.
"

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1646
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k
« Reply #392 on: June 01, 2018, 09:58:25 pm »
You didn't copy the files from the original game into the UFO folder of the OXCE+ package.

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 40
    • View Profile
Re: 40k
« Reply #393 on: June 01, 2018, 10:56:30 pm »
I copied the X-com: UFO Defense subfolders from SteamApps to the UFO folder, but still got the same error message. (Maybe the Steam version is incompatible?)

Then - I don't know if it was needed - I found a fix with the name Openxcomfolder with two exe files called OpenXcomEx and OpenXcomExPlus35.

The program starts with them but when I select the 40K mod the reloading screen sends an error message saying:

ERROR: vector: :_M_range_check:__n (which is 11) >= this->size() (which is 10)

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1646
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k
« Reply #394 on: June 01, 2018, 11:07:34 pm »
The steam version is no different in the data files, it's what I use for the data files.  I don't know what you're talking about this "fix," OpenXcomEx.exe is the executable file for OXCE+ and therefore what you should be using to run the game.  Did you completely remove everything from the nightly installation before running OXCE+?

Can you upload a copy of the openxcom.log file from when you ran the game?
« Last Edit: June 01, 2018, 11:17:58 pm by ohartenstein23 »

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 40
    • View Profile
Re: 40k
« Reply #395 on: June 03, 2018, 01:30:16 am »
Yessir,
step 1. I removed Nightly completely.
step 2. I extracted OXCE+ (from here https://openxcom.org/forum/index.php/topic,5258.0.html)
step 3. I copied the Steam's UFO subfolders into the OpenXcom UFO folder.
step 4. I ran the exe and got the error message.

I uploaded the log.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 4978
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: 40k
« Reply #396 on: June 03, 2018, 08:44:51 am »
In OpenXcom's UFO folder, do you have a GEODATA subfolder and within it a WORLD.DAT file?

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 40
    • View Profile
Re: 40k
« Reply #397 on: June 03, 2018, 09:17:14 am »
Yes, the WORLD.DAT file is in the GEODATA subfolder.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 4978
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: 40k
« Reply #398 on: June 03, 2018, 09:51:09 am »
Can you provide a screenshot of the OpenXcom root directory and of the UFO subdirectory please?

Offline Lord Flasheart

  • Sergeant
  • **
  • Posts: 40
    • View Profile
Re: 40k
« Reply #399 on: June 03, 2018, 10:23:55 am »
Okay, I think I can claim to be officially an idiot. It was poking my eyes out...The GEODATA subfolder with WORLD.DAT was in the UFO subfolder but it was also in another subfolder called X-com.
Now I removed them all from that unnecessary X-com folder and now it runs perfectly.

Thank you for your patience and help gentlemen!!!



Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 501
    • View Profile
Re: 40k
« Reply #400 on: June 04, 2018, 12:01:50 am »
i guess next releases i got to do the full package with OXCE+ included

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 501
    • View Profile
Re: 40k
« Reply #401 on: June 07, 2018, 11:33:26 pm »
New Fix UP

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1646
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k
« Reply #402 on: June 10, 2018, 01:36:53 am »
Hey bulletdesigner, the assault cannons and autocannons have duplicate dropoff entries, one with dropoff: 5 and another with dropoff: 1, causing behavior to alternate depending on which one is loaded first.  I'm guessing these should all have the standard dropoff: 5?

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 501
    • View Profile
Re: 40k
« Reply #403 on: June 10, 2018, 03:44:58 pm »
Yes the drop shoud be 5 , my mistake

Offline ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1646
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k
« Reply #404 on: June 11, 2018, 12:27:30 am »
For those of you wishing to have more content with the Imperial Guard, check out this newly-released mod!