Author Topic: 40k Bug/crashes/problem´s report  (Read 22750 times)

Offline Viilratha

  • Squaddie
  • *
  • Posts: 1
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #180 on: December 06, 2019, 01:36:22 am »
I just downloaded the newest version of OXCE and your mod.  Initial run of OXCE is fine.  Once I activate the mod though I get the following error:

"ERROR: Error processing 'STR_HEAVY_PLASMA; in manufacture: Manufacturing time must be greater than zero."

I've poked around at some of the files in the ruleset folder but I can't seem to find the section that needs to be fixed.

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 5759
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: 40k Bug/crashes/problem´s report
« Reply #181 on: December 06, 2019, 10:50:23 am »
In 40k.rul

Code: [Select]
  - name: STR_HEAVY_PLASMA
    requires:
      - STR_ALIENS_ONLY
    requiredItems:
      STR_ALIEN_ALLOYS: 40

Either add the time attribute, or even remove the whole thing as it doesn't seem to be used at all.

Offline OmniRed

  • Squaddie
  • *
  • Posts: 1
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #182 on: December 18, 2019, 03:28:37 am »
You need to add the time attribute to
STR_HEAVY_PLASMA
STR_PLASMA_PISTOL
STR_PLASMA_RIFLE

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 534
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #183 on: December 20, 2019, 12:52:06 pm »
it will be corrected on next version. The entry was deleted, but when i added chaos factions to player i forgot to remove the del

Offline Doc

  • Sergeant
  • **
  • Posts: 14
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #184 on: December 31, 2019, 12:45:05 am »
Like some of the previous posters mentioned I'm getting damage to scout marines and bikes when using drop pods, sometimes enough to kill the bikes outright. Is there any way to fix this, or am I using an out of date version?

Online ohartenstein23

  • Moderator
  • Commander
  • ***
  • Posts: 1747
  • Flamethrowers fry cyberdisk circuits
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #185 on: December 31, 2019, 02:44:20 am »
Check the latest version on the mod.io page, I'm pretty sure the bikes getting damaged on drop pod landing has been fixed. Scouts are supposed to take a little bit of damage; power armor is the only way to not be damaged when using drop pods. However, an apothecary or a support servitor is enough to keep your scouts in fine shape even when dropping them.

Offline Doc

  • Sergeant
  • **
  • Posts: 14
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #186 on: December 31, 2019, 11:21:18 am »
Check the latest version on the mod.io page, I'm pretty sure the bikes getting damaged on drop pod landing has been fixed. Scouts are supposed to take a little bit of damage; power armor is the only way to not be damaged when using drop pods. However, an apothecary or a support servitor is enough to keep your scouts in fine shape even when dropping them.

Version 023, the one at the top of the list? Fresh install of that one and it's still happening.

Offline bulletdesigner

  • Moderator
  • Commander
  • ***
  • Posts: 534
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #187 on: December 31, 2019, 04:23:08 pm »
It's corrected but not release yet. Sorry, We have a bunch a
Of stuff prepared for release, but we always do that on a big pack instead of several small ones

Offline Doc

  • Sergeant
  • **
  • Posts: 14
    • View Profile
Re: 40k Bug/crashes/problem´s report
« Reply #188 on: December 31, 2019, 11:16:16 pm »
Oh no problem at all, I appreciate all the work you guys put in to this. Loving the modpack.