aliens

Author Topic: Bugs & Crash Reports  (Read 695840 times)

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #420 on: April 25, 2016, 02:33:31 pm »
Not sure if Meridan's new exe fixed it or the fact that I deleted all TFTD files from the default directory, but now it works!  :)
Thanks for either the fix or the tip!

Offline Asheram

  • Sergeant
  • **
  • Posts: 10
    • View Profile
Re: Bugs & Crash Reports
« Reply #421 on: April 27, 2016, 02:13:37 pm »
Not sure if it has been mentioned but I've had several issues with corpses changing appearance when they are being picked up.
For example, picked up one Mercenary Commando and once it got into my hand it turned into what I believe was an Academy unit

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #422 on: April 27, 2016, 04:45:07 pm »
Not sure if Meridan's new exe fixed it or the fact that I deleted all TFTD files from the default directory, but now it works!  :)
Thanks for either the fix or the tip!

Update: Bug is back, happens when UFO accelerates out of interception screen range and re-enters it OVER WATER. Over land is fine....  :-\

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6838
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #423 on: April 27, 2016, 05:10:15 pm »
Update: Bug is back, happens when UFO accelerates out of interception screen range and re-enters it OVER WATER. Over land is fine....  :-\

It will be fixed with my newest EXE as I said... I just didn't publish it yet, have a little patience :)

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #424 on: April 27, 2016, 05:28:02 pm »
Ok.   :)

Offline Bartojan

  • Colonel
  • ****
  • Posts: 130
    • View Profile
Re: Bugs & Crash Reports
« Reply #425 on: April 27, 2016, 06:49:21 pm »
Duplicates in Pirate.nam:
Code: [Select]
Bloody
Katana
Manta
Mary
Rose
Valkyrie
Vampire
« Last Edit: April 27, 2016, 06:53:09 pm by Bartojan »

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #426 on: April 27, 2016, 09:13:26 pm »
What's up with the Gatling Laser HWP? I brought it on a mission, didn't fire a single burst, and for some reason it lost 55 out of 60 rounds. When I checked the ammo on the inventory screen, it looked like it had brought back only one round from the mission, instead of 5.  :o

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #427 on: April 27, 2016, 10:49:14 pm »
What's up with the Gatling Laser HWP? I brought it on a mission, didn't fire a single burst, and for some reason it lost 55 out of 60 rounds. When I checked the ammo on the inventory screen, it looked like it had brought back only one round from the mission, instead of 5.  :o

Distressing. Save plox, quite impossible to recreate since it can't be tested in Quick Battle.

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #428 on: April 27, 2016, 11:08:25 pm »
Here, just aborting the mission straight away is enough.

As a side note, I tried to fix this by cleaning up the Gatling Laser HWP ruleset entry a bit and matching it to the HMG Cyberdisc's, since I didn't have any ammo problems with that. Didn't work, instead the HWP gained snap and aimed fire modes apparently because I removed the tuSnap: 0 and tuAimed: 0 lines. So instead of defaulting to 0/no snap or aimed modes, it's defaulting to some other values (maybe the vanilla OpenXcom Laser HWP ruleset entry?).

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #429 on: April 27, 2016, 11:12:20 pm »
Yes it defaults to vanilla settings. Also please name saves a bit more creatively in the future, I have at least a dozen bug.sav's ;)

EDIT: okay, fixed. All you have to do is to add clipsize: 60 to STR_TANK_LASER_CANNON weapon entry. A few more tanks had such problem as well, will be fixed in the next ver.
« Last Edit: April 27, 2016, 11:23:04 pm by Dioxine »

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #430 on: April 27, 2016, 11:26:55 pm »
Hehe, I'll keep that in mind. :P And thanks for the fast fix.

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #431 on: April 28, 2016, 12:35:05 am »
Hum, that fix doesn't work for me. Now the tank brings only a single shot to missions...

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #432 on: April 28, 2016, 12:52:36 am »
Try clipsize: 0 maybe?

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #433 on: April 28, 2016, 01:06:32 am »
With clipSize: 0 capacity is correct, but now after a mission the game spawns an extra 60 rounds from thin air... 184 rounds before loading the tank into a transport, 124 rounds after that, and after returning back to base stores show 184 again with the tank still inside the transport. Pulling the tank out adds an extra 60 rounds to a total of 244.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #434 on: April 28, 2016, 01:23:33 am »
hmmm... clipsize: -2? :)