aliens

Author Topic: Bugs & Crash Reports  (Read 744545 times)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5261
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #240 on: March 21, 2016, 02:20:26 pm »
That is a some sort of OXCom bug then, you shouldn't be seeing this message. It means that your flying sub cannot engage an USO if not submerged (flying overland).

Offline ivandogovich

  • Commander
  • *****
  • Posts: 2374
  • X-Com Afficionado
    • View Profile
    • Ivan Dogovich Youtube
Re: Bugs & Crash Reports
« Reply #241 on: March 22, 2016, 01:06:20 am »
Small issue with a CTD with Superslave's rock.   Tosses fine, but CTD on impact.

Possible problem with the impact animation on AUX_ROCK?      hitAnimation: 26


Edit:  (Per Dioxine's response below).  Oops... sorry I didn't search the thread. I should have.  Thanks for the fix.

Quote
2) There's double "damageAlter" declaration in AUX_ROCK. Delete the one withouth FixRadius: 0 command.
« Last Edit: March 22, 2016, 04:29:08 pm by ivandogovich »

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 10205
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #242 on: March 22, 2016, 01:14:09 am »
hitAnimation: 26 is standard for bullets, vanilla as hell... But I can see the damageType: 3 entry under AUX_ROCK, which is explosive. So my guess is that  the game is trying to draw an explosion but it's being overridden by hitanim 26 and therefore it loses its shit, technically speaking.

If I'm right, the solution would be either setting blastRadius to 0 or changing the hitAnimation number. Or changing damageType, of course.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5261
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #243 on: March 22, 2016, 04:13:00 pm »
It's been brought up a few posts ago and fixed already.

Offline ivandogovich

  • Commander
  • *****
  • Posts: 2374
  • X-Com Afficionado
    • View Profile
    • Ivan Dogovich Youtube
Re: Bugs & Crash Reports
« Reply #244 on: March 23, 2016, 02:16:23 am »
Quick Typo find:

      STR_HYDRA_LASER_CLIP_XXX: "Hydra Laser Cip (24x5)"
should be:
Clip

Offline lancev

  • Sergeant
  • **
  • Posts: 11
    • View Profile
Re: Bugs & Crash Reports
« Reply #245 on: March 26, 2016, 06:03:02 pm »
Not sure, that this is the right thread, since the problem is likely my system setup...

The game immediately crashes at startup.
The screen goes black (no error messages etc) and I have to hardcore reset my computer (even ctrl alt delete doenst work).
I tried to reinstall visual c++, but that changes nothing.
Normal openXcom (latest nightly) works fine.
Im using Windows 7 professional.

Any ideas?

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5261
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #246 on: March 26, 2016, 06:08:10 pm »
Not only yours, this exec is compiled on Windows, which apparently isn't compatible with Windows since 2012. Blame Microsoft and seek answers there: https://openxcom.org/forum/index.php/topic,4187.0.html

Offline clownagent

  • Colonel
  • ****
  • Posts: 382
    • View Profile
Re: Bugs & Crash Reports
« Reply #247 on: March 26, 2016, 08:25:23 pm »
I have a reproducible crash to desktop after losing a base defense mission.

In the attached save, the attack will start soon. After losing the game is crashing.

Offline ycom

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #248 on: March 31, 2016, 10:21:11 am »
I'm trying to install Piratez but it's asking for "msvcp140.dll" which I don't have in my original Xcom game folders. Where do I get it?

Offline Cristao

  • Colonel
  • ****
  • Posts: 373
    • View Profile
Re: Bugs & Crash Reports
« Reply #249 on: March 31, 2016, 10:48:33 am »
Solution is in this thread. Read a few pages before this and when it comes to selecting make sure it is the 32 bit version EVEN if you are using 64 bit Windows.

Offline ycom

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #250 on: March 31, 2016, 03:06:42 pm »
Solution is in this thread. Read a few pages before this and when it comes to selecting make sure it is the 32 bit version EVEN if you are using 64 bit Windows.
I went to Microsoft's website and tried to download "Visual C++ Redistributable for Visual Studio 2015" x86 version but the download link just takes me to a page not found error. Hopefully Microsoft hasn't removed the file download because I can't get much farther without it.
Could someone please host a copy of the files on dropbox or something?

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5261
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #251 on: March 31, 2016, 03:09:45 pm »
The next version is compiled on Linux and should cause no such problems. Upload soon.

Offline ycom

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #252 on: April 01, 2016, 03:10:51 pm »
The new version works perfectly thanks.

Offline Dr_Amazing

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #253 on: April 04, 2016, 04:38:04 am »
I'm having problems with the new weapons. Almost all the melee weapons (chainsaw and hammer are ok) have no action for swinging them at an enemy. Even when standing right next to an enemy I can only throw them away. Also some weapons have a 0 TU cost (blackpowder bombs and the crossbow for sure)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5261
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #254 on: April 04, 2016, 10:03:34 am »
Probably fugged up install. Purge all assets, re-install the game.