Author Topic: Bugs & Crash Reports  (Read 695352 times)

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6837
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #465 on: April 30, 2016, 04:52:33 pm »
laser tank still has clipSize = -1, not 0 ... or at least I can't see the change

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #466 on: April 30, 2016, 04:54:03 pm »
ok now with altcorpse fixed, the tester file deleted and the language file replaced, the new version works.... :)

Love the airbus, btw. Nice ufopedia screen!

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #467 on: April 30, 2016, 04:54:41 pm »
where?

Code: [Select]
  - type: STR_TANK_LASER_CANNON
    categories: [STR_BAT_CAT_AUX]
    size: 12
    costSell: 594000
    transferTime: 96
    weight: 1
    bigSprite: 54
    floorSprite: 0
    handSprite: 0
    bulletSprite: 5
    fireSound: 11
    compatibleAmmo:
      - STR_HWP_LASER_CANNON_BATTS
    hitSound: 19
    hitAnimation: 36
    power: 70
    damageType: 4
    accuracySnap: 0
    accuracyAimed: 0
    accuracyAuto: 50
    tuSnap: 0
    tuAimed: 0
    tuAuto: 24
    battleType: 1
    fixedWeapon: true
    invWidth: 2
    invHeight: 3
    turretType: 2
    autoRange: 25
    autoShots: 5
    dropoff: 1
    bulletSpeed: 16
    listOrder: 1240

Offline legionof1

  • Commander
  • *****
  • Posts: 1773
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #468 on: April 30, 2016, 04:59:32 pm »
Somethings gone fishy. STR strings everywhere. Occurring in every armor and gal when i went to new battle to have a peak at the new stuff.

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6837
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #469 on: April 30, 2016, 04:59:56 pm »
inherited from master xcom1

Offline legionof1

  • Commander
  • *****
  • Posts: 1773
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #470 on: April 30, 2016, 05:04:03 pm »
sorry merdian that means nothing to me. Thou i notice now that these are the same strings that had language corruption. Guess overwriting lang from old version did not fully work. i wonder why.

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6837
  • OXCE developer
    • View Profile
    • My Wiki
Re: Bugs & Crash Reports
« Reply #471 on: April 30, 2016, 05:08:17 pm »
Sorry, that was answer to dioxine's question above... the clipSize=-1 is inherited from xcom1 master game ruleset.

As for the language issue, wait for a fix, it's been reported already few posts ago.

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #472 on: April 30, 2016, 05:09:46 pm »
legionof1, overwrite the new language file with the old, it now works fine for me. Just tested it in the Battle generator.
« Last Edit: April 30, 2016, 05:11:47 pm by new_civilian »

Offline legionof1

  • Commander
  • *****
  • Posts: 1773
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #473 on: April 30, 2016, 05:10:36 pm »
i did and that's how i arrived at the strings missing.

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #474 on: April 30, 2016, 05:12:43 pm »
Sorry, not the piratez_lang. rul, the one in the Language folder called en-us.yml

Offline legionof1

  • Commander
  • *****
  • Posts: 1773
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #475 on: April 30, 2016, 05:14:10 pm »
yes the one in the language file.

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #476 on: April 30, 2016, 05:23:46 pm »
Odd, it works for me.  ???

Ok here is what I did:

1. Deleted the tester rul file in the alt-corpses folder
2. corrected the bug in the alt-corpses rul  (file is above^)
3. Replaced the en-us.yml file with the one from the user/mods/piratez/language folder of the d1 version


Offline legionof1

  • Commander
  • *****
  • Posts: 1773
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #477 on: April 30, 2016, 05:27:55 pm »
yep me too. I mean at least its not partial chzech anymore so thats something.

Offline ivandogovich

  • Commander
  • *****
  • Posts: 2374
  • X-Com Afficionado
    • View Profile
    • Ivan Dogovich Youtube
Re: Bugs & Crash Reports
« Reply #478 on: April 30, 2016, 05:50:45 pm »
I'll just chime in Here:   Sorry for all the bugs with Alt -Corpses.   :-[  I tried to get it up with out having a copy of 98e. And doing the work between two computers it looks like I messed up in what I sent to Dioxine. ( One with an old bug, and my tester rul still included.)

Edit:  I've posted an updated version in the Alt-Corpses mod thread.  (Thanks new_civilian for the better rule file!)
« Last Edit: April 30, 2016, 06:12:56 pm by ivandogovich »

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #479 on: April 30, 2016, 06:44:15 pm »
Download the mod once again, I switched to an updated file with no en-US issues. Sorry for that.

@Meridian: ooops... I forgot that not every vanilla tank had Clipsize=0 :)