Author Topic: Bugs & Crash Reports  (Read 695865 times)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #450 on: April 29, 2016, 04:05:57 pm »
You sure they're heading for Death Realms? Or just Australasia? Since the HWD can't tell the country, it only tells you continent/region. Might be a language bug, if so, save or even a picture would be helpful.

Offline Mattdo

  • Sergeant
  • **
  • Posts: 39
    • View Profile
Re: Bugs & Crash Reports
« Reply #451 on: April 29, 2016, 04:09:55 pm »
Are there any other governments in Australasia in this game?

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #452 on: April 29, 2016, 05:08:09 pm »
Pirate Straits, partially?

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #453 on: April 30, 2016, 03:36:21 pm »
Looks like CYBERDISC_ARMOR in Piratez_Armors.rul is missing a lot of entries, corpseBattle and armor values among other things.

Online Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 10162
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #454 on: April 30, 2016, 03:47:29 pm »
Looks like CYBERDISC_ARMOR in Piratez_Armors.rul is missing a lot of entries, corpseBattle and armor values among other things.

Then it certainly inherits them from vanilla CYBERDISC_ARMOR.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #455 on: April 30, 2016, 03:49:10 pm »
Looks like CYBERDISC_ARMOR in Piratez_Armors.rul is missing a lot of entries, corpseBattle and armor values among other things.

So? What is the bug you've spotted? Or did you look under the skirt for no reason? :P
« Last Edit: April 30, 2016, 03:51:14 pm by Dioxine »

Offline jammjammjamm

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #456 on: April 30, 2016, 04:05:59 pm »
I just installed 0.98E in windows, and when I run it, I get an error in Piratez_AltCorpse.rul (yaml-cpp: error at line 725, column 4: end of sequence not found).

So it automatically disables the mod, and when I restart, the language is not English (Czech, maybe?). When I change the language back to English [US], not everything changes. The first time, there were lots of STR_whatever names, including for my funds, so I couldn't see how much money I had (just STR_FUNDS).

I deleted my installation and reinstalled. Same AltCorpses bug. This time when I changed the language back to English, some of the strings are in English, and some aren't. I re-enabled AltCorpses, and got the same error. When I restarted it this time, it's back to the STR_whatever strings.

Offline Hazard

  • Captain
  • ***
  • Posts: 60
    • View Profile
Re: Bugs & Crash Reports
« Reply #457 on: April 30, 2016, 04:07:26 pm »
So? What is the bug you've spotted? Or did you look under the skirt for no reason? :P
I was taking a look because I didn't get any cyberdisc wrecks from a terror mission, even though I thought I met the requirements to get them... But it could well be I didn't kill them in a manner that preserves the wreck. My first thought was that there's something wrong with corpseBattle items.

Online Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 10162
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Bugs & Crash Reports
« Reply #458 on: April 30, 2016, 04:10:15 pm »
I just installed 0.98E in windows, and when I run it, I get an error in Piratez_AltCorpse.rul (yaml-cpp: error at line 725, column 4: end of sequence not found).

So it automatically disables the mod, and when I restart, the language is not English (Czech, maybe?). When I change the language back to English [US], not everything changes. The first time, there were lots of STR_whatever names, including for my funds, so I couldn't see how much money I had (just STR_FUNDS).

I deleted my installation and reinstalled. Same AltCorpses bug. This time when I changed the language back to English, some of the strings are in English, and some aren't. I re-enabled AltCorpses, and got the same error. When I restarted it this time, it's back to the STR_whatever strings.

Have you tried other EN languages?

Offline bluberd

  • Sergeant
  • **
  • Posts: 42
    • View Profile
Re: Bugs & Crash Reports
« Reply #459 on: April 30, 2016, 04:22:08 pm »
I just installed 0.98E in windows, and when I run it, I get an error in Piratez_AltCorpse.rul (yaml-cpp: error at line 725, column 4: end of sequence not found).

So it automatically disables the mod, and when I restart, the language is not English (Czech, maybe?). When I change the language back to English [US], not everything changes. The first time, there were lots of STR_whatever names, including for my funds, so I couldn't see how much money I had (just STR_FUNDS).

I deleted my installation and reinstalled. Same AltCorpses bug. This time when I changed the language back to English, some of the strings are in English, and some aren't. I re-enabled AltCorpses, and got the same error. When I restarted it this time, it's back to the STR_whatever strings.

I have the same problem with .98E on Win10); Czech as default, when switching to English US or UK dates/funds etc look like crap.
Also, same with the AltCorpses, but I just took the mod from .098D1 and works.
A lot of interesting changes in .98E but I guess I stick now to the .98D1 unless someone comes with an idea how to correct the dates.

Offline jammjammjamm

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #460 on: April 30, 2016, 04:23:27 pm »
Have you tried other EN languages?

I just tried all the other EN languages and it's the same. I also tried a few other random languages, and they also seem the same. If I set the language back to the original one it tries (Cesky), then there are no longer any STR_whatever strings. Then when I change the language to something else, any UI element that had a STR_ string now has a Cesky string instead. So in English [US], it's "5 sek" instead of "5 secs", "1 had" for "1 hour", and "1 den" for "1 day", etc.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #461 on: April 30, 2016, 04:31:02 pm »
Try to use /piratez/language en-US.yml file from the previous version. Also restore your old config file. The language system for 'master mods' is quite shitty and looks like I broke it again.

EDIT: I will update links with a corrected version. And can someone PLEASE set up an archive with correct language files (2015-10-29) for all languages? The only good ones I have are EN-US and Czech.
« Last Edit: April 30, 2016, 04:36:11 pm by Dioxine »

Offline jammjammjamm

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: Bugs & Crash Reports
« Reply #462 on: April 30, 2016, 04:40:34 pm »
Try to use /piratez/language en-US.yml file from the previous version. Also restore your old config file.

That fixed it. Thanks!

Offline new_civilian

  • Commander
  • *****
  • Posts: 726
    • View Profile
Re: Bugs & Crash Reports
« Reply #463 on: April 30, 2016, 04:42:46 pm »
Here also the fix for the altcorpse mod. It seems Dioxine used an old version to update. AND please delete the Tester rul file in the altcorpse mod, too, it is unneeded and contains another bug (missing graphic)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5259
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #464 on: April 30, 2016, 04:46:04 pm »
Nah I used an unofficial updated version Ivan linked me yesterday :)