Author Topic: [Ubuntu] Having trouble with the install  (Read 3464 times)

Offline ubai

  • Sergeant
  • **
  • Posts: 22
    • View Profile
[Ubuntu] Having trouble with the install
« on: August 26, 2015, 06:53:55 am »
Hello,

I tried to install the milestone version of OpenXCOM today, but it still seems to be giving me the old version. It says it is 1.0 on the web site, but I am not seeing a "common" folder in /usr/share/local/openxcom and I can't put the UFO data files in my ./local/share/OpenXCOM folder and have them recognized by the game.

Thanks in advance,
Matt

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #1 on: August 26, 2015, 07:05:51 am »
I tried to install the milestone version of OpenXCOM today

there's your problem. the milestone IS 1.0, the old version. you'll want to get the latest revision from github and make that instead. IRC is probably your best bet for a quick solution.

Offline ubai

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #2 on: August 26, 2015, 07:11:35 am »
OK, thanks! I thought 1.0 was all the new stuff. I'll try the github route when I have time.



Offline rcreasey

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #3 on: August 26, 2015, 07:30:35 am »
Let me know if you end up having problems with it detecting your data directory on linux. I was eyeballing this:
https://github.com/SupSuper/OpenXcom/blob/master/src/Engine/CrossPlatform.cpp#L112 [nofollow]

When I was making changes for osx and noticed how incredibly tangled everything was.   I was thinking about making this a set of paths, with a fallback defined as well.

niculinux

  • Guest
Re: [Ubuntu] Having trouble with the install
« Reply #4 on: August 26, 2015, 11:10:46 am »
Dear ubai, have also a look here i think that thread should be pinned up  ::)

Offline ubai

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #5 on: August 27, 2015, 05:00:33 am »
Thanks for the replies! I tried the instructions in https://openxcom.org/forum/index.php/topic,3530.0.html

but I got the following error:
g++ -O2 -Wall -Wextra -rdynamic  -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL   -c -o ../obj/lodepng.o lodepng.cpp
make: g++: Command not found
make: *** [../obj/lodepng.o] Error 127

I may just have to wait until the newer version becomes a milestone, I'm not a Linux expert or anything.

Thanks,
Matt

niculinux

  • Guest
Re: [Ubuntu] Having trouble with the install
« Reply #6 on: August 27, 2015, 03:51:54 pm »
Ubai, in the 1.0 verison ufo game files, along th mods might to be throwen also in the following path:

Code: [Select]
/home/username/.local/share/openxcom/data/
I always put there usin 1.0. Hope may help

Offline hellrazor

  • Commander
  • *****
  • Posts: 2254
  • Deep Ruleset Digger & Bughunter
    • View Profile
    • Github Account
Re: [Ubuntu] Having trouble with the install
« Reply #7 on: August 27, 2015, 06:22:14 pm »
Thanks for the replies! I tried the instructions in https://openxcom.org/forum/index.php/topic,3530.0.html

but I got the following error:
g++ -O2 -Wall -Wextra -rdynamic  -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL   -c -o ../obj/lodepng.o lodepng.cpp
make: g++: Command not found
make: *** [../obj/lodepng.o] Error 127

I may just have to wait until the newer version becomes a milestone, I'm not a Linux expert or anything.

Thanks,
Matt

Your missing a compiler.

apt-get install gcc

should fix this :>

Offline ubai

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #8 on: August 30, 2015, 05:38:11 am »
Thanks for the replies! I tried to install gcc but it says I already have it.

Offline AndO3131

  • Colonel
  • ****
  • Posts: 137
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #9 on: August 30, 2015, 09:58:07 am »
It's a different package. This should help:

apt-get install g++

Offline ubai

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: [Ubuntu] Having trouble with the install
« Reply #10 on: August 31, 2015, 04:29:17 am »
Thanks! That did the trick. :)