Author Topic: Hovering Avenger  (Read 13330 times)

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
Re: Hovering Avenger
« Reply #45 on: August 16, 2015, 03:30:48 am »
try now

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6496
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Hovering Avenger
« Reply #46 on: August 16, 2015, 09:14:09 am »
1/ the functional issue with interceptors staying on place after shooting down UFO is now fixed (or at least I couldn't reproduce anymore)

Fixed. Re-test OK.

2/ there is still a visual issue that some interceptors are exactly over the UFO, but some are visibly some distance from it... I don't care as long as it works, but it looks funny. Visual issue can be seen here: https://youtu.be/3vngZKRhrWg

Fixed with the newest nightly (openxcom_git_master_2015_08_16_0227.zip).

3/ this visual issue (and also the description of the bug in the tracker) reminded me that I also had an issue with skyranger following UFOs which land... the skyranger for some reason didn't start the mission after the UFO landed... and I could reproduce this now also on the newest build

Again I used the same trick with "1 Day" speed, but I have seen it also on much lower speeds (e.g. "5 Min"), there is even a proof somewhere in my LP, but I don't know which episode. Anyway, this video: https://youtu.be/sE7k7foX98s shows the issue... I am doing the same there 3-times, first on "5 Min" speed, then on "1 Hour" speed and lastly on "1 Day" speed. First two speeds correctly result in a mission... but the third speed causes that the mission never starts.

This last issue is not fixed yet.

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
Re: Hovering Avenger
« Reply #47 on: August 16, 2015, 09:57:34 pm »
damn, i was hoping the last two were linked

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2337
  • Developer
    • View Profile
Re: Hovering Avenger
« Reply #48 on: August 18, 2015, 04:27:45 am »
good news everyone!

we're sending your rookies to a ufo landing site to make sure this bug is fixed, so they can all die gloriously in battle!

now, hurry along! you don't want to be late.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 6496
  • Aaand we're back!
    • View Profile
    • My Wiki
Re: Hovering Avenger
« Reply #49 on: August 18, 2015, 10:06:55 am »
All 3 bugs fixed.
(All rookies died in a blaze of glory.)