Author Topic: Yaml libs again. Can anyone HBO?  (Read 2982 times)

Offline KingMob4313

  • Commander
  • *****
  • Posts: 537
  • Never let me down again.
    • View Profile
    • Mod Hub for Equal Terms 2.0
Yaml libs again. Can anyone HBO?
« on: July 03, 2015, 06:09:25 am »
I just had my repo get hosed on git and in trying to fix it, I lost all my work and my deps folder and my repo on the git server. Whooo hooo!

I've spent the last 2 days kicking at boost + yaml + cmake to no avail.  I had it working before but I remember I had to struggle with it for a while to pull it off.

I do have version 1.5.1 to avoid the issues with things changing in 1.5.2 but it still won't go.

Does anyone have a prebuilt yaml-cpp.lib and a yaml-cppd.lib file for 64 bit windows that they could share? I'm at my wits end.


Offline Yankes

  • Commander
  • *****
  • Posts: 2496
    • View Profile
Re: Yaml libs again. Can anyone HBO?
« Reply #1 on: July 03, 2015, 01:02:10 pm »
Why not simply drop src of Yaml as part of project? At least it work for me (with GCC).

Offline winterheart

  • Colonel
  • ****
  • Posts: 180
  • Fellow Squaddie
    • View Profile
Re: Yaml libs again. Can anyone HBO?
« Reply #2 on: July 03, 2015, 05:32:09 pm »
Why not simply drop src of Yaml as part of project? At least it work for me (with GCC).
No, that is not solution.

Does anyone have a prebuilt yaml-cpp.lib and a yaml-cppd.lib file for 64 bit windows that they could share? I'm at my wits end.
There no 64-bit Windows build. As stated here, use Win32.

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2162
    • View Profile
Re: Yaml libs again. Can anyone HBO?
« Reply #3 on: July 04, 2015, 04:26:37 pm »
There no 64-bit Windows build. As stated here, use Win32.
There is, you just can't build it with VS Express (I guess that's obsolete now since you can build it with the new VS Community), don't know who messed with the wiki since it's a lot harder to understand now.

Anyways the pre-built dependencies include everything you should need (both 32-bit and 64-bit):
VS 2010
VS 2013

Offline KingMob4313

  • Commander
  • *****
  • Posts: 537
  • Never let me down again.
    • View Profile
    • Mod Hub for Equal Terms 2.0
Re: Yaml libs again. Can anyone HBO?
« Reply #4 on: July 07, 2015, 04:24:51 am »
There is, you just can't build it with VS Express (I guess that's obsolete now since you can build it with the new VS Community), don't know who messed with the wiki since it's a lot harder to understand now.

Anyways the pre-built dependencies include everything you should need (both 32-bit and 64-bit):
VS 2010
VS 2013

Crap, I am a moron, I just saw that there were vs2013 deps, with 64 bit in there. Works gloriously.