aliens

Author Topic: [BUG] Battlescape AI stuck in a loop  (Read 3529 times)

Offline tw

  • Squaddie
  • *
  • Posts: 3
    • View Profile
[BUG] Battlescape AI stuck in a loop
« on: October 12, 2014, 07:02:38 pm »
Just encountered a game-ending bug. After ending my turn the AI will get stuck in a loop and because it's ironman mode, game over. I tried restarting the game and reloading several times but the bug will occur invariably. I've attached the save file. I'm playing version 1.0. Is there anything I could do to salvage this game?

Offline Arthanor

  • Commander
  • *****
  • Posts: 2488
  • XCom Armoury Quartermaster
    • View Profile
Re: [BUG] Battlescape AI stuck in a loop
« Reply #1 on: October 12, 2014, 08:34:18 pm »
hum.. Not really a solution, but maybe a hack to allow you to keep going:

Do you have save scumming turned on in the options? If not, turn it on. Often it is possible to get the AI to do something else (shoot instead of grenades, move somewhere else, etc.), which may avoid getting in the situation where the bug happens.

Offline tw

  • Squaddie
  • *
  • Posts: 3
    • View Profile
Re: [BUG] Battlescape AI stuck in a loop
« Reply #2 on: October 12, 2014, 08:41:02 pm »
hum.. Not really a solution, but maybe a hack to allow you to keep going:

Do you have save scumming turned on in the options? If not, turn it on. Often it is possible to get the AI to do something else (shoot instead of grenades, move somewhere else, etc.), which may avoid getting in the situation where the bug happens.

Hey, that actually helped. Had to save and abandon during enemy turn and then reload with save scumming on. Pretty nasty bug though and lost some dudes for nothing.

Edit: Or not... It seems that there's a Silacoid that refuses to do anything. The game is over unless I can somehow edit the savefile.

Edit 2: Unit id 1000015 (STR_SILACOID_TERRORIST) caused the bug. I managed to fix the save by changing its status to 6 (which I presume is dead).
« Last Edit: October 12, 2014, 09:11:24 pm by tw »

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2333
  • Developer
    • View Profile
    • Email
Re: [BUG] Battlescape AI stuck in a loop
« Reply #3 on: October 13, 2014, 04:18:09 am »
this was fixed some time ago in the nightly build.