Author Topic: >>std::bad_alloc<<  (Read 1821 times)

Offline CityLight

  • Sergeant
  • **
  • Posts: 17
    • View Profile
>>std::bad_alloc<<
« on: June 24, 2014, 05:36:55 pm »
Crash


OpenXcom Error Message

std::bad_alloc


[24-06-2014 16:19:44]   [INFO]   Options loaded successfully.
[24-06-2014 16:19:44]   [INFO]   SDL initialized successfully.
[24-06-2014 16:19:45]   [INFO]   SDL_mixer initialized successfully.
[24-06-2014 16:19:45]   [INFO]   Attempting to set display to 1680x1050x8...
[24-06-2014 16:19:45]   [INFO]   Display set to 1680x1050x8.
[24-06-2014 16:19:45]   [INFO]   Loading ruleset...
[24-06-2014 16:19:46]   [INFO]   Ruleset loaded successfully.
[24-06-2014 16:19:46]   [INFO]   Loading resources...
[24-06-2014 16:19:46]   [INFO]   Loading extra resources from ruleset...
[24-06-2014 16:19:46]   [INFO]   Resources loaded successfully.
[24-06-2014 16:19:46]   [INFO]   Loading language...
[24-06-2014 16:19:46]   [INFO]   Language loaded successfully.
[24-06-2014 16:19:46]   [INFO]   OpenXcom started successfully!
[24-06-2014 16:19:46]   [INFO]   Playing flx, 320x200, 890 frames
[24-06-2014 16:19:47]   [INFO]   Using software scaling routine. For best results, try an OpenGL filter.
[24-06-2014 16:31:50]   [INFO]   Attempting to set display to 640x480x8...
[24-06-2014 16:31:50]   [INFO]   Display set to 640x480x8.
[24-06-2014 16:32:03]   [INFO]   Attempting to set display to 640x480x8...
[24-06-2014 16:32:03]   [INFO]   Display set to 640x480x8.
[24-06-2014 16:33:14]   [FATAL]   std::bad_alloc
« Last Edit: June 24, 2014, 05:50:41 pm by CityLight »

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2148
    • View Profile
Re: >>std::bad_alloc<<
« Reply #1 on: June 24, 2014, 11:32:09 pm »
Do you have more details? Like what exactly were you doing when the game crashed, is it reproducible, etc.

Offline CityLight

  • Sergeant
  • **
  • Posts: 17
    • View Profile
Re: >>std::bad_alloc<<
« Reply #2 on: June 25, 2014, 01:42:52 am »